Subject: Re: [Editorial Errata Reported] RFC7540 (4720)

From: Mark Nottingham <[email-masked]>
Date: Thu, 28 Jul 2016 15:59:28 +0200

I think this is APPROVE.

> On 27 Jun 2016, at 8:46 AM, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC7540,
> "Hypertext Transfer Protocol Version 2 (HTTP/2)".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=7540&eid=4720
> 
> --------------------------------------
> Type: Editorial
> Reported by: Kazu Yamamoto <[email-masked]>
> 
> Section: 8.2.1
> 
> Original Text
> -------------
> Pushed responses are always associated with an explicit request from
> the client.  The PUSH_PROMISE frames sent by the server are sent on
> that explicit request's stream. 
> 
> Corrected Text
> --------------
> Promised requests are always associated with an explicit request from
> the client.  The PUSH_PROMISE frames sent by the server are sent on
> that explicit request's stream. 
> 
> Notes
> -----
> This section talks about promised requests, not pushed responses.
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC7540 (draft-ietf-httpbis-http2-17)
> --------------------------------------
> Title               : Hypertext Transfer Protocol Version 2 (HTTP/2)
> Publication Date    : May 2015
> Author(s)           : M. Belshe, R. Peon, M. Thomson, Ed.
> Category            : PROPOSED STANDARD
> Source              : Hypertext Transfer Protocol Bis APP
> Area                : Applications
> Stream              : IETF
> Verifying Party     : IESG
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 28 Jul 2016 16:27:35 +0200

I *think* the clear intent is as is suggested, and it was just an editorial slip. Martin?

> On 28 Jul 2016, at 4:25 PM, Ben Campbell <[email-masked]> wrote:
> 
> Is this really just editorial?
> 
> On 28 Jul 2016, at 8:59, Mark Nottingham wrote:
> 
>> I think this is APPROVE.
>> 
>>

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 28 Jul 2016 09:25:12 -0500

---

From: Martin Thomson <[email-masked]>
Date: Sun, 31 Jul 2016 23:30:24 +0200

It is - in my view - ok in the original, but much more precise in the
revised/proposed form.