Subject: draft-montenegro-httpbis-h2ot-00

From: <[email-masked]>
Date: Sun, 17 Jul 2016 15:52:29 +0000

Hi Gab,

I like the draft because it initiates a discussion that can't be avoided as TCP might not be the mainstream for the transport of HTTP in the future.

Multicast is a transport property requested by many IoT scenario. HTTP2 is not well designed for such cases. Are they out of scope of the mainstream approach?

Are the scenarios where the 'mainstream is the best option' constrained by low-power consumption ?

Regards
Emile

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Gabriel Montenegro <[email-masked]>
Date: Tue, 19 Jul 2016 16:13:46 +0000

Hi Emile, thanks for your comments.

A typical use of multicast is for either discovery or routing. If discovery, that would be handled via mDNS as is already done in some IoT scenarios, instead of overloading the application transport protocol to also fulfill that function. Routing also would use a different protocol, not HTTP/2. As for applications that require multicast, it is a bit complex, yes, as currently http/2 does not support multicast. There was some effort a long time ago to specify that (https://tools.ietf.org/html/draft-goland-http-udp) so one could consider going that path. However, I would caution against the security issues that raises (e.g., TLS won't handle multicast either even though there were some initial ideas that were being discussed in DICE WG for DTLS). 

Power consumption is difficult to assess. Mainstream protocols may be somewhat more inefficient than purpose-built protocols. The point is that if it’s a difference of 10 or 20%, that may not be relevant after some time to counteract advances in efficiency of implementations, or tradeoffs of knowledge, trained people, etc. Furthermore, there are examples of hw support appearing for mainstream protocols (e.g., for mdns) which would not be available for other discovery protocols.  This is another reason mainstream protocols may end up being more efficient.