Subject: Client Hints to Experimental

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Aug 2016 14:12:34 +1000

As discussed in Berlin <https://github.com/httpwg/wg-materials/blob/gh-pages/ietf96/minutes.md#client-hints>, Ilya is cleaning up the last few issues on the Client Hints spec, and it's waiting on Fetch integration.

However, we still only have implementation in Blink-based browsers; so far we haven't seen substantial interest in implementing this by other browsers.

Given that this feature needs broad adoption by browsers to be really useful, this is concerning. After some discussion with Patrick and Ilya, I'd like to suggest that we change the Intended Status for this spec to Experimental, since this seems to fall into guideline 4 at <https://www.ietf.org/iesg/informational-vs-experimental.html>. As an Experimental spec, it would be a document of how Blink is doing this, and if their deployment encourages other implementations, we can shift it to Standards Track later on.

What do people think? Please give feedback on the list and/or at <https://github.com/httpwg/http-extensions/issues/224>.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 18 Aug 2016 10:04:45 +1000

OK, let's go ahead and do this. Ilya, please flip the bit in the draft's header when you publish the next update; I'll update datatracker.

Regards,

> On 10 Aug 2016, at 2:12 PM, Mark Nottingham <[email-masked]> wrote:
>

---

From: Ilya Grigorik <[email-masked]>
Date: Thu, 18 Aug 2016 21:37:53 -0700

Will do, thanks Mark!