Subject: Fwd: New Version Notification for draft-nottingham-httpbis-retry-00.txt

From: Mark Nottingham <[email-masked]>
Date: Thu, 11 Aug 2016 14:07:53 +1000

I've tried to summarise where I think the discussion of retry / replay behaviour is for HTTP in this draft. 

Note that it's just a talk piece, not intended for publication as an RFC; if it goes well, we can start to develop the different ideas in Section 4.

A pretty, more readable version is at:
  https://mnot.github.io/I-D/httpbis-retry/

Feedback very welcome, and thanks to everyone who's given input already (whether you knew it or not :)

Cheers,

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-nottingham-httpbis-retry-00.txt
> Date: 11 August 2016 at 2:04:30 PM AEST
> To: "Mark Nottingham" <[email-masked]>
> 
> 
> A new version of I-D, draft-nottingham-httpbis-retry-00.txt
> has been successfully submitted by Mark Nottingham and posted to the
> IETF repository.
> 
> Name:		draft-nottingham-httpbis-retry
> Revision:	00
> Title:		Retrying HTTP Requests
> Document date:	2016-08-11
> Group:		Individual Submission
> Pages:		16
> URL:            https://www.ietf.org/internet-drafts/draft-nottingham-httpbis-retry-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-nottingham-httpbis-retry/
> Htmlized:       https://tools.ietf.org/html/draft-nottingham-httpbis-retry-00
> 
> 
> Abstract:
>   HTTP allows requests to be automatically retried under certain
>   circumstances.  This draft explores how this is implemented,
>   requirements for similar functionality from other parts of the stack,
>   and potential future improvements.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Daniel Stenberg <[email-masked]>
Date: Thu, 11 Aug 2016 08:28:34 +0200 (CEST)

> (whether you knew it or not :)

Not that it adds much, but curl uses an algorithm similar to Chromium's it 
seems: it retries everything if the connection is reused and not a single byte 
had been received when it broke.

https://github.com/curl/curl/blob/master/lib/transfer.c#L1892

-- 

  / daniel.haxx.se

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 12 Aug 2016 11:08:07 +1000

Included; thanks!

> On 11 Aug 2016, at 4:28 PM, Daniel Stenberg <[email-masked]> wrote:
> 
> Not that it adds much, but curl uses an algorithm similar to Chromium's it seems: it retries everything if the connection is reused and not a single byte had been received when it broke.
>