Subject: [Technical Errata Reported] RFC7230 (4838)

From: RFC Errata System <[email-masked]>
Date: Sat, 22 Oct 2016 16:10:45 -0700 (PDT)

The following errata report has been submitted for RFC7230,
"Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7230&eid=4838

--------------------------------------
Type: Technical
Reported by: Etan Kissling <[email-masked]>

Section: 4

Original Text
-------------
   Parameters are in the form of a name or name=value pair.

     transfer-parameter = token BWS "=" BWS ( token / quoted-string )

Corrected Text
--------------
   Parameters are in the form of a name or name=value pair.

     transfer-parameter = token 
                        / token BWS "=" BWS ( token / quoted-string )

Notes
-----
The form of a name cannot be represented with the original ABNF.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7230 (draft-ietf-httpbis-p1-messaging-26)
--------------------------------------
Title               : Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
Publication Date    : June 2014
Author(s)           : R. Fielding, Ed., J. Reschke, Ed.
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Julian Reschke <[email-masked]>
Date: Sun, 23 Oct 2016 10:12:23 +0200

On 2016-10-23 01:10, RFC Errata System wrote:
> ...

That's true, but that doesn't mean it's an erratum. If's defined this 
way intentionally, and also hasn't changed compared to RFC 2616.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Sun, 23 Oct 2016 11:32:33 +0200

On 2016-10-23 10:27, Etan Kissling wrote:
> Thanks for the quick response :-)
>
> I'm a bit confused now: Is the form "transfer-parameter = token" allowed
> as the test suggests,
> or is it disallowed as the ABNF suggests?
>
> Thanks
>
> Etan

Ah, I see - only processed half of the erratum.

Indeed, the spec is inconsistent, and the text is wrong. It needs to say:

"Parameters are in the form of name=value pairs."

Best regards, Julian

-- 
<green/>bytes GmbH, Hafenweg 16, D-48155 Münster, Germany
Amtsgericht Münster: HRB5782

---

From: Etan Kissling <[email-masked]>
Date: Sun, 23 Oct 2016 08:28:08 +0000

I'm a bit confused now: Is the form "transfer-parameter = token" allowed as the test suggests,
or is it disallowed as the ABNF suggests?

Thanks

Etan

> On 23 Oct 2016, at 10:12, Julian Reschke <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> http://www.rfc-editor.org/errata_search.php?rfc=7230&eid=4838 <http://www.rfc-editor.org/errata_search.php?rfc=7230&eid=4838>
>> 
> That's true, but that doesn't mean it's an erratum. If's defined this way intentionally, and also hasn't changed compared to RFC 2616.
> 
> Best regards, Julian