Subject: [Technical Errata Reported] RFC7230 (4839)

From: RFC Errata System <[email-masked]>
Date: Sun, 23 Oct 2016 03:28:18 -0700 (PDT)

The following errata report has been submitted for RFC7230,
"Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7230&eid=4839

--------------------------------------
Type: Technical
Reported by: Etan Kissling <[email-masked]>

Section: 4

Original Text
-------------
   Parameters are in the form of a name or name=value pair.

     transfer-parameter = token BWS "=" BWS ( token / quoted-string )

Corrected Text
--------------
   Parameters are in the form of a name=value pair.

     transfer-parameter = token BWS "=" BWS ( token / quoted-string )

Notes
-----
The ABNF does not allow the form of a name.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7230 (draft-ietf-httpbis-p1-messaging-26)
--------------------------------------
Title               : Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
Publication Date    : June 2014
Author(s)           : R. Fielding, Ed., J. Reschke, Ed.
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 26 Oct 2016 16:38:12 +1100

Verified.

(This seems to have slipped into one of the very last drafts of the bis process without being noticed; see <https://tools.ietf.org/wg/httpbis/trac/changeset/2519>).

Cheers,

> On 23 Oct. 2016, at 9:28 pm, RFC Errata System <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/