Subject: Fwd: New Version Notification for draft-ietf-httpbis-cache-digest-01.txt

From: Mark Nottingham <[email-masked]>
Date: Tue, 1 Nov 2016 10:51:26 +1100

[ editor hat ]

This revision explicitly conveys the origin which is the scope of CACHE_DIGEST. Note that there's still some discussion of alternative scoping:
  https://github.com/httpwg/http-extensions/issues/216

Based on discussion, I think we can close the 'Digest Algorithm' issue <https://github.com/httpwg/http-extensions/issues/228> with no action, because we don't have a suitable non-cryptographic digest available for reference. Anyone disagree?
  
See remaining open issues here:
  https://github.com/httpwg/http-extensions/issues?q=is%3Aissue+label%3Acache-digest+is%3Aopen

Another question that the WG should consider is whether we publish this as Standards Track or Experimental. Based on the level of interest I've seen so far from browsers, Experimental might be more appropriate. Thoughts?

Cheers,

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-ietf-httpbis-cache-digest-01.txt
> Date: 1 November 2016 at 10:44:02 am AEDT
> To: "Mark Nottingham" <[email-masked]>, "Kazuho Oku" <[email-masked]>
> 
> 
> A new version of I-D, draft-ietf-httpbis-cache-digest-01.txt
> has been successfully submitted by Mark Nottingham and posted to the
> IETF repository.
> 
> Name:		draft-ietf-httpbis-cache-digest
> Revision:	01
> Title:		Cache Digests for HTTP/2
> Document date:	2016-11-01
> Group:		httpbis
> Pages:		10
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-httpbis-cache-digest-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-httpbis-cache-digest/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-httpbis-cache-digest-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-httpbis-cache-digest-01
> 
> Abstract:
>   This specification defines a HTTP/2 frame type to allow clients to
>   inform the server of their cache's contents.  Servers can then use
>   this to inform their choices of what to push to clients.
> 
> Note to Readers
> 
>   Discussion of this draft takes place on the HTTP working group
>   mailing list ([email-masked]), which is archived at
>   https://lists.w3.org/Archives/Public/ietf-http-wg/ .
> 
>   Working Group information can be found at http://httpwg.github.io/ ;
>   source code and issues list for this draft can be found at
>   https://github.com/httpwg/http-extensions/labels/cache-digest .
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 1 Nov 2016 13:30:02 +0900

2016-11-01 8:51 GMT+09:00 Mark Nottingham <[email-masked]>:
> [ editor hat ]
>
> This revision explicitly conveys the origin which is the scope of
> CACHE_DIGEST. Note that there's still some discussion of alternative
> scoping:
> Based on discussion, I think we can close the 'Digest Algorithm' issue
> <https://github.com/httpwg/http-extensions/issues/228> with no action,
> because we don't have a suitable non-cryptographic digest available for
> reference. Anyone disagree?
>
> Another question that the WG should consider is whether we publish this as
> Standards Track or Experimental. Based on the level of interest I've seen so
> far from browsers, Experimental might be more appropriate. Thoughts?

I also think that going to Experimental might be a good idea, for the
following two reasons:

Reason 1: without some kind of standard it is hard to use cache
digests on the public internet, since it is hard to negotiate which
draft version should be used. Note that a cache-digest frame is
typically included in the first flight.

Reason 2: even if browsers do not support cache-digests, a variant
(using HTTP headers) can be implemented using ServiceWorkers. Having a
standard format defined as an RFC would help us gain interoperability
between implementations using ServiceWorkers.

> URL:
> https://www.ietf.org/internet-drafts/draft-ietf-httpbis-cache-digest-01.txt
> Status:
> https://datatracker.ietf.org/doc/draft-ietf-httpbis-cache-digest/
> Htmlized:
> https://tools.ietf.org/html/draft-ietf-httpbis-cache-digest-01
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-httpbis-cache-digest-01
>
> Abstract:

-- 
Kazuho Oku