Subject: draft-ietf-httpbis-encryption-encoding-04, "4.1 Encryption of a Response"

From: Julian Reschke <[email-masked]>
Date: Tue, 1 Nov 2016 12:15:21 +0100

<https://greenbytes.de/tech/webdav/draft-ietf-httpbis-encryption-encoding-04.html#rfc.section.4.1>:

"Here, a successful HTTP GET response has been encrypted using input 
keying material that is identified by the string “a1”."

However, a1 doesn't appear in the example...

Best regards, Julian

---

From: Martin Thomson <[email-masked]>
Date: Wed, 2 Nov 2016 12:13:55 +1100

On 1 November 2016 at 22:15, Julian Reschke <[email-masked]> wrote:
> "Here, a successful HTTP GET response has been encrypted using input keying
> material that is identified by the string “a1”."
>

Thanks for catching that.  I redid the examples in a bit of a hurry
after someone pointed out that my code had an error.

  https://github.com/httpwg/http-extensions/pull/259

As you pointed out privately, the record size field is crazy.  I'll
have to look at my tests again to see if I've messed something up
there.