Subject: Client hints: Add support for hinting Display Gamut / Color Profile

From: "Gunther, Brunner" <[email-masked]>
Date: Tue, 08 Nov 2016 08:54:06 +0000

Hi, my name is Gunther Brunner and I work for CyberAgent, Ltd.
We are building a real-time image processing service.

I would like to discuss adding client hints support for the following Display related Header Fields:

Viewport-Color-Gamut
https://drafts.csswg.org/mediaqueries-4/#color-gamut <https://drafts.csswg.org/mediaqueries-4/#color-gamut>
Viewport-Color-Profile
https://www.w3.org/TR/css-color-4/#at-ruledef-profile <https://www.w3.org/TR/css-color-4/#at-ruledef-profile>

The reason for this request is that recently, there has been a huge market increase in Displays that are non-sRGB (In particular DCI-P3 and AdobeRGB displays).

As an example: iPhone 7, Galaxy S7, MacBook Pro, Surface Studio, all of them support DCI-P3 wide color.

However since the “color-gamut” it’s a display thing the only way to detect for wide-color support from server side would be Client Hints since its not even possible with UA-sniffing (for most cases).

I know the spec is past WGLC, 
but still would like to discuss this further, and its feasibility.

Thank you.

Regards,
Gunther Brunner

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 21 Nov 2016 14:54:34 +1100

Hi Gunther,

Thanks for bringing it up. 

What do people think about this? Note the discussion on the issue Gunther raised:
  https://github.com/httpwg/http-extensions/issues/263

My .02 -- If we're not sure that we can get this into the spec quickly, it may make more sense to do it as a separate draft. It doesn't need to be in the same draft as CH; putting the headers you see there together was only for convenience.

Cheers,

> On 8 Nov. 2016, at 7:54 pm, Gunther, Brunner <[email-masked]> wrote:
> 
> https://drafts.csswg.org/mediaqueries-4/#color-gamut
> 
> Viewport-Color-Profile
> https://www.w3.org/TR/css-color-4/#at-ruledef-profile
> 
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 21 Nov 2016 08:05:52 +0100

> My .02 -- If we're not sure that we can get this into the spec quickly, it may make more sense to do it as a separate draft. It doesn't need to be in the same draft as CH; putting the headers you s…

+1 for not including at this point.

Best regards, Julian

---

From: Ilya Grigorik <[email-masked]>
Date: Mon, 21 Nov 2016 11:10:31 -0800

Separate draft sounds reasonable to me too.

On Sun, Nov 20, 2016 at 11:05 PM, Julian Reschke <[email-masked]>
wrote:

>> My .02 -- If we're not sure that we can get this into the spec quickly,
>> it may make more sense to do it as a separate draft. It doesn't need to be
>> in the same draft as CH; putting the headers you see there together was
>> only for convenience.
>>
>> Cheers,
>>
>