Subject: aes128gcm: is the 1st example wrong?

From: "Manger, James" <[email-masked]>
Date: Tue, 17 Jan 2017 02:26:54 +0000

I cannot replicate the 1st example in draft-ietf-httpbis-encryption-encoding <https://github.com/httpwg/http-extensions/blob/master/draft-ietf-httpbis-encryption-encoding.md>. Can anyone confirm if it is correct? I can confirm that the 2nd example decrypts correctly.

(all quantities are base64url-encoding of the actual byte arrays)

IKM = B33e_VeFrOyIHwFTIfmesA
salt = sJvlboCWzB5jr8hI_q9cOQ

Draft gives:
PRK = MLAQxt_DHjM15cdlyU1oUnjq7TFlzToGTkdRmvvxVBw

But I get:
PRK = Mg9ErPx3DpJfkz72kj7Yvx369iqvd4Fmf7tOMTdXELo

--
James Manger

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Jan 2017 16:16:08 +1300

> PRK = Mg9ErPx3DpJfkz72kj7Yvx369iqvd4Fmf7tOMTdXELo

Ahh, so do I.  Strange.  I ran those examples many times.  And I even
have unit tests against them....

...except that the unit test has the key "6Aqf1aDH8lSxLyCpoCnAqg",
which I expect will work for you.  Fixed it in 622f21d.