Subject: RE: Change to padding in encryption -- examples look ok

From: "Manger, James" <[email-masked]>
Date: Tue, 31 Jan 2017 07:01:55 +0000

Martin Thomson wrote:
> Based on the discussion thus far, I've put together a PR that changes how padding works.
> https://github.com/httpwg/http-extensions/pull/283

The 2 main examples in the PR are correct according to my implementation (https://id.cto.telstra.com/2017/aes128gcm).

Typos:
* In "JWE Mapping", "leading padding" should now be "trailing padding".
* In "JWE Mapping", the nonce looks wrong; I guess it should be .Bcs8gkIRKLI8GeI8. to match the #explicit example.
* In #aes128gcm, drop "a" from "octet a value of 1".

--
James Manger

---

From: Martin Thomson <[email-masked]>
Date: Tue, 31 Jan 2017 18:12:39 +1100

Thanks for confirming so quickly James.  I've corrected the nits.