Subject: Re: draft-ietf-httpbis-encryption-encoding-08, Relaxing UTF-8 requirement for `keyid`

From: Martin Thomson <[email-masked]>
Date: Sat, 25 Mar 2017 16:51:11 -0500

The requirement is already relaxed, it's a SHOULD.  I don't see that
as a problem in this case.

On 23 March 2017 at 13:03, Kit Cambridge <[email-masked]> wrote:
> Hi,
>
> In
> https://tools.ietf.org/html/draft-ietf-httpbis-encryption-encoding-08#section-2.1,
> the `keyid` parameter is defined to be a UTF-8 encoded string. However,
> https://webpush-wg.github.io/webpush-encryption uses the `keyid` to encode
> the sender's ephemeral DH public key.
>
> Given that this field can be used to carry any kind of keying info, I'm
> wondering if we might relax the UTF-8 requirement.
>
> Cheers,
> - kit

---

From: Kit Cambridge <[email-masked]>
Date: Thu, 23 Mar 2017 18:04:30 +0000

Hi,

In https://tools.ietf.org/html/draft-ietf-httpbis-encryption-encoding-08#section-2.1 <https://tools.ietf.org/html/draft-ietf-httpbis-encryption-encoding-08#section-2.1>, the `keyid` parameter is defined to be a UTF-8 encoded string. However, https://webpush-wg.github.io/webpush-encryption <https://webpush-wg.github.io/webpush-encryption> uses the `keyid` to encode the sender's ephemeral DH public key.

Given that this field can be used to carry any kind of keying info, I'm wondering if we might relax the UTF-8 requirement.

Cheers,
- kit

---

From: Julian Reschke <[email-masked]>
Date: Wed, 29 Mar 2017 10:16:56 +0200

> as a problem in this case.

...wait. You're putting a key into a field that is defined to be a key *id*?

This really sounds like a disconnect between these two drafts. :-)

Best regards, Julian