Subject: Is a payload always a representation?

From: "Yi, EungJun" <[email-masked]>
Date: Mon, 27 Mar 2017 17:34:28 +0000

Hi all,

RFC 7231 says:

> 3.3.  Payload Semantics
>
>    Some HTTP messages transfer a complete or partial representation as
>    the message "payload".

Is the converse also true? In other words, is a payload in an HTTP message
always a complete or partial representation?

"3.1.4.1.  Identifying a Representation" defines what an unidentified
payload
is. Is the unidentified payload also a complete or partial representation?

If an unidentified payload is also a representation, it reflects a state of
a
resource. Does the resource have no uri or have one that we don't know?

Best regards,
EungJun

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 27 Mar 2017 12:50:10 -0500

> On Mar 27, 2017, at 12:34 PM, Yi, EungJun <[email-masked]> wrote:
> 
> Hi all,
> 
> RFC 7231 says:
> 
> > 3.3.  Payload Semantics
> > 

Yes, but not necessarily a representation of the resource identified by the request-target.

> "3.1.4.1.  Identifying a Representation" defines what an unidentified payload
> If an unidentified payload is also a representation, it reflects a state of a

One (or many) that we don't know.

....Roy

---

From: "Yi, EungJun" <[email-masked]>
Date: Tue, 28 Mar 2017 17:29:23 +0000

Thanks for the clarification, Roy!