Subject: HTTP Request Media Query Headers for HTTP2 Push hinting

From: Bobby Mozumder <[email-masked]>
Date: Mon, 10 Apr 2017 23:17:56 -0400

Hi,

I’ve been using HTTP/2 push for a bit now, mostly for font push, and it’s been great.  I’m now trying to expand on other resources to push, including images.

Right now, it seems like an impossible task with the HTML PICTURE element, where we don’t know which sizes/format of an image that a client would need.  The HTML PICTURE element provides a list of all sorts of possible sizes/resolutions/formats of a single image, and the client picks one of them to download based on window height/width & browser capabilities.

Would it be possible to add standard HTTP request headers to indicate to the server the client media capabilities - resolution, size, etc..?  This is then complicated by the fact that the browser might change its client window size, or some items might already be cached.

Thank you,

-bobby

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 11 Apr 2017 13:42:33 +1000

Hi Bobby,

It sounds like you're looking for this:
  http://httpwg.org/http-extensions/client-hints.html

Cheers,

> On 11 Apr 2017, at 1:17 pm, Bobby Mozumder <[email-masked]> wrote:
> 
> Hi,
> 

--
Mark Nottingham   https://www.mnot.net/