Subject: Question regarding the Cache Digest feature

From: Simeon Frid <[email-masked]>
Date: Tue, 16 May 2017 15:53:44 +0000

Hi,

I have a question regarding how this feature will work on the client-side. From reading the work document I don't quite understand whether this will support invalidating a client asset, even if it has not expired in the client resource cache (i.e. doing a cache bust from the server).

I'm absolutely new to standard works and am probably not using the correct terminology, but I'll try to explain: Let's say a client sends a cache digest including an asset X, and the server responds: "Your asset X is stale". My question is whether the client will then update asset X, even if asset X is fresh according to the client's resource cache.

If this mechanism works as I'm thinking, this feature could be used as an alternative to URL cache busting (invalidating a fresh client-cached resource by renaming the resource URL from the server-side). Is that a correct assumption?

Kindly,
Simeon

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 17 May 2017 19:00:24 +1000

Hi Simeon,

That's not part of the current design; we don't specify a way for the server to tell the client that a stored response is stale outside the context of a request.

You *could* do this with server push, but that hasn't been specified to such a level of detail. Doing that is something we've discussed in the past. See thread starting here:
  http://www.w3.org/mid/[email-masked]

Cheers,

> On 17 May 2017, at 1:53 am, Simeon Frid <[email-masked]> wrote:
> 
> Hi,
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Simeon Frid <[email-masked]>
Date: Wed, 17 May 2017 14:52:37 +0000

Thanks a lot!

Kindly,
Simeon

ons 17 maj 2017 kl 11:00 skrev Mark Nottingham <[email-masked] <mailto:[email-masked]>>:
Hi Simeon,

You *could* do this with server push, but that hasn't been specified to such a level of detail. Doing that is something we've discussed in the past. See thread starting here:
  http://www.w3.org/mid/[email-masked] <http://www.w3.org/mid/[email-masked]>

Cheers,

> On 17 May 2017, at 1:53 am, Simeon Frid <[email-masked] <mailto:[email-masked]>> wrote:
>
> Hi,
>

--
Mark Nottingham   https://www.mnot.net/ <https://www.mnot.net/>