Subject: draft-ietf-httpbis-header-compression-latest, "2.3.2 Dynamic Table"

From: "[email-masked]" <[email-masked]>
Date: Wed, 14 Jun 2017 02:56:05 +0000

<https://http2.github.io/http2-spec/compression.html#rfc.section.2.3.2 <https://http2.github.io/http2-spec/compression.html#rfc.section.2.3.2>>:

Hi,

Good day!

I have a question about the section "The encoder decides how to update the dynamic table and as such can control how much memory is used by the dynamic table. To limit the memory requirements of the decoder, the dynamic table size is strictly bounded (see Section 4.2 <https://http2.github.io/http2-spec/compression.html#maximum.table.size>).”

the decision about how to update the dynamic table is from “encoder” or “decoder”? I thought it is decoder.

Please correct me if it is not :)

Best Regards,

Okis Chuang
TREND MICRO EMAIL NOTICE
The information contained in this email and any attachments is confidential 
and may be subject to copyright or other intellectual property protection. 
If you are not the intended recipient, you are not authorized to use or 
disclose this information, and we request that you notify us by reply mail or
telephone and delete the original message from your mail system.

---

From: Mike Bishop <[email-masked]>
Date: Wed, 14 Jun 2017 17:58:04 +0000

The decoder sets a maximum size.  The encoder can select the size it wishes to actually use, so long as it’s not greater than the decoder’s limit.  That’s why there’s a limit in both directions – the decoder declares its maximum in HTTP/2 SETTINGS, while the encoder declares the size it’s actually using in an HPACK instruction.

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, June 13, 2017 7:56 PM
To: [email-masked]
Subject: draft-ietf-httpbis-header-compression-latest, "2.3.2 Dynamic Table"

<https://http2.github.io/http2-spec/compression.html#rfc.section.2.3.2<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fhttp2.github.io%2Fhttp2-spec%2Fcompression.html%23rfc.section.2.3.2&data=02%7C01%7CMichael.Bishop%40microsoft.com%7C24a659790e50463dfec208d4b2f8baf3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636330228734303857&sdata=q0c%2B501pZdpspgVF26ZPQYyOJqYpZt9Rq1LVgyMu260%3D&reserved=0>>:

Hi,

Good day!

I have a question about the section "The encoder decides how to update the dynamic table and as such can control how much memory is used by the dynamic table. To limit the memory requirements of the decoder, the dynamic table size is strictly bounded (see Section 4.2<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fhttp2.github.io%2Fhttp2-spec%2Fcompression.html%23maximum.table.size&data=02%7C01%7CMichael.Bishop%40microsoft.com%7C24a659790e50463dfec208d4b2f8baf3%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636330228734303857&sdata=XDxJ2a4TBv%2BOZxv6ipbrFpLHnl3eAYqtx8pfGcu5PMA%3D&reserved=0>).”

Best Regards,

Okis Chuang

TREND MICRO EMAIL NOTICE