Subject: What does ? ? ? mean in the octet diagrams in the HPACK rfc7541

From: Hadil Sabbagh <[email-masked]>
Date: Fri, 28 Jul 2017 17:19:36 -0700

I am confused by the question marks in the diagrams for the integer compressionn in HPACK. Does this mean we ignore the values of the bits, or are they set by another process — reserved for something else?

Please advise,

Hadil G. Sabbagh, Ph. D.

---

From: Amos Jeffries <[email-masked]>
Date: Sat, 29 Jul 2017 13:15:38 +1200

> I am confused by the question marks in the diagrams for the integer compressionn in HPACK. Does this mean we ignore the values of the bits, or are they set by another process — reserved for somethi…

As the first paragraph of that section states " An integer 
representation can start anywhere within an octet."

Integers are almost always preceded by a typecode of some sort which 
indicates what the integer values means. eg indexes numbers for the 
various tables, or a header field-value. The type codes have different 
lengths which are defined later in the document.

The '?' are there to emphasize that some number of bits (not always 3) 
are to be ignored by the integer decoder in the first byte it is given.

Amos