Subject: DRAFT - HTTPtre scope of work

From: Mark Nottingham <[email-masked]>
Date: Tue, 10 Oct 2017 08:43:10 -0700

Hi everyone,

We've talked about revising the HTTP/1.1 documents a few times; I think the next step is to agree on a scope of work. See draft proposal below.

--->8---

The Working Group will revise the RFC723[0-5] document set. The primary goals of this work will be:

1)  To clearly separate the version-dependent aspects of HTTP from those that are version-independent, to aid readers and implementers, and assist definition of future protocol versions;

2) Clarifying HTTP's underlying abstractions and guarantees (the "abstract model" of HTTP), to define a target for future versions of the protocol;

3) Incorporating errata;

4) Clarifying how HTTP is extended and versioned, as necessary; and

5) Addressing significant (as determined by the Chairs) security and interoperability issues that are raised.

Issues that are specific to HTTP/1.1 (e.g., chunked encoding, connection handling) will only be addressed if there is broad (as determined by the Chairs) implementation support for doing so.

The number and focus of the resulting documents might be the same, or might differ. It is expected that the resulting documents will be suitable for publication as Internet Standard. 

---8<---

Thoughts?

--
Mark Nottingham   https://www.mnot.net/

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 10 Oct 2017 16:22:16 +0000

Hi Mark,

A couple of points, apologies if these have already been asked/discussed:

1) Is the intention to carry out the work in this WG, or form a new HTTPtre WG?
2) In Julian's presentation at IETF 99, it was proposed to include in scope the resolution of GitHub issues. Is this implicit in your text (points 3 or 5?), or have they been explicitly left out?

Regards
Lucas

-----------------------------
http://www.bbc.co.uk
This e-mail (and any attachments) is confidential and
may contain personal views which are not the views of the BBC unless specifically stated.
If you have received it in
error, please delete it from your system.
Do not use, copy or disclose the
information in any way nor act in reliance on it and notify the sender
immediately.
Please note that the BBC monitors e-mails
sent or received.
Further communication will signify your consent to
this.
-----------------------------

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 10 Oct 2017 09:23:36 -0700

> On 10 Oct 2017, at 9:22 am, Lucas Pardue <[email-masked]> wrote:
> 
> Hi Mark,
> 

Same WG.

> 2) In Julian's presentation at IETF 99, it was proposed to include in scope the resolution of GitHub issues. Is this implicit in your text (points 3 or 5?), or have they been explicitly left out?

It's implied in those points, yes. Each issue will be judged on a case-by-case basis (see proposed criteria).

Cheers,

---

From: Willy Tarreau <[email-masked]>
Date: Wed, 11 Oct 2017 13:48:42 +0200

Hi Mark,

> The number and focus of the resulting documents might be the same, or might differ. It is expected that the resulting documents will be suitable for publication as Internet Standard. 

This sounds pretty reasonable and will possibly lead to better design choices
in the future now that we have some experience feedback making two versions
coexist.

I think that we should also start to give more recommendations about things
that should/should not be done to ease porting. I don't have anything
specific in mind, but it can range from new header field names to adopting
stricter types for values to ease parsing or structured representation for
example.

In short, we used to only know H/1 and its deployed implementations. Now
that many of us have known some difficulties dealing with H1+H2, we'll
probably want to be a bit more directive.

Cheers,
Willy

---

From: Patrick McManus <[email-masked]>
Date: Wed, 11 Oct 2017 21:14:38 +0000 (UTC)

On Wed, Oct 11, 2017 at 7:48 AM, Willy Tarreau <[email-masked]> wrote:

> > 1)  To clearly separate the version-dependent aspects of HTTP from those
> that are version-independent, to aid readers and implementers, and assist
> definition of future protocol versions;
> >
>

[..]

> that should/should not be done to ease porting.
>

hopefully these thoughts are complementary!

---

From: Willy Tarreau <[email-masked]>
Date: Thu, 12 Oct 2017 04:12:06 +0200

> hopefully these thoughts are complementary!

Yes but they don't completely overlap. Being version agnostic is one thing,
but optimizing for future versions is another one. This can range from trying
to take more advantage of HPACK for H2 to trying hard to make first requests
fit in a single QUIC packet. This can have some consequences on the design
choice for future header field names and syntax for instance.

Cheers,
Willy

---

From: Patrick McManus <[email-masked]>
Date: Thu, 12 Oct 2017 14:42:20 +0000 (UTC)

to the extent they don't overlap, imo your suggestion is out of scope for
tre.. but it might be in scope for another effort.. we've tried
(unsuccessfully) in the past with a "tuning tcp for h1" document for
example and I think we're open to more work along those lines in other
documents. that's just my opinion - the point of the thread is to get
everyone's opinion on tre, but I think a tight focus like Mark suggests is
imperative.

-P