Subject: Initial comments on draft-mcmanus-httpbis-h2-websockets-01

From: Eric Rescorla <[email-masked]>
Date: Sun, 12 Nov 2017 04:49:01 +0000

I took an initial look at this, and have a few comments:

1. Why do you need the magic preamble? How do you get confused about the
protocol.
2. "The End-Preamble type (0xff) MUST be the last TLS". I assume you mean
TLV.

-Ekr

---

From: Patrick McManus <[email-masked]>
Date: Sun, 12 Nov 2017 12:54:26 +0800

The -02 doesn't use the preamble..
https://github.com/mcmanus/draft-h2ws/blob/master/draft-mcmanus-httpbis-h2-websockets-02.txt
(datatracker is closed so it hasn't been submitted yet)