Subject: [Technical Errata Reported] RFC7725 (5181)

From: RFC Errata System <[email-masked]>
Date: Fri, 10 Nov 2017 20:05:40 -0800 (PST)

The following errata report has been submitted for RFC7725,
"An HTTP Status Code to Report Legal Obstacles".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5181

--------------------------------------
Type: Technical
Reported by: Stéphane Bortzmeyer <[email-masked]>

Section: 3

Original Text
-------------
   Link: <https://spqr.example.org/legislatione>; rel="blocked-by"

Corrected Text
--------------
   Link: <https://search.example.net/legal>; rel="blocked-by"

Notes
-----
Of course, it is hard to say from just an URL but it seems that the original "blocked-by" mentioned the authority requesting the blocking (spqr = Roman Senate and People) while the text in section 4 says "The intent is that the header be used to identify the entity actually implementing blockage, not any other entity mandating it."

Experience with the 451 crawler during the IETF 99 hackathon showed that several implementors got this wrong and used a "blocked-by" indicating the authority.

[It could be a good idea to have two links, one for the authority and one for the implementor, but this is outside the scope of this errata.]

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7725 (draft-ietf-httpbis-legally-restricted-status-04)
--------------------------------------
Title               : An HTTP Status Code to Report Legal Obstacles
Publication Date    : February 2016
Author(s)           : T. Bray
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Tim Bray <[email-masked]>
Date: Sat, 11 Nov 2017 08:00:10 +0000

I think this erratum is probably right, and in the very unlikely event we
were to republish the 451 RFC we should give a little more thought to the
URI in the example.  It could be fun to dream up an address for an ISP of
the Roman Empire - perhaps a sketchy Internet cafe in Corinth - that is
actually interposing the block; I know one or two Latin scholars whom I’m
sure would be delighted to make erudite suggestions. There'd be fun to be
had around something like CXXVII.?.?.I but Roman notation had no zeroes.

Having said that, it's not 100% obvious that the URI is wrong - perhaps you
are sitting in the Senate’s own Imperial Library, foolishly looking for
radical-chic Judean subversives.  The Legionaries are on their way to get
you because you foolishly followed a non-HTTPS link.  It’s the big cats in
the Coliseum for you.

On Sat, Nov 11, 2017 at 4:05 AM, RFC Errata System <
[email-masked]> wrote:

> Of course, it is hard to say from just an URL but it seems that the
> original "blocked-by" mentioned the authority requesting the blocking (spqr
> = Roman Senate and People) while the text in section 4 says "The intent is
> that the header be used to identify the entity actually implementing
> blockage, not any other entity mandating it."
>
> Experience with the 451 crawler during the IETF 99 hackathon showed that
> several implementors got this wrong and used a "blocked-by" indicating the
> authority.
>
> [It could be a good idea to have two links, one for the authority and one
> for the implementor, but this is outside the scope of this errata.]
>
> Instructions:
> -------------

-- 
- Tim Bray (If you’d like to send me a private message, see
https://keybase.io/timbray)