Subject: Zstd compression (FYI)

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 15 Nov 2017 07:57:47 +0000

I'd like to make this WG aware of a draft that's being processed in the ART area, namely draft-kucherawy-dispatch-zstd[1].  It describes a data compression algorithm and registers a related media type and content encoding.  The developers aren't seeking browser adoption at this point but since it is making entries in registries affecting in this area, I wanted to make it visible here.

It was discussed briefly in DISPATCH at IETF 100, and it was decided that it will be AD-sponsored.  There's no action item for HTTPBIS.  Just FYI.

Thanks,

-MSK

[1] https://datatracker.ietf.org/doc/draft-kucherawy-dispatch-zstd/ <https://datatracker.ietf.org/doc/draft-kucherawy-dispatch-zstd/>

---

From: Roland Zink <[email-masked]>
Date: Wed, 15 Nov 2017 15:48:25 +0100

Hi Murray,

HTTP has a content coding and a transfer coding registration. You may 
want to register it for both although the transfer coding will probably 
not be used by browsers.

Regards,

Roland

Am 15.11.2017 um 08:57 schrieb Murray S. Kucherawy:
> I'd like to make this WG aware of a draft that's being processed in 
> the ART area, namely draft-kucherawy-dispatch-zstd[1].  It describes a 
> data compression algorithm and registers a related media type and 
> content encoding.  The developers aren't seeking browser adoption at 
> this point but since it is making entries in registries affecting in 
> this area, I wanted to make it visible here.
>
> It was discussed briefly in DISPATCH at IETF 100, and it was decided 
> that it will be AD-sponsored.  There's no action item for HTTPBIS.  
> Just FYI.
>
> Thanks,
>
> -MSK
>
> [1] https://datatracker.ietf.org/doc/draft-kucherawy-dispatch-zstd/