Subject: Secondary Certs: Open PRs

From: Mike Bishop <[email-masked]>
Date: Fri, 8 Dec 2017 23:58:42 +0000

There are two open PRs in my old repo which I didn't merge before publishing the first WG draft simply so that we could adopt the draft everyone had read without sneaking changes in.  Both need a little polishing to incorporate feedback before merging.  Once that's done, I'm planning to merge them soon and they'll appear in -01 unless someone screams.  Fair warning.

First, #17<https://github.com/MikeBishop/http2-certs/pull/17> implements Kazuho's suggestion to remove the AUTOMATIC_USE flag and  replace it with pre-emptively sending USE_CERTIFICATE.  This is generally good, though it further emphasizes the problem discussed in a moment.  Second, #18<https://github.com/MikeBishop/http2-certs/pull/18> tracks the changes in Exported Authenticator #9<https://github.com/tlswg/tls-exported-authenticator/pull/9>, so I'll merge after Nick does.

There's still the open issue that some of the frames get sent on stream that are half-closed or closed, which is odd in HTTP/2 and downright impossible in HTTP/QUIC.  That probably means moving them to Stream 0, but other creative ideas are welcome.

---

From: Nick Sullivan <[email-masked]>
Date: Fri, 15 Dec 2017 22:46:27 +0000

Exported Authenticator #9 was merged and -05 draft is now published
including the change.

On Fri, Dec 8, 2017 at 4:10 PM Mike Bishop <[email-masked]> wrote:

> There are two open PRs in my old repo which I didn’t merge before
> publishing the first WG draft simply so that we could adopt the draft
> everyone had read without sneaking changes in.  Both need a little
> polishing to incorporate feedback before merging.  Once that’s done, I’m
> planning to merge them soon and they’ll appear in -01 unless someone
> screams.  Fair warning.
>
>
>
> First, #17 <https://github.com/MikeBishop/http2-certs/pull/17> implements
> Kazuho’s suggestion to remove the AUTOMATIC_USE flag and  replace it with
> pre-emptively sending USE_CERTIFICATE.  This is generally good, though it
> further emphasizes the problem discussed in a moment.  Second, #18
> <https://github.com/MikeBishop/http2-certs/pull/18> tracks the changes in
> Exported Authenticator #9
> <https://github.com/tlswg/tls-exported-authenticator/pull/9>, so I’ll
> merge after Nick does.
>
>
>
> There’s still the open issue that some of the frames get sent on stream
> that are half-closed or closed, which is odd in HTTP/2 and downright
> impossible in HTTP/QUIC.  That probably means moving them to Stream 0, but
> other creative ideas are welcome.
>