Subject: FW: New Version Notification for draft-bishop-httpbis-grease-00.txt

From: Mike Bishop <[email-masked]>
Date: Thu, 24 May 2018 21:54:36 +0000

There was a recent incident with a peer which closed the connection on an unknown setting, and that has given rise to some discussion about greasing HTTP/2's extension mechanisms (frame types and settings).  This draft is a quick proposal to do just that; if it gets traction on the HTTP/2 side, I'll put the same requirements into the HTTP/QUIC spec.

Comments welcome.

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Thursday, May 24, 2018 2:51 PM
To: Mike Bishop <[email-masked]>
Subject: New Version Notification for draft-bishop-httpbis-grease-00.txt

A new version of I-D, draft-bishop-httpbis-grease-00.txt
has been successfully submitted by Mike Bishop and posted to the IETF repository.

Name:		draft-bishop-httpbis-grease
Revision:	00
Title:		GREASE for HTTP/2
Document date:	2018-05-24
Group:		Individual Submission
Pages:		4
URL:            https://www.ietf.org/internet-drafts/draft-bishop-httpbis-grease-00.txt
Status:         https://datatracker.ietf.org/doc/draft-bishop-httpbis-grease/
Htmlized:       https://tools.ietf.org/html/draft-bishop-httpbis-grease-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-bishop-httpbis-grease

Abstract:
   Reserves several values in the HTTP/2 registries to exercise the
   requirement that clients and servers ignore unknown values.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Andy Green <[email-masked]>
Date: Fri, 25 May 2018 07:15:25 +0800

On 05/25/2018 05:54 AM, Mike Bishop wrote:
> There was a recent incident with a peer which closed the connection
> on an unknown setting, and that has given rise to some discussion
> about greasing HTTP/2's extension mechanisms (frame types and
> settings).  This draft is a quick proposal to do just that; if it
> gets traction on the HTTP/2 side, I'll put the same requirements into
> the HTTP/QUIC spec.

I recently started working on QUIC and saw they do this with their 
version negotiation, it's pretty smart.

There's a typo -->

2.1.  GREASE for Frame Types

    Frame types of the format "0xb + (0x1f * N)" are reserved for use as
    grease.  These frames have no semantic meaning, and SHOULD be send

... SHOULD be sent

-Andy

> Comments welcome.
> 
> -----Original Message----- From: [email-masked]
> <[email-masked]> Sent: Thursday, May 24, 2018 2:51 PM To:
> Mike Bishop <[email-masked]> Subject: New Version Notification
> for draft-bishop-httpbis-grease-00.txt
> 
> 
> A new version of I-D, draft-bishop-httpbis-grease-00.txt has been
> successfully submitted by Mike Bishop and posted to the IETF
> repository.
> 
> Name:		draft-bishop-httpbis-grease Revision:	00 Title:		GREASE for
> HTTP/2 Document date:	2018-05-24 Group:		Individual Submission Pages:
> 4 URL:
> https://www.ietf.org/internet-drafts/draft-bishop-httpbis-grease-00.txt
>
> 
Status: 
https://datatracker.ietf.org/doc/draft-bishop-httpbis-grease/
> Htmlized:
> https://tools.ietf.org/html/draft-bishop-httpbis-grease-00 Htmlized:
> https://datatracker.ietf.org/doc/html/draft-bishop-httpbis-grease
> 
> 
> Abstract: Reserves several values in the HTTP/2 registries to
> exercise the requirement that clients and servers ignore unknown
> values.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Patrick McManus <[email-masked]>
Date: Thu, 24 May 2018 23:35:53 +0000 (UTC)

On Thu, May 24, 2018 at 5:54 PM, Mike Bishop <[email-masked]> wrote:

> There was a recent incident with a peer which closed the connection on an
> unknown setting, and that has given rise to some discussion about greasing
> HTTP/2's extension mechanisms (frame types and settings).  This draft is a
> quick proposal to do just that; if it gets traction on the HTTP/2 side,
> I'll put the same requirements into the HTTP/QUIC spec.
>

I strongly support you putting these requirements into hq independently of
whether this is something we take up for h2.

My only concern about h2 is the lack of a time machine. Doing this now
could result in breakage (hopefully I'm wrong - but its possible) rather
than be preventative (i.e. grease). Its probably not too late for h2, but
its definitely not too late for hq!

-P

---

From: Martin Thomson <[email-masked]>
Date: Fri, 25 May 2018 10:04:28 +1000

On Fri, May 25, 2018 at 9:44 AM Patrick McManus <[email-masked]>
wrote:
> Its probably not too late for h2,

Can I infer from this that you think that the ORIGIN frame will cause
things to break?  Or is your assertion that servers are the broken ones?

Either way, I'm inclined to do this for h2.  There's a cost in bustage that
we pay, but the payoff might be that we can use new frame types.

---

From: Patrick McManus <[email-masked]>
Date: Fri, 25 May 2018 00:24:16 +0000 (UTC)

I said its probably _not_ too late for h2 :)

(I'm just contrasting that with its definitely not too late for hq - mike
had suggesting gating hq grease on h2 grease and that doesn't seem
necessary to me.)

---

From: Mike Bishop <[email-masked]>
Date: Fri, 25 May 2018 00:42:58 +0000

We're still trying to walk the line of having similar frame types at the same code points between the two. While reserving values for GREASE doesn't break that per se, it is a big reservation on the other side of the fence.

Sent from Nine<http://www.9folders.com/>
________________________________
From: Patrick McManus <[email-masked]>
Sent: Thursday, May 24, 2018 5:24 PM
To: Martin Thomson
Cc: Patrick McManus; Mike Bishop; HTTP Working Group
Subject: Re: FW: New Version Notification for draft-bishop-httpbis-grease-00.txt

(I'm just contrasting that with its definitely not too late for hq - mike had suggesting gating hq grease on h2 grease and that doesn't seem necessary to me.)

On Thu, May 24, 2018 at 8:04 PM, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:
On Fri, May 25, 2018 at 9:44 AM Patrick McManus <[email-masked]<mailto:[email-masked]>>