Subject: Push Use Cases

From: Mike Bishop <[email-masked]>
Date: Fri, 29 Jun 2018 23:06:37 +0000

This draft isn't targeted for a protocol standard so much as enumerating different ways to use push.  HTTP/2 provides the mechanics of pushing a request/response pair that the client hasn't asked for yet, but... what exactly does that request look like, and what does a client actually *do* with it?

Pretty much the only thing that has coalesced is dependent resources on the same page.  Pushing responses to XHR queries, pushing cache validation updates or invalidations, etc. are things that we've handwaved about and never really defined.

This draft is an effort to enumerate the different ways that push *could* be used, in hopes that it can develop into a common reference to describe what each client supports or doesn't.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, June 29, 2018 3:54 PM
To: Mike Bishop <[email-masked]>
Subject: New Version Notification for draft-bishop-httpbis-push-cases-00.txt

A new version of I-D, draft-bishop-httpbis-push-cases-00.txt
has been successfully submitted by Mike Bishop and posted to the IETF repository.

Name:		draft-bishop-httpbis-push-cases
Revision:	00
Title:		HTTP/2 Server Push Use Cases
Document date:	2018-06-28
Group:		Individual Submission
Pages:		6
URL:            https://www.ietf.org/internet-drafts/draft-bishop-httpbis-push-cases-00.txt
Status:         https://datatracker.ietf.org/doc/draft-bishop-httpbis-push-cases/
Htmlized:       https://tools.ietf.org/html/draft-bishop-httpbis-push-cases-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-bishop-httpbis-push-cases

Abstract:
   HTTP/2 defines the wire mechanics of Server Push.  Though the
   mechanics of how a pushed resource is delivered are well-specified,
   the use cases that describe which resources can be pushed, in what
   states, and for what purpose are not described in HTTP/2.  As a
   result, support between implementations varies widely.

   This document attempts to enumerate interesting scenarios, in hopes
   that a more concrete taxonomy can assist the community in arriving at
   a standard set of supported scenarios.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 30 Jun 2018 00:20:31 +0000

Hi Mike,

What category do you think something like DNS over HTTPS falls into? In this case, DNS could be pushed using the the GET method format. This is related to the DOM but doesn't deliver a resource that is explicilty part of the render.

Lucas
________________________________________
From: Mike Bishop [[email-masked]]
Sent: 30 June 2018 00:06
To: HTTP Working Group
Subject: Push Use Cases

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 29, 2018 3:54 PM
To: Mike Bishop <[email-masked]>
Subject: New Version Notification for draft-bishop-httpbis-push-cases-00.txt

Abstract:

The IETF Secretariat

---

From: Mike Bishop <[email-masked]>
Date: Sat, 30 Jun 2018 15:33:28 +0000

I'm inclined to think of that as an API, either something called by a script, or by a DNS client component further down in the system.

-----Original Message-----
From: Lucas Pardue <[email-masked]> 
Sent: Friday, June 29, 2018 5:21 PM
To: Mike Bishop <[email-masked]>; HTTP Working Group <[email-masked]>
Subject: RE: Push Use Cases

Hi Mike,

Lucas

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, June 29, 2018 3:54 PM
To: Mike Bishop <[email-masked]>
Subject: New Version Notification for draft-bishop-httpbis-push-cases-00.txt

Abstract:

The IETF Secretariat