Subject: Working Group Last Call: draft-ietf-httpbis-client-hints-06

From: Mark Nottingham <[email-masked]>
Date: Tue, 17 Jul 2018 11:46:45 -0400

Ilya indicates that he thinks we're ready for WGLC on this document:

  https://tools.ietf.org/html/draft-ietf-httpbis-client-hints-06

Note that the intended status is Experimental.

Please have a look through and bring up any issues here or on the issues list, and please indicate support (or lack thereof) for advancement on the mailing list. If you are implementing or intend to implement the specification, that would be useful information for us.

WGLC will end on 7 August.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Kari Hurtta <[email-masked]>
Date: Sun, 22 Jul 2018 19:23:01 +0300 (EEST)

HTTP Client Hints

3.1.  The DPR Header Field

https://tools.ietf.org/html/draft-ietf-httpbis-client-hints-06#section-3.1

|   The "DPR" request header field is a number that indicates the
|   client's current Device Pixel Ratio (DPR), which is the ratio of
|   physical pixels over CSS px (Section 5.2 of [CSSVAL]) of the layout
|   viewport (Section 9.1.1 of [CSS2]) on the device.
|
|     DPR = 1*DIGIT [ "." 1*DIGIT ]
|
|   If DPR occurs in a message more than once, the last value overrides
|   all previous occurrences.

But on elsewhere

https://tools.ietf.org/html/rfc7230#section-3.2.2

|   A recipient MAY combine multiple header fields with the same field
|   name into one "field-name: field-value" pair, without changing the
|   semantics of the message, by appending each subsequent field value to
|   the combined field value in order, separated by a comma. 

So is that saying that if there is several DPR values on
DPR Header Field, last value is used ?

If that in interpreted only that if last DPR header field is used,
and header field is ignored if it does not fit
 
    DPR = 1*DIGIT [ "." 1*DIGIT ]

syntax, result is different is recipient combines multiple
DPR headers.

3.1.1.  Confirming Selected DPR
https://tools.ietf.org/html/draft-ietf-httpbis-client-hints-06#section-3.1.1

|   If Content-DPR occurs in a message more than once, the last value
|   overrides all previous occurrences.

( Partially same on here. Refering of value is better however ).

3.1.1.  Confirming Selected DPR
https://tools.ietf.org/html/draft-ietf-httpbis-client-hints-06#section-3.1.1

|   If Content-DPR occurs in a message more than once, the last value
|   overrides all previous occurrences.

Same in here.

3.2.  The Width Header Field
https://tools.ietf.org/html/draft-ietf-httpbis-client-hints-06#section-3.2

|                           If Width occurs in a message more than once, the
|   last value overrides all previous occurrences.

( Partially same on here. Refering of value is better however ).

3.3.  The Viewport-Width Header Field
https://tools.ietf.org/html/draft-ietf-httpbis-client-hints-06#section-3.3

|   If Viewport-Width occurs in a message more than once, the last value
|   overrides all previous occurrences.

So it should mention that on these header fields also last value
is used when values are ',' -separated.

/ Kari Hurtta