Subject: a few comments about HiNT [was: Re: HTTP proposal for UDP proxying: HELIUM]

From: "Fossati, Thomas (Nokia - GB/Cambridge)" <[email-masked]>
Date: Sun, 8 Jul 2018 23:19:59 +0000

Hi Lucas,

Thanks for the clarity and the very good analysis.

A few comments:

  *   I'm still pondering whether the mechanisms described (and more generally a tunnelled-QUIC approach) can be used by a proxy sitting in the mobile access to run an optimised congestion controller that benefits the end-to-end flow.  I guess one has to try ☺

  *   Section 4.: I think we should refrain from considering extending CONNECT semantics.  This is possibly the most complex of the approaches because of the huge installed base, which we can't expect to forklift overnight.

  *   Typo in 6.1. s/Is/It is/

Cheers, t

On 02/07/2018, 23:27, "Lucas Pardue" <[email-masked]<mailto:[email-masked]>> wrote:

To follow Ben’s previous email, I have published another draft in the UDP proxying family.

This one takes a broader look at today’s TCP tunnelling that uses the HTTP CONNECT method. It generalises the tunnelling concepts and surveys options that may be suited toward UDP or IP tunnels. Design considerations are captured, and some technical solutions are specced out for illustrative purposes. Four candidate solutions are proposed to help direct discussion, although the matrix of options supports many permutations.

Title:
   HTTP-initiated Network Tunnelling

Abstract:

   The HTTP CONNECT method allows an HTTP client to initiate, via a

   proxy, a TCP-based tunnel to a single destination origin.  This memo

   explores options for expanding HTTP-initiated Network Tunnelling

   (HiNT) to cater for diverse UDP and IP associations.

https://tools.ietf.org/html/draft-pardue-httpbis-http-network-tunnelling-00

Questions and reviews are welcomed. Ben and I will are scheduled to present our drafts at the HTTPbis session on Tuesday 17 July.

Kind regards
Lucas

From: Ben Schwartz [mailto:[email-masked]]
Sent: 25 June 2018 21:44
To: HTTP Working Group <[email-masked]>
Subject: HTTP proposal for UDP proxying: HELIUM

Hello HTTPBIS,

In a thread a few months ago [1], there was call for interest in extending HTTP proxying (e.g. HTTP CONNECT) to support UDP traffic, motivated by the growth of QUIC and WebRTC.  Since then, the people who expressed interest have brainstormed some possible use cases and solutions.  I am emailing to present the first of what I hope will be several drafts that we will present on the topic and discuss at IETF 102.  This draft presents one possible solution enabling HTTP proxying of UDP.

https://www.ietf.org/id/draft-schwartz-httpbis-helium-00.txt

Title:
   Hybrid Encapsulation Layer for IP and UDP Messages (HELIUM)
Abstract:
   HELIUM is a protocol that can be used to implement a UDP proxy, a
   VPN, or a hybrid of these.  It is intended to run over a reliable,
   secure substrate transport.  It can serve a variety of use cases, but
   its initial purpose is to enable HTTP proxies to forward non-TCP
   flows.

Questions and reviews much appreciated.

--Ben Schwartz

[1] https://www.ietf.org/mail-archive/web/httpbisa/current/msg30667.html

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 13 Jul 2018 11:13:49 +0000

Hi Thomas,

Thanks for the feedback, addressing your points in order:

> I'm still pondering whether the mechanisms described (and more generally a tunnelled-QUIC approach) can be used by a proxy sitting in the mobile access to run an optimised congestion controller that benefits the end-to-end flow.  I guess one has to try ☺

Proxying for congestion control is an interesting use case. So I think this question comes from the protections of QUIC making transparent (aka implicit) proxying hard/impossible. Is it feasible for the access network to explicitly signal the presence of such a proxy in the mobile environment? In other words, there are methods for proxy discovery (DHCP etc) but are these practically deployable by operators?

> Section 4.: I think we should refrain from considering extending CONNECT semantics.  This is possibly the most complex of the approaches because of the huge installed base, which we can't expect to forklift overnight.

That is useful feedback, thanks. We hope to gather similar feedback either here or in the HTTPbis session at ITF 102.

> Typo in 6.1. s/Is/It is/

I’ll get it fixed in the next draft.

Regards
Lucas

From: Fossati, Thomas (Nokia - GB/Cambridge) [mailto:[email-masked]]
Sent: 09 July 2018 00:20
To: Lucas Pardue <[email-masked]>; HTTP Working Group <[email-masked]>
Cc: Ben Schwartz <[email-masked]>; Fossati, Thomas (Nokia - GB/Cambridge) <[email-masked]>
Subject: a few comments about HiNT [was: Re: HTTP proposal for UDP proxying: HELIUM]

Hi Lucas,

A few comments:

Cheers, t

----------------------------

http://www.bbc.co.uk
This e-mail (and any attachments) is confidential and may contain personal views which are not the views of the BBC unless specifically stated.
If you have received it in error, please delete it from your system.
Do not use, copy or disclose the information in any way nor act in reliance on it and notify the sender immediately.
Please note that the BBC monitors e-mails sent or received.
Further communication will signify your consent to this.

---------------------