Subject: Registering Content-MD5

From: Mark Nottingham <[email-masked]>
Date: Thu, 11 Oct 2018 10:06:56 +1100

In <https://github.com/httpwg/http-core/issues/93>, we noticed that while RFC7231 talks about deprecating the Content-MD5 header, the change didn't make its way into the registry, causing some amount of confusion.

Is there any objection in the working group to asking IANA* to update the Permanent Message Header registry with:

Header name: Content-MD5
Protocol: http
Status: obsoleted
Reference: RFC7231, Appendix B

?

Cheers,

* Technically, we'll send it to the headers list first, as per <https://tools.ietf.org/html/rfc3864#section-4.3>.

--
Mark Nottingham   https://www.mnot.net/

---

From: "Roy T. Fielding" <[email-masked]>
Date: Wed, 10 Oct 2018 17:18:59 -0700

> On Oct 10, 2018, at 4:06 PM, Mark Nottingham <[email-masked]> wrote:
> 

Hmm, I think it should be

   Reference: RFC2616 (obsoleted by RFC7231)

to be consistent with the Status.

+1

....Roy

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 11 Oct 2018 11:23:02 +1100

WFM, although we should include the section in 7231 for convenience.

> On 11 Oct 2018, at 11:18 am, Roy T. Fielding <[email-masked]> wrote:
>

---

From: Patrick McManus <[email-masked]>
Date: Wed, 10 Oct 2018 18:45:37 -0700

the plan makes sense to me.. thanks!

On Wed, Oct 10, 2018 at 5:25 PM Mark Nottingham <[email-masked]> wrote:

> >> In <https://github.com/httpwg/http-core/issues/93>, we noticed that
> while RFC7231 talks about deprecating the Content-MD5 header, the change
> didn't make its way into the registry, causing some amount of confusion.
> >>
> >> Is there any objection in the working group to asking IANA* to update
> the Permanent Message Header registry with:
> >>
> >> Header name: Content-MD5
> >> Protocol: http
> >> Status: obsoleted