Subject: Re: Adam Roach's Discuss on draft-ietf-httpbis-expect-ct-07: (with DISCUSS and COMMENT)

From: Emily Stark <[email-masked]>
Date: Sat, 10 Nov 2018 09:31:10 -0800

Hi Adam,
Thanks for the review. I've addressed your comments in
https://github.com/httpwg/http-extensions/commit/d6e31360bdeeace4b8271162b0a8d25b836eb446.
(Some of them had already been fixed during other reviews.)
Emily

On Wed, Sep 19, 2018 at 9:25 AM Julian Reschke <[email-masked]>
wrote:

> On 9/13/2018 8:54 AM, Adam Roach wrote:
> > ...
> > §2.1.3:
> >
> >>   The "max-age" directive is REQUIRED to be present within an "Expect-
> >>   CT" header field.
> >
> > This doesn't appear to be true as stated; or, at least, it is stated in a
> > somewhat confusing way. A casual reading of this requirement is that an
> > "Expect-CT" header field is noncompliant if it is missing this directive.
> > Based on the examples given, the actual requirement here is that a
> response
> > that contains an Expect-CT header field MUST contain an Expect-CT header
> field
> > with a max-age directive, although that directive does not necessarily
> need to
> > appear in each Expect-CT header field. This should probably be clarified.
> > ...
>
> That's another case where progress on
> <https://github.com/httpwg/http-core/issues/111> would help. This
> plagues other WG drafts as well.
>
> Best regards, Julian
>

---

From: Adam Roach <[email-masked]>
Date: Thu, 15 Nov 2018 16:28:21 -0600

Thanks. This addresses my concern, and I will clear my discuss once a 
new version of the document is in the i-d repository.

/a

On 11/10/18 11:31 AM, Emily Stark wrote:
> On Wed, Sep 19, 2018 at 9:25 AM Julian Reschke <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     > Based on the examples given, the actual requirement here is that
>     a response
>     > that contains an Expect-CT header field MUST contain an
>     Expect-CT header field
>     > with a max-age directive, although that directive does not
>     necessarily need to