Subject: Re: Spencer Dawkins' Yes on charter-ietf-httpbis-07-01: (with COMMENT)

From: Alexey Melnikov <[email-masked]>
Date: Wed, 21 Nov 2018 11:14:59 +0000

Hi Spencer,

On Tue, Nov 20, 2018, at 8:22 PM, Spencer Dawkins wrote:
> Spencer Dawkins has entered the following ballot position for
> charter-ietf-httpbis-07-01: Yes
> 
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
> 
> 
> 
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/charter-ietf-httpbis/
> 
> 
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> I appreciate the addition of QUIC-related work to this charter.
> 
> I'm sympathetic to Mirja's comments about intentions, including her comment on
> not-optimal-timing. At a minimum, as I mentioned during discussions at IETF
> 103, I note that the current QUIC charter calls out HTTP/2, and if that's not
> what QUIC is going to call their deliverable (as per this charter), it would be
> nice to update the QUIC charter to reflect the new name.
> 
> Keeping in mind that HTTPbis and QUIC currently share one co-chair, and that
> this might not always be true, you might consider a couple of "good fences make
> good neighbors" edits, as
> 
> OLD
> 
> The Working Group will review the QUIC Working Group's documents regarding
> the use of HTTP over the transport protocol they define, providing feedback and
> collaborating where necessary.
> 
> NEW
> 
> Upon request from the QUIC Working Group, the HTTPbis Working Group will review
> the QUIC Working Group's documents regarding the use of HTTP over the transport
> protocol they define, providing feedback and collaborating where necessary.
> 
> END
> 
> and
> 
> OLD
> 
> Once the QUIC Working Group publishes the expression of HTTP semantics in QUIC
> (HTTP/3), this Working Group will maintain and develop extensions for that
> protocol as necessary. This includes ancillary specifications (e.g. QPACK).
> 
> NEW
> 
> Once the QUIC Working Group publishes the expression of HTTP semantics in QUIC
> (HTTP/3), the HTTPbis Working Group will maintain and develop extensions for
> HTTP/3 as necessary. This includes ancillary specifications (e.g. QPACK).
> 
> END

I applied your changes, thank you!

> And I notice that this is the first mention of HTTP/3 in the revised charter.
> Perhaps that's worth a sentence, on its own?

"HTTP semantics in QUIC" is supposed to be definition of HTTP/3. If you can suggest a better wording (or extra text), that would be much appreciated.

Best Regards,
Alexey

---

From: Spencer Dawkins <[email-masked]>
Date: Thu, 22 Nov 2018 14:53:51 +0000

OLD

NEW

END

and

OLD

NEW

END