Subject: Spencer Dawkins' Yes on charter-ietf-httpbis-07-03: (with COMMENT)

From: Spencer Dawkins <[email-masked]>
Date: Mon, 03 Dec 2018 18:14:57 +0000

Spencer Dawkins has entered the following ballot position for
charter-ietf-httpbis-07-03: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-httpbis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

This revision looks "Yes"-able, but of course, I have questions ... but they're
mostly for the ART ADs.

I'm somewhat surprised that a revision of HTTP/1.1 is called out, but a similar
effort for HTTP/2 is not (and maybe more surprised because HTTP/3 extensions
are mentioned). I should just assume that if work on HTTP/2 turns out to be
necessary, the working group would be rechartered, maybe?

I see that https://datatracker.ietf.org/doc/draft-ietf-httpbis-bcp56bis/ is in
WGLC now, so maybe it's not worth mentioning, but I'm getting a sense that ART
and TSV are going to be having more conversations about the evolution of
transport that involve HTTP as an application substrate. TSVAREA gave over our
entire agenda at IETF 103 for topics in this space. It might be that the ART
ADs would not have those conversations in HTTPbis, or would be part of a later
recharter, but I did want to ask if they should be in charter for HTTPbis now,
since we're balloting on an update.

And a nit - if "The Working Group will refine the "core" HTTP document set (RFC
7230-RFC 7235)" actually means "revise" that document set, I'd suggest saying
so.

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 06 Dec 2018 14:55:08 +0000

Hi Spencer,
Sorry I missed your comments earlier.

> charter-ietf-httpbis-07-03: Yes

 [snip]

> necessary, the working group would be rechartered, maybe?

I know this is a bit weird, but that is the current intent of the WG. Work on revising HTTP/2 will effectively result in HTTP/3. I don't think there is a separate effort just to revise HTTP/2 at this point. There is definitely an effort to revise HTTP/1.1

> since we're balloting on an update.

If you can suggest some specific text, maybe we can discuss?

> 7230-RFC 7235)" actually means "revise" that document set, I'd suggest saying

Happy to do this change.

Best Regards,
Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 06 Dec 2018 15:13:55 +0000

Hi Spencer,

On Thu, Dec 6, 2018, at 3:10 PM, Spencer Dawkins at IETF wrote:
> Hi, Alexey, 
> 
> On Thu, Dec 6, 2018 at 8:55 AM Alexey Melnikov
> <[email-masked]> wrote:>> 
>> > I see that
>> > https://datatracker.ietf.org/doc/draft-ietf-httpbis-bcp56bis/ is in>>  > WGLC now, so maybe it's not worth mentioning, but I'm getting a
>>  > sense that ART>>  > and TSV are going to be having more conversations about the
>>  > evolution of>>  > transport that involve HTTP as an application substrate. TSVAREA
>>  > gave over our>>  > entire agenda at IETF 103 for topics in this space. It might be
>>  > that the ART>>  > ADs would not have those conversations in HTTPbis, or would be
>>  > part of a later>>  > recharter, but I did want to ask if they should be in charter for
>>  > HTTPbis now,>>  > since we're balloting on an update.
>> 
> My question was more high-level - whether these discussions would be
> part of the HTTPbis charter, or might happen somewhere else.> 
> It's OK if we don't know the answer to that yet. I just wanted to ask
> while you've got the HTTPbis charter open for minor surgery :-)I don't know answer to this. I am open to suggestions. I am also happy
if we decide later.
> 
> Spencer
>  
>> 
>> > And a nit - if "The Working Group will refine the "core" HTTP
>> > document set (RFC>>  > 7230-RFC 7235)" actually means "revise" that document set, I'd
>>  > suggest saying>>  > so.
>> 
>>  Happy to do this change.
>> 
>>  Best Regards,
>>  Alexey