Subject: Call for Adoption: Cache HTTP Response Header

From: Tommy Pauly <[email-masked]>
Date: Sun, 13 Jan 2019 12:19:52 -0800

Hello HTTPBis,

In Bangkok, we had a presentation from Mark on a draft to define a standard Cache HTTP Response Header, that can be used to replace non-standard uses of the "X-Cache" header. The document can be found here: https://tools.ietf.org/html/draft-nottingham-cache-header-00.

The response in the room was favorable to having the group work on this header, but we didn't have time (and hadn't had sufficient discussion) to do a formal call for adoption.

This email starts a request for feedback, and a call for adoption. Please reply to this email with your thoughts, and state whether or not you believe the group should adopt this document. Feedback is requested by Friday, January 25th.

Best,
Tommy

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 13 Jan 2019 20:29:32 +0000

I am in support of adopting this. The initial proposal generated some
discussion and I think it would be too to adopt the document to further
that and incorporate WG ideas.

Lucas

On Sun, 13 Jan 2019, 20:23 Tommy Pauly <[email-masked] wrote:

> Hello HTTPBis,
>
> In Bangkok, we had a presentation from Mark on a draft to define a
> standard Cache HTTP Response Header, that can be used to replace
> non-standard uses of the "X-Cache" header. The document can be found here:
> https://tools.ietf.org/html/draft-nottingham-cache-header-00.
>
> The response in the room was favorable to having the group work on this
> header, but we didn't have time (and hadn't had sufficient discussion) to
> do a formal call for adoption.
>
> This email starts a request for feedback, and a call for adoption. Please
> reply to this email with your thoughts, and state whether or not you
> believe the group should adopt this document. Feedback is requested by *Friday,
> January 25th*.
>
> Best,
> Tommy
>

---

From: Thomas Peterson <[email-masked]>
Date: Mon, 14 Jan 2019 09:48:31 +0000

I too am also in favour of adopting, and despite my initial concerns not 
being completely addressed with any update to the document (see 
https://lists.w3.org/Archives/Public/ietf-http-wg/2018JulSep/0314.html), 
I don't believe these should block it moving forward.

Regards

On 13/01/2019 20:19, Tommy Pauly wrote:
> non-standard uses of the "X-Cache" header. The document can be found 
> here: https://tools.ietf.org/html/draft-nottingham-cache-header-00.
>
> The response in the room was favorable to having the group work on 
> this header, but we didn't have time (and hadn't had sufficient 
> discussion) to do a formal call for adoption.
>
> This email starts a request for feedback, and a call for adoption. 
> Please reply to this email with your thoughts, and state whether or 
> not you believe the group should adopt this document. Feedback is 
> requested by *Friday, January 25th*.
>
> Best,
> Tommy

---

From: Matthew Stock <[email-masked]>
Date: Mon, 14 Jan 2019 15:57:58 -0500

With regards to the cache status, has there been any discussion around
range requests?  In particular, when the cache node has some of the
requested range but has to go upstream for the rest, how is it
represented?  My suggestion is to call it a HIT, and add a new parameter
"partial".

Aside from that, I'm in support of adoption.

Matt

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 15 Jan 2019 10:02:18 -0700

I think we could accommodate range requests, but AFAICT interoperability isn't great there:
  https://cache-tests.fyi/#partial

Cheers,

> On 14 Jan 2019, at 1:57 pm, Matthew Stock <[email-masked]> wrote:
> 
> With regards to the cache status, has there been any discussion around range requests?  In particular, when the cache node has some of the requested range but has to go upstream for the rest, how is it represented?  My suggestion is to call it a HIT, and add a new parameter "partial".
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 25 Jan 2019 08:59:50 -0800

Hello HTTPBis,

Thank you for your feedback on this document! It looks like we do have support and interest in the group for working on this, so we'll adopt it as a working group document.

Mark, please submit a -ietf-httpbis draft when ready.

Thanks,
Tommy

> On Jan 13, 2019, at 12:19 PM, Tommy Pauly <[email-masked]> wrote:
> 
> Hello HTTPBis,
> 
> In Bangkok, we had a presentation from Mark on a draft to define a standard Cache HTTP Response Header, that can be used to replace non-standard uses of the "X-Cache" header. The document can be found here: https://tools.ietf.org/html/draft-nottingham-cache-header-00 <https://tools.ietf.org/html/draft-nottingham-cache-header-00>.
>