Subject: Re: Empty lists in Structured Headers (#781)

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Jul 2019 17:08:22 +1000

On 13 Jun 2019, at 6:43 pm, Mark Nottingham <[email-masked]> wrote:
> 
> After thinking about this a bit more, I think this issue is backwards; it's asking why we don't support a specific syntax, rather than a specific data model.
> 
> If people just want to make sure we can express an empty list in SH, that's pretty easy; we can say that the absence of a list-based SH field is equivalent to an empty list.
> 
> However, if people want to map a *specific* syntax to an empty list (namely, a header field name with an empty or whitespace-only value), I'd like to understand why. There's only been one example given, and there isn't any deployment of the specified semantics AFAIK -- reinforcing the notion that doing so is bad practice. And, as a reminder (sorry for sounding like a broken record), the whole point of SH is that we're not mapping every conceivable field value into the data model; just the conventions that are useful (in other words, paving the cowpaths).
> 
> Which bucket are the people who are clamouring for this in?

See proposal at:
  <https://github.com/httpwg/http-extensions/pull/817>

--
Mark Nottingham   https://www.mnot.net/

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Wed, 03 Jul 2019 09:09:10 +0000

--------

>  <https://github.com/httpwg/http-extensions/pull/817>

Isn't this just a complicated way of saying "No header XYZ is the
same as an empty XYZ header" ?

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Jul 2019 19:10:38 +1000

Pretty much. 

Sent from my iPhone

> On 3 Jul 2019, at 7:09 pm, Poul-Henning Kamp <[email-masked]> wrote:
> 
> --------