Subject: New I-D: standard RateLimit headers and their relations with Retry-After

From: Roberto Polli <[email-masked]>
Date: Wed, 7 Aug 2019 11:32:29 +0200

Hi @all,

I'm writing a new I-D to standardize `RateLimit-*` headers.
I had some positive feedback from Erik Wilde, so I'm posting here :)

The document defines the RateLimit-Limit, RateLimit-Remaining,
RateLimit-Reset header fields for HTTP, thus allowing servers to
publish current request quotas and clients to shape their request
policy avoiding being throttled out.

The draft is here:

-  https://tinyurl.com/draft-ratelimit-html

If you are interested, feel free to comment PRs and file issues!
If you have any questions don't hesitate to ask :)

Thanks and have a nice day,
R

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 8 Aug 2019 12:13:49 +1000

Hi Roberto,

It's good to see you working on these; I've been meaning to start something like this for a while.

I've raised some issues on the repo, please continue. 

Cheers,

> On 7 Aug 2019, at 7:32 pm, Roberto Polli <[email-masked]> wrote:
> 
> Hi @all,
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Roberto Polli <[email-masked]>
Date: Thu, 8 Aug 2019 11:55:40 +0200

Hi Mark,

Il giorno gio 8 ago 2019 alle ore 04:17 Mark Nottingham
<[email-masked]> ha scritto:
> It's good to see you working on these;
> I've been meaning to start something like this for a while.
That's a great news!

> I've raised some issues on the repo, please continue.
I tried to address some of these. Let me know if I can
merge directly or you prefer to approve the PRs.

Thanks for all your support and guidance,
R.

-- 
Roberto Polli
Full Stack Developer
M. +39 3406522736
·D
TEAM PER LA
TRASFORMAZIONE
DIGITALE
Presidenza del Consiglio dei Ministri
teamdigitale.governo.it

Il Team per la Trasformazione Digitale, salvo eccezioni, comunica con
le altre Amministrazioni via posta elettronica ordinaria e non posta
elettronica certificata, in conformità a quanto previsto dall’art.47
del Codice dell’Amministrazione Digitale.

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 09 Aug 2019 00:06:07 +1000

> merge directly or you prefer to approve the PRs.

As long as the work is exclusively yours (which it is until the WG adopts it), you can do as you please with it.  Use your judgment of course.  Being responsive to feedback only improves your changes of eventual adoption, publication, and the accolades that come with being an RFC author.  Let me tell you that the royalty money is pretty crazy.

---

From: Roberto Polli <[email-masked]>
Date: Thu, 8 Aug 2019 16:40:49 +0200

Hi Martin,

Il giorno gio 8 ago 2019 alle ore 16:10 Martin Thomson
<[email-masked]> ha scritto:
> > [can I] merge directly or you prefer to approve the PRs.
>
> [..] until the WG adopts it  you can do as you please with it.
> Use your judgment of course.
Sure, I just wanted to know if the issues were properly addressed :)

> Being responsive to feedback only improves your changes of eventual adoption, publication,
> and the accolades that come with being an RFC author.
>  Let me tell you that the royalty money is pretty crazy.
You're welcome to partake to the royalties sharing your
comments on the I-D :)

- https://github.com/ioggstream/draft-polli-ratelimit-headers/pulls
-  https://tinyurl.com/draft-ratelimit-html

Thanks for your email, Martin!
R.