Subject: Call for consensus: Priorities in HTTP/3

From: Mark Nottingham <[email-masked]>
Date: Thu, 8 Aug 2019 10:04:58 +1000

In the Montreal meeting, we discussed the QUIC Working Group's intentions regarding HTTP/2 priority implementation in HTTP/3, which they are currently working on, but this WG will take control of upon publication.

The QUIC WG is required by their charter to ship "a description of HTTP/2 semantics using QUIC", which arguably includes HTTP/2 priorities.

However, after discussion, the overwhelming feedback we've received is that HTTP/2 priorities are not suitable for inclusion in HTTP/3. If they are specified, it is likely that a significant number of implementations will not support them.

As a result, we believe the best path forward is NOT to require the QUIC WG to include HTTP/2 priorities in HTTP/3. Doing so does not necessarily mean that HTTP/3 will ship without a priority scheme. The expectation is that work will continue (in the HTTP WG) to develop a new priority scheme that is suitable for HTTP/3 (and ideally, available as an extension to HTTP/2).

Meeting HTTP/3's timelines will require significant effort. We'll do our best to accommodate this work (e.g. giving time in Singapore), but by necessity, it's not clear what the outcome will be. If HTTP is ready to ship, but a new priority scheme is not agreed to, both this WG and the QUIC WG will have to determine a path forward at that time.

In Montreal, the sense in the room was quite strong that this is the correct path forward. If you have objections, please state them clearly; in particular, if you have new information. Please do so soon; we want to finalise this next week.

Upon consensus, we'll check this decision with both ADs to assure that QUIC remains within its charter. Once we resolve that, the practical and immediate outcome will be the removal of HTTP/2 priorities from the HTTP/3 specification; see <https://github.com/quicwg/base-drafts/pull/2922>. 

In the meantime, note that a Design Team has already begun work on a concrete proposal; see the e-mail from Ian a little while back: <https://www.w3.org/mid/CAKcm_gPzaGaRczP=[email-masked]>⁩

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 16 Aug 2019 11:04:46 +1000

Hearing no pushback, consensus declared.

Cheers,

> On 8 Aug 2019, at 10:04 am, Mark Nottingham <[email-masked]> wrote:
>