Subject: Re: LS from 3GPP on QUIC network level troubleshooting capabilities

From: Ian Swett <[email-masked]>
Date: Sun, 13 Oct 2019 18:35:20 -0400

If the main concern is inability to passively measure packet loss and as
Lars said this is not for end-to-end user traffic(so support for certain
extensions could be assumed), then this could be a good test case for
draft-ferrieuxhamchaoui-quic-lossbits
<https://tools.ietf.org/html/draft-ferrieuxhamchaoui-quic-lossbits-01> to
prove it works as intended and see if the mechanism needs any changes.

On Sun, Oct 13, 2019 at 4:34 AM Lars Eggert <[email-masked]> wrote:

> Hi Lionel,
>
> On 2019-10-12, at 11:24, <[email-masked]> <
> [email-masked]> wrote:
> > Please find enclosed a liaison statement from the 3GPP CT WG 4 (CT4).
>
> I do not see this liaison statement posted at
> https://datatracker.ietf.org/liaison/. Please make sure to submit it via
> the regular process, to keep all relevant entities in the loop.
>
> > This WG is actually studying the introduction of QUIC as transport
> protocol instead of HTTP/2 in the 5G core network.
> > The WG has some questions regarding the troubleshooting capabilities
> supported by QUIC compared to the ones available with TCP.
>
> Based on my (limited) understanding of the 5G architecture, this use of
> QUIC would be as a protocol for carrying control information inside a 5G
> network control plane. In other words, it is not about the end-to-end use
> of QUIC over paths that traverse 5G networks. Is my understanding correct?
>
> Thanks,
> Lars
>
> >  The LS is officially addressed to the QUIC WG. However, it was
> highlighted that httpbis WG could also be interested in. I will let you
> decide if only QUIC or both are relevant in the discussion.
> >
> > Next CT4 WG meetings:
> > 3GPP TSG CT4#95           11th – 15th November 2019       Reno, US
> > 3GPP TSG CT4#96           24th – 28th February 2020          Sophia
> Antipolis, FR
> >
> > It would be good to receive an official feedback at the latest for the
> February meeting, where the study will be concluded (at least for this
> release).
> >
> > Regards,
> >
> >
> > Lionel Morand
> > Chair of 3GPP TSG CT
> > 3GPP Liaison Person to IETF
> > Chair of IETF Dime and Radext WGs
> > Core Network Senior Architect and Diameter expert
> > Cell. +33 6 07 75 89 36 <+33%206%2007%2075%2089%2036>
> > [email-masked]
> >
> >
> >
> >
> >
> _________________________________________________________________________________________________________________________
> >
> > Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> > pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> > Orange decline toute responsabilite si ce message a ete altere, deforme
> ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> > they should not be distributed, used or copied without authorisation.
> > If you have received this email in error, please notify the sender and
> delete this message and its attachments.
> > As emails may be altered, Orange is not liable for messages that have
> been modified, changed or falsified.
> > Thank you.
> >
> > <Liaison Statement on QUIC network level troubleshooting
> capabilities.docx>
>
>

---

From: "Lubashev, Igor" <[email-masked]>
Date: Mon, 14 Oct 2019 12:09:14 +0000

Christian, do you believe that the outcome of the tsvwg discussion and the contents of draft-ietf-Ztsvwg-transport-encrypt will be timely enough to affect QUIC v1?  If not, a discussion in QUIC WG would have a better chance of being timely for QUIC v1.
 
3GPP consists of Internet players who are mostly absent from QUIC WG, and their concerns should be taken seriously, since their networks carry a large portion of QUIC traffic.  It would require everyone’s efforts to ensure that QUIC can grow from a single-digit percentage to the majority of Internet traffic with QUIC v1.
 
Igor
 
From: Christian Huitema <[email-masked] <mailto:[email-masked]>> 
Sent: Saturday, October 12, 2019 11:41 PM
This topic, troubleshooting capabilities supported by QUIC compared to the ones available with TCP, is currently being debated in the transport area working group (tsvwg). The TSVWG draft (https://datatracker.ietf.org/doc/draft-ietf-tsvwg-transport-encrypt/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dtsvwg-2Dtransport-2Dencrypt_&d=DwMD-g&c=96ZbZZcaMF4w0F4jpN6LZg&r=Djn3bQ5uNJDPM_2skfL3rW1tzcIxyjUZdn_m55KPmlo&m=Lnp-EOYUknzse809dTMZYzMs55FSJEDbEYvz9ZPWGuo&s=DRWGiEADVTxFXLm2BWHCFSJQKLTHtSdQ4d2frGEGouI&e=>) is a general discussion of "The Impact of Transport Header Confidentiality on Network Operation and Evolution of the Internet".

It might be a good idea for the IETF to have that discussion at just one place.

-- Christian huitema

On 10/12/2019 1:24 AM, [email-masked] <mailto:[email-masked]> wrote:
Hi,
 
Please find enclosed a liaison statement from the 3GPP CT WG 4 (CT4).
This WG is actually studying the introduction of QUIC as transport protocol instead of HTTP/2 in the 5G core network.
The WG has some questions regarding the troubleshooting capabilities supported by QUIC compared to the ones available with TCP.
 
The LS is officially addressed to the QUIC WG. However, it was highlighted that httpbis WG could also be interested in. I will let you decide if only QUIC or both are relevant in the discussion.
 
Next CT4 WG meetings:
3GPP TSG CT4#95           11th – 15th November 2019       Reno, US
3GPP TSG CT4#96           24th – 28th February 2020          Sophia Antipolis, FR
 
It would be good to receive an official feedback at the latest for the February meeting, where the study will be concluded (at least for this release).
 
Regards,

Lionel Morand 
Chair of 3GPP TSG CT
3GPP Liaison Person to IETF
Chair of IETF Dime and Radext WGs 
Core Network Senior Architect and Diameter expert 
Cell. +33 6 07 75 89 36  <https://urldefense.proofpoint.com/v2/url?u=https-3A__monsi.sso.francetelecom.fr_index.asp-3Ftarget-3Dhttp-253A-252F-252Fclicvoice.sso.francetelecom.fr-252FClicvoiceV2-252FToolBar.do-253Faction-253Ddefault-2526rootService-253DSIGNATURE-2526to-253D0607758936&d=DwMD-g&c=96ZbZZcaMF4w0F4jpN6LZg&r=Djn3bQ5uNJDPM_2skfL3rW1tzcIxyjUZdn_m55KPmlo&m=Lnp-EOYUknzse809dTMZYzMs55FSJEDbEYvz9ZPWGuo&s=F2f6eijakCDMZfPDciLaCuzHubXGQ1onCA7xdxhrcMs&e=>
[email-masked] <mailto:[email-masked]>

---

From: <[email-masked]>
Date: Mon, 14 Oct 2019 12:09:15 +0000

Hi,
 
As said below, QUIC would be used only in the control plane and not for e2e user traffic.
 
Regards,
 
Lionel
 
De : Ian Swett [mailto:[email-masked]] 
Envoyé : lundi 14 octobre 2019 00:35
À : Lars Eggert
Cc : MORAND Lionel TGI/OLN; [email-masked]; [email-masked]; [email-masked]; Gonzalo Camarillo; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Objet : Re: LS from 3GPP on QUIC network level troubleshooting capabilities
 
If the main concern is inability to passively measure packet loss and as Lars said this is not for end-to-end user traffic(so support for certain extensions could be assumed), then this could be a good test case for draft-ferrieuxhamchaoui-quic-lossbits <https://tools.ietf.org/html/draft-ferrieuxhamchaoui-quic-lossbits-01> to prove it works as intended and see if the mechanism needs any changes.
 
On Sun, Oct 13, 2019 at 4:34 AM Lars Eggert <[email-masked] <mailto:[email-masked]>> wrote:
Hi Lionel,

> Please find enclosed a liaison statement from the 3GPP CT WG 4 (CT4).

I do not see this liaison statement posted at https://datatracker.ietf.org/liaison/ <https://datatracker.ietf.org/liaison/>. Please make sure to submit it via the regular process, to keep all relevant entities in the loop.

> The WG has some questions regarding the troubleshooting capabilities supported by QUIC compared to the ones available with TCP.

Based on my (limited) understanding of the 5G architecture, this use of QUIC would be as a protocol for carrying control information inside a 5G network control plane. In other words, it is not about the end-to-end use of QUIC over paths that traverse 5G networks. Is my understanding correct?

Thanks,
Lars

> Cell. +33 6 07 75 89 36 <tel:+33%206%2007%2075%2089%2036>
> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or privileged information that may be protected by law;
> If you have received this email in error, please notify the sender and delete this message and its attachments.
> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
> Thank you.
> 
> <Liaison Statement on QUIC network level troubleshooting capabilities.docx>

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.