Subject: RE: Call for Adoption: Extensible Prioritization Scheme for HTTP

From: Mike Bishop <[email-masked]>
Date: Thu, 5 Dec 2019 20:32:56 +0000

I also support adoption.  The e2e/h2h distinction is tricky, and beyond the immediate usefulness of this work, it’s also a good venue in which to work out the distinction between those two concepts.

From: Patrick McManus <[email-masked]>
Sent: Thursday, November 21, 2019 4:23 AM
To: Tommy Pauly <[email-masked]>
Cc: HTTP Working Group <[email-masked]>
Subject: Re: Call for Adoption: Extensible Prioritization Scheme for HTTP

I strongly support adoption. We don't want to end up with a gap in client priority due to the h3 transition so timeliness matters. The broad input it has already received makes it the right candidate for the WG to begin work on - the core tension around e2e vs hop-2-hop is one we have in a number of places and is something we might just have to focus on how we can put as much of it into upgradable pieces that we can replace later. In any event, that's something for the WG to deal with after adoption.

-Patrick

On Thu, Nov 21, 2019 at 3:31 PM Tommy Pauly <[email-masked]<mailto:[email-masked]>> wrote:
Hello HTTPbis,

During our IETF 106 meetings, we received updates from the design team for updating HTTP's priority hinting mechanism, with the goals of defining priorities for HTTP/3 and allowing this scheme to be backported to HTTP/2.

The output of the design team is documented in this draft: https://tools.ietf.org/html/draft-kazuho-httpbis-priority-04

This draft defines:
- A SETTINGS parameter to disable the HTTP/2 priority mechanism
- Two priority values, urgency (0-7), and incremental (boolean)
- Mechanisms to communicate these priority values using headers and frames

This email begins a call for Working Group adoption of this draft. Note that adoption indicates that we, as a working group, want to use draft-kazuho-httpbis-priority as a basis for the definition of priorities for HTTP/3. There is still ongoing discussion that will continue, specifically around the mechanism for end-to-end and hop-by-hop signaling.

This call will end on Friday, December 6. Please reply to this email and indicate whether or not you believe we should adopt this document!

Best,
Tommy & Mark

---

From: Willy Tarreau <[email-masked]>
Date: Fri, 6 Dec 2019 04:17:06 +0100

On Thu, Dec 05, 2019 at 08:32:56PM +0000, Mike Bishop wrote:
> I also support adoption.  The e2e/h2h distinction is tricky, and beyond the
> immediate usefulness of this work, it's also a good venue in which to work
> out the distinction between those two concepts.

Same for me.

Willy

---

From: Roberto Polli <[email-masked]>
Date: Fri, 6 Dec 2019 11:42:37 +0100

I support adoption.

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 13 Dec 2019 08:45:18 -0800

Hello all,

Thanks for the feedback received in the call for adoption! We will be adopting this document into the working group. We have asked Lucas and Kazuho to continue as editors of the document.

Authors, please submit a draft-ietf-httpbis-priority-00 when ready; we'll also move this document into the WG GitHub.

As mentioned previously, this work is an important piece of deploying HTTP/3. As such, I would like to encourage that we try to converge on open design issues quickly (QUICly?). The adoption call did highlight that the main concern is around the use of headers or frames for signaling. If anyone has thoughts on this issue, please take them to the list and/or GitHub.

Best,
Tommy & Mark

> On Nov 20, 2019, at 11:28 PM, Tommy Pauly <[email-masked]> wrote:
> 
> Hello HTTPbis,
> 
> The output of the design team is documented in this draft: https://tools.ietf.org/html/draft-kazuho-httpbis-priority-04 <https://tools.ietf.org/html/draft-kazuho-httpbis-priority-04>
> 
> This draft defines: