Subject: Working Group Last Call: Structured Headers for HTTP

From: Tommy Pauly <[email-masked]>
Date: Wed, 29 Jan 2020 09:11:20 -0800

Hi all,

The Structured Headers draft was updated yesterday, and Mark (as author) let me know that the authors believe this is ready for last call. The issues list is down to zero, so it's a good time for the working group to take a careful read-through the document, and get it progressed!

This email starts a working group last call, which will end on Friday, February 21. Please review the document and reply to the list with your comments (or file an issue), and state whether you think this document is ready for publication.

The current version of the document can be found here: https://tools.ietf.org/html/draft-ietf-httpbis-header-structure-15

Best,
Tommy

---

From: Rob Sayre <[email-masked]>
Date: Wed, 29 Jan 2020 11:29:06 -0800

On Wed, Jan 29, 2020 at 9:14 AM Tommy Pauly <[email-masked]> wrote:

> Hi all,
>
> The Structured Headers draft was updated yesterday, and Mark (as author)
> let me know that the authors believe this is ready for last call. The
> issues list is down to zero, so it's a good time for the working group to
> take a careful read-through the document, and get it progressed!
>

I think the technical aim of the document is fine, but it needs another
round just looking for editorial nits. I found small things like:

Duplicate parsing steps (#2 and #6):
https://tools.ietf.org/html/draft-ietf-httpbis-header-structure-15#section-4.2

and duplicate references. I believe the document may also need a collected
ABNF grammar. There are references to things like "item_or_inner_list" that
indicate there probably is a grammar, but it's just not in the document. It
may also be worthwhile to add a PEG grammar to the test repository before
publication, so that it's clear that the specification is straightforward
to parse with a recursive descent parser (I would use Pest[0]).

thanks,
Rob

[0] https://github.com/pest-parser/pest

---

From: Rob Sayre <[email-masked]>
Date: Wed, 29 Jan 2020 11:35:04 -0800

> https://tools.ietf.org/html/draft-ietf-httpbis-header-structure-15#section-4.2

Ah, I see this is intentional, since the other sections say "input_string
is modified to remove the parsed value."

I am not sure this is a good way to specify this behavior, but it is
consistent and does not rise to level of an objection.

thanks,
Rob