Subject: Working on H3 priorities

From: Tommy Pauly <[email-masked]>
Date: Wed, 08 Jan 2020 18:31:13 -0800

Hello HTTPbis,

I wanted to highlight to the group that the recently adopted HTTP priorities document, "Extensible Prioritization Scheme for HTTP", is being tracked on our GitHub:

Editor's copy: https://httpwg.org/http-extensions/draft-ietf-httpbis-priority.html
Issues list: https://github.com/httpwg/http-extensions/issues?q=is%3Aopen+is%3Aissue+label%3Apriority

You may notice that our issues list is currently empty! =)

During our call for adoption, there were several comments regarding concerns about which mechanism to use to communicate the priority hints. I would like to encourage anyone who has ideas or questions in this space to open an issue, or start a discussion on the list.

Best,
Tommy

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 09 Jan 2020 15:47:04 +1100

On Thu, Jan 9, 2020, at 13:31, Tommy Pauly wrote:
> Issues list: 
> https://github.com/httpwg/http-extensions/issues?q=is%3Aopen+is%3Aissue+label%3Apriority
> 

I provided a few for you.  No doubt I missed some.

The big one here is the question about frames vs. header fields vs. both.

BTW, if anyone interested in this topic is NOT going to the QUIC interim, it might be good to inform someone who is.  It seems likely that we'll use the opportunity to make some progress on this issue and we don't want to exclude anyone from that discussion.

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 08 Jan 2020 20:52:22 -0800

> On Jan 8, 2020, at 8:47 PM, Martin Thomson <[email-masked]> wrote:
> 

Thanks, Martin! Also, I realize my link was incorrect. It should be:

https://github.com/httpwg/http-extensions/issues?q=is%3Aissue+is%3Aopen+label%3Apriorities