Subject: zstd PMCE for WebSocket

From: Felipe Gasper <[email-masked]>
Date: Wed, 22 Apr 2020 12:41:20 -0400

Hello,

	Has there been any motion on a standard PMCE to implement zstd compression for WebSocket?

	Thank you!

-Felipe Gasper

---

From: "W. Felix Handte" <[email-masked]>
Date: Thu, 23 Apr 2020 12:36:26 -0400

Hi Felipe,

You've sent this email just in time! We are wrapping up an update to the 
Zstandard RFC right now. So I can include a section that specifies and 
registers a PMCE if that would be helpful.

- Felix

---

From: Felipe Gasper <[email-masked]>
Date: Thu, 23 Apr 2020 12:46:36 -0400

Hi Felix,

	Great to hear! Yes, a zstd PMCE would be useful. Let me know if I can help in any way.

cheers,
-Felipe Gasper

> On Apr 23, 2020, at 12:36 PM, W. Felix Handte <[email-masked]> wrote:
> 
> Hi Felipe,
> 
> You've sent this email just in time! We are wrapping up an update to the Zstandard RFC right now. So I can include a section that specifies and registers a PMCE if that would be helpful.
> 
> - Felix
>

---

From: "W. Felix Handte" <[email-masked]>
Date: Thu, 23 Apr 2020 17:49:20 -0400

Felipe and I discussed some off-list. It seems like this topic is better 
treated separately from the Zstd draft currently in progress, so the two 
of us are going to spin up a new document here:

https://github.com/felixhandte/draft-handte-httpbis-zstd-pcme

Contributions/collaborators are welcome!

- Felix

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 24 Apr 2020 10:48:11 +1000

Hi,

That sounds great, but please note that this is not the appropriate place to discuss WebSockets; that's [email-masked], or _maybe_ webtransport@.

Cheers,

> On 24 Apr 2020, at 7:49 am, W. Felix Handte <[email-masked]> wrote:
> 
> Felipe and I discussed some off-list. It seems like this topic is better treated separately from the Zstd draft currently in progress, so the two of us are going to spin up a new document here:
> 

--
Mark Nottingham   https://www.mnot.net/