Subject: I-D Action: draft-ietf-httpbis-message-signatures-00.txt

From: [email-masked]
Date: Fri, 10 Apr 2020 16:08:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the HTTP WG of the IETF.

        Title           : Signing HTTP Messages
        Authors         : Annabelle Backman
                          Justin Richer
                          Manu Sporny
	Filename        : draft-ietf-httpbis-message-signatures-00.txt
	Pages           : 38
	Date            : 2020-04-10

Abstract:
   This document describes a mechanism for creating, encoding, and
   verifying digital signatures or message authentication codes over
   content within an HTTP message.  This mechanism supports use cases
   where the full HTTP message may not be known to the signer, and where
   the message may be transformed (e.g., by intermediaries) before
   reaching the verifier.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-httpbis-message-signatures/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-httpbis-message-signatures-00
https://datatracker.ietf.org/doc/html/draft-ietf-httpbis-message-signatures-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Justin Richer <[email-masked]>
Date: Tue, 14 Apr 2020 11:21:27 -0400

A note to the WG: This draft is a copy of the ID that Annabelle had previously put together for the consensus call. We are now working on translating it into the the Markdown format and starting on the changes discussed within the document. 

Thanks to everyone who’s commented so far, we’ll be starting to work on actual issues once we have things in the right format and moved to the right repository within the HTTP WG. 

 — Justin

> On Apr 10, 2020, at 7:08 PM, [email-masked] wrote:
> 
>

---

From: Julian Reschke <[email-masked]>
Date: Tue, 14 Apr 2020 18:52:00 +0200

On 14.04.2020 17:21, Justin Richer wrote:
> ...

FWIW, you don't *need* to transform to Markdown...

Best regards, Julian

---

From: Roberto Polli <[email-masked]>
Date: Tue, 14 Apr 2020 19:37:42 +0200

Hi Justin,

Il giorno mar 14 apr 2020 alle ore 17:25 Justin Richer
<[email-masked]> ha scritto:
> A note to the WG: This draft is a copy of the ID that Annabelle had previously put together for the consensus call.
> We are now working on translating it into the the Markdown format
you can check if this can help in some way,
- https://github.com/richanna/request-signing/blob/191a9b43954ceee4dfa1149723a8fa19cf3f448c/draft-richanna-http-message-signatures.md

> and starting on the changes discussed within the document.
IIRC the first version of the file should be the markdown copy of the file
that was voted for consensus, and all the changes should happen
on the httpwg repo.

Have a nice day,
R.

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Tue, 14 Apr 2020 21:14:43 +0000

That is our intent. The first commit will match the text presented to and adopted by the working group.

–
Annabelle Backman (she/her)
AWS Identity
https://aws.amazon.com/identity/

On 4/14/20, 10:42 AM, "Roberto Polli" <[email-masked]> wrote:

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

Hi Justin,

Have a nice day,
R.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 15 Apr 2020 12:17:58 +1000

Great, thanks Justin. Look forward to seeing the draft in the repo (like Julian says, it doesn't have to be Markdown, although many find it easier).

In the meantime, I've created the 'signatures' label for issues: <https://github.com/httpwg/http-extensions/issues?q=is%3Aopen+is%3Aissue+label%3Asignatures>

Cheers,

> On 15 Apr 2020, at 1:21 am, Justin Richer <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Justin Richer <[email-masked]>
Date: Wed, 15 Apr 2020 06:47:30 -0400

Understood re: format, but we want to make collaboration easier, and translating to the format used by the rest of the drafts in the repository is a simple thing we can do to facilitate that. 

Thanks,
 — Justin

> On Apr 14, 2020, at 10:17 PM, Mark Nottingham <[email-masked]> wrote:
>