Subject: Structured Fields: last-minute corrections

From: Mark Nottingham <[email-masked]>
Date: Mon, 5 Oct 2020 17:03:10 +1100

Hi everyone,

SF is in the RFC Editor queue, and I assume will be in AUTH48 soon.

In the meantime, keen readers have identified a couple of issues in the spec:

* https://github.com/httpwg/http-extensions/issues/1269
* https://github.com/httpwg/http-extensions/issues/1273

Both seem like fairly straightforward specification (i.e., editor; sorry!) errors. Please take a look (especially at the suggested fixes); unless I hear pushback, we'll apply the fixes that those issues settle on during AUTH48.

Cheers,

P.S. We also have <https://github.com/httpwg/http-extensions/issues/1251>, but I don't see that as an issue that's worth addressing at this late stage. If I've read that wrongly and folks feel strongly about it, please indicate on the issue.

--
Mark Nottingham   https://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 5 Oct 2020 08:57:26 +0200

Am 05.10.2020 um 08:03 schrieb Mark Nottingham:
> ...

I think it would be better to gather consensus, apply them in Git, and
optimally submit a new draft.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 5 Oct 2020 18:02:25 +1100

> On 5 Oct 2020, at 5:57 pm, Julian Reschke <[email-masked]> wrote:
> 

Given that the RFC Editor has already started processing the draft, I don't think submitting a new draft is practical; their copy will already be different than what we have. However, we can give them a diff to make it as clear as possible what the changes are (but that would happen in AUTH48 anyway).

Cheers,

---

From: Julian Reschke <[email-masked]>
Date: Mon, 5 Oct 2020 09:36:25 +0200

> Given that the RFC Editor has already started processing the draft, I don't think submitting a new draft is practical; their copy will already be different than what we have. However, we can give t…

In a perfect world, the markdown source in Git should reflect the
current RFC Editor changes, so at the end we have source that reflects
that the RFC says.

Best regards, Julian

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 05 Oct 2020 10:15:19 -0700

Agreed that a new draft version is not needed, and these can be applied by the editor (before or after AUTH48).

The changes to the document are minor, and I believe the suggestions do not change the meaning or intention of the specification, but merely clarify.

If there is anyone in the working group who disagrees with the suggested changes, please speak up!

Best,
Tommy

> On Oct 5, 2020, at 12:02 AM, Mark Nottingham <[email-masked]> wrote:
> 
> 
>

---

From: Matthew Kerwin <[email-masked]>
Date: Tue, 6 Oct 2020 07:32:04 +1000

On Tue., 6 Oct. 2020, 03:21 Tommy Pauly, <[email-masked]> wrote:

> The changes to the document are minor, and I believe the suggestions do
> not change the meaning or intention of the specification, but merely
> clarify.
>

I commented on #1273, I don't understand the proposed ABNF. However I
generally agree to the approach on both issues (and am happy to ignore the
third), as long as that bit of syntax is correct.

Cheers
Matthew Kerwin