Subject: [Technical Errata Reported] RFC7230 (6333)

From: RFC Errata System <[email-masked]>
Date: Fri, 13 Nov 2020 09:12:08 -0800 (PST)

The following errata report has been submitted for RFC7230,
"Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6333

--------------------------------------
Type: Technical
Reported by: Jeff Brower <[email-masked]>

Section: 3.2.6 (PDF)

Original Text
-------------
     tchar          = "!" / "#" / "$" / "%" / "&" / "’" / "*"
                    / "+" / "-" / "." / "^" / "_" / "‘" / "|" / "~"

Corrected Text
--------------
     tchar          = "!" / "#" / "$" / "%" / "&" / "'" / "*"
                    / "+" / "-" / "." / "^" / "_" / "`" / "|" / "~"

Notes
-----
The generated PDF contains misleading right and left quotes (U+8217 and U+8216), which are not ASCII characters. The text and html versions of the RFC have the correct apostrophe and grave accent characters (' and `).

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7230 (draft-ietf-httpbis-p1-messaging-26)
--------------------------------------
Title               : Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing
Publication Date    : June 2014
Author(s)           : R. Fielding, Ed., J. Reschke, Ed.
Category            : PROPOSED STANDARD
Source              : Hypertext Transfer Protocol Bis APP
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Julian Reschke <[email-masked]>
Date: Fri, 13 Nov 2020 18:27:58 +0100

Am 13.11.2020 um 18:12 schrieb RFC Errata System:
> ...

This is not an error. The published text file is correct, and so is - as 
far as I can tell - <https://www.rfc-editor.org/rfc/pdfrfc/rfc7230.txt.pdf>.

RFC-Editor, please reject.

Jeff: what exact PDF are you looking at?

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Fri, 13 Nov 2020 20:22:29 +0100

Am 13.11.2020 um 19:16 schrieb Jeff Brower:
> The PDF you linked does contain the invalid characters:
> image.png
> 
> Notice the right and left quotes (6th and 13th items in this list) 
> rather than apostrophe and grave accent found in the text/html versions:
> image.png
> 
> Regards,
> Jeff

Funny enough, they look exactly the same in the image you attached, but 
yes, you are right, the PDF is incorrect.

I recommend reporting this as a problem with the code that generates the 
PDFs from plain text. It definitively is not a problem in the published 
plain text RFC.

Best regards, Julian

---

From: Barry Leiba <[email-masked]>
Date: Fri, 13 Nov 2020 14:45:53 -0500

Right: errata reports only cover the canonical published RFC, which is
the .txt file at rfc-editor.org.  So I'm going to mark this "Rejected"
for that reason.  If there's a problem in the generation of the .pdf
version, that needs to be reported to the RFC Editor separately
(they'll see this discussion, of course, so that might be sufficient).

Barry

---

From: Willy Tarreau <[email-masked]>
Date: Sat, 14 Nov 2020 08:11:26 +0100

On Fri, Nov 13, 2020 at 06:27:58PM +0100, Julian Reschke wrote:
> > Notes
> > -----
> > The generated PDF contains misleading right and left quotes (U+8217 and
> > U+8216), which are not ASCII characters. The text and html versions of the
> > RFC have the correct apostrophe and grave accent characters (' and `).
> > ...
> 
> This is not an error. The published text file is correct, and so is - as far
> as I can tell - <https://www.rfc-editor.org/rfc/pdfrfc/rfc7230.txt.pdf>.

For me that PDF is wrong as well, two same quotes (when viewed in my
browser or in xpdf)! However, if I select the text and copy-paste it
here in my terminal, the second one is turned to a back quote:

   tchar          = "!" / "#" / "$" / "%" / "&" / "'" / "*"
                  / "+" / "-" / "." / "^" / "_" / "`" / "|" / " #"
                  / DIGIT / ALPHA
                  ; any VCHAR, except delimiters

Ah the joy of extended character sets! I didn't imagine they would one
day go as far as corrupting standards! One day we'll probably see emojis
there :-/

Willy

---

From: Martin J. Dürst <[email-masked]>
Date: Sat, 14 Nov 2020 16:14:10 +0900

For what it's worth, the Erratum is also technically incorrect, in that 
it says:
right and left quotes (U+8217 and U+8216)

The two characters are, in HTML/XML notation:
     Hexadecimal: &#x2019;&#x2018;
or
     Decimal: &#8217;&#8216;

U+-notation is hexadecimal, so this should be U+2019 and U+2018.
U+8217 and U+8216 are two Kanji, 舗 舖.

https://r12a.github.io/app-conversion/ is a very convenient tool for 
such checks.

Regards,   Martin.

---

From: Willy Tarreau <[email-masked]>
Date: Sat, 14 Nov 2020 20:02:33 +0100

On Sat, Nov 14, 2020 at 01:52:57PM -0500, John R. Levine wrote:
> On Sat, 14 Nov 2020, Willy Tarreau wrote:
> That PDF was generated mechanically from the definitive text RFC.  We use a
> generic text to PDF converter (I can check which one) and it's not
> surprising that it uses heuristics to guess which kind of quote to use, nor
> is it surprising that it sometimes guesses wrong in technical text.

But here there are clearly two distinct characters, one is 0x27 and the
other one is 0x60. Both are perfectly printable ASCII characters, which
is why this is particularly surprising.

> If you want to copy and paste ABNF, for heaven's sake copy it from the
> definitive text version, not the PDF.

Sure but when just checking for a message validity, the PDF or even a
printed copy are commonly used as well.

Best regards,
Willy

---

From: Julian Reschke <[email-masked]>
Date: Thu, 19 Nov 2020 11:09:25 +0100

Am 14.11.2020 um 19:52 schrieb John R. Levine:
> That PDF was generated mechanically from the definitive text RFC.  We 
> use a generic text to PDF converter (I can check which one) and it's not 
> surprising that it uses heuristics to guess which kind of quote to use, 
> nor is it surprising that it sometimes guesses wrong in technical text.
 > ...

FWIW: we should check what tool is doing that, and whether we can stop 
it from trying to be "smart".

Best regards, Julian