Subject: Re: Call for Adoption: SEARCH method

From: Mitar <[email-masked]>
Date: Tue, 1 Dec 2020 18:46:56 -0800

Hi!

I would prefer if GET semantics get extended. This is already
something some already use (e.g., ElasticSearch). Maybe we just have
to find a way for client/server/caches to opt-in or declare opt-in.

As a compromise, I like this proposal as well. But I would propose
that we do not extend existing SEARCH verb but instead standardize a
new QUERY verb. Maybe picking a name is bikesheding, but I find both
SEARCH and REPORT mentioning until now too semantically specific. To
me this is really like GET, just with payload, which means instead of
GETting a resource based on URI, we are QUERYing it because we need
more than just an URI for the query.

I strongly feel that the response should be cacheable. Otherwise why
not just use POST?

Mitar

On Tue, Nov 3, 2020 at 5:11 PM Mark Nottingham <[email-masked]> wrote:
>
> As discussed in the October 202 Interim, this is a Call for Adoption for the HTTP SEARCH method draft:
>   https://tools.ietf.org/html/draft-snell-search-method-02
>
> Please indicate whether you support adoption in response to this e-mail; information about intent to implement (or use) it is also useful.
>
> The Call for Adoption will end on 18 November 2020.
>
> Cheers,
>
> Mark and Tommy
>
>

-- 
http://mitar.tnode.com/
https://twitter.com/mitar_m

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 01 Dec 2020 19:52:50 -0800

Thanks for all of the feedback and detailed discussion on draft-snell-search-method!

Based on the input, we believe that the working group has consensus to adopt this item. Many of the details, including the method name, will continue to be discussed as this is adopted, but the scope of work is to define a method that has the behavior of a GET with a body.

Best,
Tommy & Mark

> On Nov 3, 2020, at 5:07 PM, Mark Nottingham <[email-masked]> wrote:
>

---

From: James M Snell <[email-masked]>
Date: Tue, 1 Dec 2020 20:08:39 -0800

That's very good news. More than happy to leave the draft in the working
group's more than capable hands :) ... I'm not expecting to be able to
dedicate much time (if any) to the discussions moving it forward but will
definitely be following the progress.

On Tue, Dec 1, 2020, 19:55 Tommy Pauly <[email-masked]> wrote:

> Based on the input, we believe that the working group has consensus to
> adopt this item. Many of the details, including the method name, will
> continue to be discussed as this is adopted, but the scope of work is to
> define a method that has the behavior of a GET with a body.
>
> Best,
> Tommy & Mark
>
> > Please indicate whether you support adoption in response to this e-mail;
> information about intent to implement (or use) it is also useful.
> >