Subject: Alt-Svc interaction with HTTPS/SVCB DNS records

From: Erik Nygren <[email-masked]>
Date: Thu, 17 Jun 2021 19:00:07 -0400

The HTTPS/SVCB DNS record draft past WGLC in DNSOP.
There has been a bunch of discussion in this pull-request recently
on improving the interaction between Alt-Svc and HTTPS RRs.
Much of the discussion is here:

   https://github.com/MikeBishop/dns-alt-svc/pull/329/files

Most of the resulting text is now in -06 in Section 8.3:

https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-svcb-https-06#section-8.3

Given how this is at the borderline of HTTP Alt-Svc and DNS,
we had a discussion in the Interim today that this could use
more visibility from the HTTP WG.

More broadly, while it hasn't changed recently, Section 6.1
(for "alpn" SvcParam handling) takes into account some experience
from clients with challenges with ALPN handling with Alt-Svc
and some of the proposed text in it may want to be included
in an Alt-Svc-bis:

https://datatracker.ietf.org/doc/html/draft-ietf-dnsop-svcb-https-06#section-6.1

The chairs are discussing whether we may want to have a call on this,
but in the meantime feedback and comments are most welcome.

      Erik

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 18 Jun 2021 09:15:52 +1000

I think that it would be helpful to write a page or two about the motivation and rationale behind the decision.  That text is quite dense and not at all clear.  An explanation of how the pieces fit together at a high level and the consequences of that for the design of the protocol (and it's impact on how people configure servers or build clients) would be very helpful.

---

From: Mike Bishop <[email-masked]>
Date: Tue, 29 Jun 2021 15:29:03 +0000

There's a bit of discussion on the interaction between the two documents in https://github.com/MikeBishop/alt-svc-bis/pull/1/files.  Hopefully, this helps frame the discussion for people.  If there's something key you think isn't included here, please suggest additions to the PR.

-----Original Message-----
From: Martin Thomson <[email-masked]> 
Sent: Thursday, June 17, 2021 7:16 PM
To: Erik Nygren <[email-masked]>; [email-masked] Group <[email-masked]>; Mike Bishop <[email-masked]>; Ben Schwartz <[email-masked]>
Subject: Re: Alt-Svc interaction with HTTPS/SVCB DNS records

On Fri, Jun 18, 2021, at 09:00, Erik Nygren wrote:
> There has been a bunch of discussion in this pull-request recently on 
> improving the interaction between Alt-Svc and HTTPS RRs.
> Given how this is at the borderline of HTTP Alt-Svc and DNS, we had a 
> discussion in the Interim today that this could use more visibility 
> from the HTTP WG.
> 
> More broadly, while it hasn't changed recently, Section 6.1 (for 
> "alpn" SvcParam handling) takes into account some experience from 
> clients with challenges with ALPN handling with Alt-Svc and some of 
> the proposed text in it may want to be included in an Alt-Svc-bis:
> 
>