Subject: Fwd: Request to Charter a New Working Group: Oblivious HTTP (OHTTP)

From: Mark Nottingham <[email-masked]>
Date: Tue, 8 Jun 2021 15:36:01 +1000

FYI, if you're not on one of the lists that received this news.

> Begin forwarded message:
> 
> From: IESG Secretary <[email-masked]>
> Subject: Request to Charter a New Working Group: Oblivious HTTP (OHTTP)
> Date: 8 June 2021 at 4:30:12 am AEST
> To: "IETF Announcement List" <[email-masked]>
> Cc: [email-masked]
> Reply-To: [email-masked]
> Archived-At: <https://mailarchive.ietf.org/arch/msg/ietf-announce/SptL9Iucx3lKTMSSLDI6K0FOW70>
> 
> The IESG has received a request to charter a new working group, 
> Oblivious HTTP (OHTTP).  The proposed charter, which is a work in 
> progress, can be found here:
> 
> <https://datatracker.ietf.org/doc/charter-ietf-ohttp/>
> 
> The charter will be discussed on the <[email-masked]> mailing list,
> which can be subscribed to here:
> 
> <https://www.ietf.org/mailman/listinfo/ohttp>
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

--
Mark Nottingham   https://www.mnot.net/

---

From: [email-masked]
Date: Tue, 08 Jun 2021 21:53:15 +1200

Thanks. Though I'm wondering why this is a new WG.

Amos

On 2021-06-08 17:36, Mark Nottingham wrote:
>> Archived-At:
> <https://mailarchive.ietf.org/arch/msg/ietf-announce/SptL9Iucx3lKTMSSLDI6K0FOW70>
>>

---

From: Willy Tarreau <[email-masked]>
Date: Tue, 8 Jun 2021 14:42:17 +0200

> Thanks. Though I'm wondering why this is a new WG.

Same here. We'd need to make sure that we don't restart something
"http-like" but incompatible like hybi a decade ago which started out
of the HTTP WG and had to be redesigned once some HTTP participants
put their nose there :-/

Willy

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 09 Jun 2021 08:53:32 +1000

> Thanks. Though I'm wondering why this is a new WG.

We could have decided to do all the work in this working group.  That was an option that was considered during the meeting where this was discussed.  The general sense at the time was that the bulk of the work was security-related.  This (ab)uses HTTP, but it is not modifying HTTP, so a separate group is fine.  This group also has a very large slate of items already.  And in recent years the IESG has preferred to use small working groups where possible.

So that all stacked up in favour of a new working group.

Obviously the experience and expertise here are relevant, so any input this group has will be considered and I expect that this list will be kept up to date.