Subject: Éric Vyncke's No Objection on draft-ietf-httpbis-targeted-cache-control-03: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Thu, 13 Jan 2022 06:22:42 -0800

Éric Vyncke has entered the following ballot position for
draft-ietf-httpbis-targeted-cache-control-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-httpbis-targeted-cache-control/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for the work put into this document. Even not being a specialist, the
interest of the document is clear (and the document itself is easy to read).

Please find below some non-blocking COMMENT points (but replies would be
appreciated even if only for my own education), and some nits.

Special thanks to Tommy Pauly for the shepherd's write-up including the section
about the WG consensus (and be clear about that I-D is mainly the work of 3
CDNs).

I hope that this helps to improve the document,

Regards,

-éric

Generic comment: while the document appears to be very generic (barring my
comment below), it actually only requests IANA for a "CDN-Cache-Control"
targeted header, I.e., should this be reflected in the title ?

-- Section 1 --
Is there any reason why the enterprise caches/proxies are not mentioned in the
first § ?

-- Section 2.2 --
As the target list is merely a local decision, why are the behaviours specified
as a "MUST" and not as a "SHOULD" ? I.e., after all it is all local decisions
and there could be local constraints/restrictions. There is also no negotiation
between the cache and its upstream cache/origin that could contractually bind
the 2 parties.

== NITS ==

-- Section 1 --
In "a Web site", does "web" really deserve being capitalised ?

-- Section 2.1 --
In "as if the field were not present" should field be in the plural form ?

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 14 Jan 2022 11:08:43 +1100

HI Éric,

Thanks for the comments; responses below.

> On 14 Jan 2022, at 1:22 am, Éric Vyncke via Datatracker <[email-masked]> wrote:
> 

Originally it was, but we got some strong representations that it should be a more broad framework, rather than just for that. "Targeted HTTP Cache Control and the CDN-Cache-Control Header Field" seems a bit wordy...

> Is there any reason why the enterprise caches/proxies are not mentioned in the

Speaking very generally, there usually isn't a relationship between those devices and the services they're caching, so there isn't a strong motivation to target directives at them specifically. That use isn't prohibited, of course -- it's just not very common, so we didn't think it worth calling out.

> between the cache and its upstream cache/origin that could contractually bind

The behaviour needs to be deterministic (there's a long history of caches taking liberty with directives, at the expense of interoperability). That's not to say it's inflexible; the target list is under control of the cache, and can be adapted on a per-request basis. It's just that when a request 'hits' the target list, it needs to operate in a deterministic fashion.

Also, if we specified as SHOULD, we'd need to describe what conditions satisfy the SHOULD...

> In "a Web site", does "web" really deserve being capitalised ?

It's this way because I've written a lot for the W3C, where 'Web' is still the norm. I'm reasonably sure the RPC will make a decision that's consistent with our style. :)

> In "as if the field were not present" should field be in the plural form ?

No, I don't think so.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 15 Jan 2022 12:11:04 +1100

> On 15 Jan 2022, at 1:35 am, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 
> EV> how can it be deterministic (as seen by upstream/origin) when the target list is local. Still wondering but not blocking.

In the sense that once the semantics are invoked, they're consistent. The target list only affects invocation, not the semantics themselves.

> EV> this is indeed the usual issue when using "SHOULD"...

:)