Subject: Call for Adoption: draft-bishop-httpbis-origin-h3-00

From: Mark Nottingham <[email-masked]>
Date: Tue, 11 Jan 2022 16:40:29 +1100

Hi everyone,

At our last interim, we discussed adopting this document:
  https://datatracker.ietf.org/doc/draft-bishop-httpbis-origin-h3/
... and there seemed to be support for doing so.

This message is a call for adoption of this document. Please state whether you support WG adoption of this draft.

The CfA will end in one week.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 11 Jan 2022 18:28:31 +1100

It might be worth asking how widely deployed ORIGIN is.  If it is in use, then this seems fine, but I'm not sure how much it is being used.

The draft is mostly OK, though a bit strange in parts.  It should exclusively focus on ORIGIN, but it implies that there might be more frames.  Section 2 is ?.  Section 3 might benefit from a (non-normative) redrawing of the frame rather than pointing to the h2 specification.

On Tue, Jan 11, 2022, at 16:40, Mark Nottingham wrote:
> This message is a call for adoption of this document. Please state 
> whether you support WG adoption of this draft.
>

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Jan 2022 07:41:29 +0000

I know that Akamai uses ORIGIN, primarily on connections where we want to disallow coalescing for various reasons.  The draft strangeness comes from originally being for ALTSVC, then both ALTSVC and ORIGIN, but now just ORIGIN since we adopted 7838bis -- it can definitely stand a fresh editorial pass to reflect its refocused topic, either when I'm back or if the chairs select someone else as editor.

It sounds, however, like all of that is feedback that can easily be addressed by the WG post-adoption.