Subject: Zaheduzzaman Sarker's No Objection on draft-ietf-httpbis-targeted-cache-control-03: (with COMMENT)

From: Zaheduzzaman Sarker via Datatracker <[email-masked]>
Date: Tue, 18 Jan 2022 00:21:58 -0800

Zaheduzzaman Sarker has entered the following ballot position for
draft-ietf-httpbis-targeted-cache-control-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/blog/handling-iesg-ballot-positions/
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-httpbis-targeted-cache-control/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks for working on this specification.

I have only one observation - CND-Cache-Control is a targeted for CDN caches,
however, my understanding is this can end up in the clients. There is no
description or reference to description about what a client supposed to handle
this (obvious is to ignore). It would be great if we can write something about
it or refer to the client behavior description elsewhere. If my understanding
is wrong that this header field will never reach any client then I would say it
requires some wording in the specification to clearly state that.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 20 Jan 2022 14:47:10 +1100

> On 18 Jan 2022, at 7:21 pm, Zaheduzzaman Sarker via Datatracker <[email-masked]> wrote:
> 

This is the case for all HTTP fields -- implementations that aren't consuming a field ignores it. That allows extensibility.

Furthermore, the spec already says: "Targeted fields that are not on a cache's target list MUST NOT change that cache's behaviour, and MUST be passed through."

Note that a cache is a component that's separate and independent from clients or servers -- i.e., a client or server can have a cache.

Cheers,

--
Mark Nottingham   https://www.mnot.net/