Subject: Dynamic table size updates

From: "Martin Thomson" <[email-masked]>
Date: Wed, 05 Jan 2022 16:51:59 +1100

Hey folks,

We've had a bunch of discussion about the interpretation of RFC 7540 and 7541 regarding updates to the HPACK header table size limits.

A few problems were identified:

1. This is very consistently implemented.

2. Normative text on this is split between the two RFCs.

3. That text isn't completely unambiguous.

We won't fix the first, but we can at least fix the others.  Proposed changes:

https://github.com/httpwg/http2-spec/pull/1005/files 

(Thanks to Willy and Kazuho for helping to work through this, and Stefan and Cory for their input.)

Chairs, Francesca, we're in IESG processing for the draft.  Is this change likely to be a problem?

Cheers,
Martin

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 05 Jan 2022 16:58:58 +1100

Correction:

> 1. This is very consistently implemented.

This is NOT very consistently implemented.

Or rather this is almost consistently mis-implemented :(

---

From: Willy Tarreau <[email-masked]>
Date: Wed, 5 Jan 2022 08:20:47 +0100

> Or rather this is almost consistently mis-implemented :(

Or implemented depending how the specs are read :-)

Willy

---

From: Stefan Eissing <[email-masked]>
Date: Wed, 5 Jan 2022 09:48:10 +0100

> Am 05.01.2022 um 08:20 schrieb Willy Tarreau <[email-masked]>:
> 

What else is new? ;-)

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 12 Jan 2022 11:25:32 +1100

Just a follow-up to this.  We've had a few more eyeballs on the text and I think we're all happy with all the grammar.

Anyone who hasn't looked yet, see https://github.com/httpwg/http2-spec/pull/1005

Chairs, where do we stand?

On Wed, Jan 5, 2022, at 16:51, Martin Thomson wrote:
> Hey folks,
>
> We've had a bunch of discussion about the interpretation of RFC 7540 
> and 7541 regarding updates to the HPACK header table size limits.
>

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 20 Jan 2022 08:54:26 +1100

I just merged the pull request.

On Wed, Jan 12, 2022, at 11:25, Martin Thomson wrote:
> Just a follow-up to this.  We've had a few more eyeballs on the text 
> and I think we're all happy with all the grammar.
>

---

From: Willy Tarreau <[email-masked]>
Date: Thu, 20 Jan 2022 04:59:18 +0100

> I just merged the pull request.

Many thanks Martin!
Willy