Subject: Adoption call for draft-nottingham-http-structure-retrofit

From: Tommy Pauly <[email-masked]>
Date: Mon, 07 Feb 2022 10:34:12 -0800

Hello HTTP,

This email starts a working group adoption call for draft-nottingham-http-structure-retrofit (Retrofit Structured Fields for HTTP), which was discussed as potential new work at our interim meeting last week.

You can find the draft here:
https://www.ietf.org/archive/id/draft-nottingham-http-structure-retrofit-02.html <https://www.ietf.org/archive/id/draft-nottingham-http-structure-retrofit-02.html>
https://datatracker.ietf.org/doc/draft-nottingham-http-structure-retrofit/ <https://datatracker.ietf.org/doc/draft-nottingham-http-structure-retrofit/>

This adoption call will last for two weeks. Please reply to this email by Monday, February 21, and indicate whether you think this document should be adopted by the WG.

Best,
Tommy

---

From: James <[email-masked]>
Date: Mon, 7 Feb 2022 20:34:12 +0100

I support adoption, and I've got a proposed change - Mark, I'll raise you an issue in Github.

- J

> On 7 Feb 2022, at 19:34, Tommy Pauly <[email-masked]> wrote:
> 
> Hello HTTP,
> 
> https://www.ietf.org/archive/id/draft-nottingham-http-structure-retrofit-02.html
> https://datatracker.ietf.org/doc/draft-nottingham-http-structure-retrofit/
>

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Mon, 07 Feb 2022 20:35:15 +0000

--------
Tommy Pauly writes:

> This adoption call will last for two weeks. Please reply to this email
> by Monday, February 21, and indicate whether you think this document
> should be adopted by the WG.

I'm for adoption.

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 8 Feb 2022 10:26:39 +0100

Am 07.02.2022 um 19:34 schrieb Tommy Pauly:
> Hello HTTP,
>
> This email starts a working group adoption call
> for draft-nottingham-http-structure-retrofit (Retrofit Structured Fields
> for HTTP), which was discussed as potential new work at our interim
> meeting last week.
>
> <https://www.ietf.org/archive/id/draft-nottingham-http-structure-retrofit-02.html>
> <https://datatracker.ietf.org/doc/draft-nottingham-http-structure-retrofit/>
>

Yes, it should.

Best regards, Julian

---

From: Justin Richer <[email-masked]>
Date: Tue, 8 Feb 2022 10:29:43 -0500

I support adoption.

 — Justin

> On Feb 7, 2022, at 1:34 PM, Tommy Pauly <[email-masked]> wrote:
> 
> Hello HTTP,
>

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 8 Feb 2022 15:43:59 +0000

I support adoption.

If it were to be adopted, I think it would be useful to formalize the
inclusion criteria because there's a lot of non-SF headers out there. It
might also be useful to understand how implementation status of this spec
might be measured.

Cheers,
Lucas

On Mon, Feb 7, 2022 at 6:37 PM Tommy Pauly <[email-masked]> wrote:

> for HTTP), which was discussed as potential new work at our interim meeting
> last week.
>
> This adoption call will last for two weeks. Please reply to this email by
> Monday, February 21, and indicate whether you think this document should be
> adopted by the WG.
>
> Best,
> Tommy
>

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 09 Feb 2022 12:47:22 +1100

I support adoption.

On Tue, Feb 8, 2022, at 05:34, Tommy Pauly wrote:
> Hello HTTP,
>
> This email starts a working group adoption call for 
> draft-nottingham-http-structure-retrofit (Retrofit Structured Fields

---

From: Tommy Pauly <[email-masked]>
Date: Sat, 26 Feb 2022 15:16:26 -0800

Thanks to everyone who provided feedback! Based on this input, we have adopted this as a new WG item. Mark, please upload a WG version when ready.

Best,
Tommy

> On Feb 7, 2022, at 10:37 AM, Tommy Pauly <[email-masked]> wrote:
> 
> Hello HTTP,
>