Subject: [Hubmib] cross posting with hubmib

From: Nathan Kohn <[email-masked]>
Date: Tue, 10 Apr 2001 16:13:14 -0400

atom mib wg:

Item of interest from hubmib (ethernet) session 
[thanks to Steve Moulton for recording this item]
"Presentation: WAN Interface Sublayer Management - John Flick.
Slides are in IETF50WisMib.ppt.

The edge objects defined by SONET do not match up with the EtherNet MIB
definitions.  The SONET MIB (AToMMIB) has 15 minute ethernet interval counters,
rather than the traditional SNMP free running counters.  The story was told of
the old telecom practice of taking pictures of counters on phone switches every
fifteen minutes (literal snapshots), and how the current practice echoes this
historical practice. The SONET MIB has a current table that has the current
interval,and a 15 minute table.  You can derive the counters from the interval
tables.  If we do this work, we should do it in cooperation with the SONET guys. 

The co-chair of the AToM MIB working group, Nathan Kohn agreed, and asked for
this issue to be cross posted.  Tom Rutt has volunteered to contribute an
analysis."

kaj et. al, perhaps you could provide some insights into the choice between
interval vs free-running counters.

nathan kohn

_______________________________________________
Hubmib mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/hubmib

---

From: Kaj Tesink <[email-masked]>
Date: Wed, 11 Apr 2001 10:25:12 -0400

>interval vs free-running counters.

there have been several food fights about this one;
its one of these differences that we ended up having to
live with. the 15 minute counts were rooted in telecom
practices, methods&procedures and implementations.
when snmp showed up with continues counters as the
common practice (and simple to implement)
the trunk-mib wg ran into this question
for the ds1 mib. common implementations as well as
leading specifications pretty much decided what the answer
should be for the ds1 mib. subsequently the ds3, sonet and ds0 mibs
then simply built on the model set by the ds1 mib.
inside bellcore we did take a look at the extent to which
15-minute bucket counts would be translatable into continuous
counts or vice versa. the answer was: to some extent it is just
representation but there are subtle differences that you have to
live with, i.e., under some circumstances true translation
may not be possible. also, differences were identified in
the smarts of the agent where the 15 min buckets need to be stored
for a while (and you need to worry about border conditions),
and where the continuous counts rely more or
periodic retrieval of the count value. you can come up
with pros and cons for each method.

overall my own inclination is
a) to avoid mibs that do it both ways ("options") for
    the same counter flavors
b) to pick the method that is compatible with what is
    common practice in both current equipment and
    current methods&procedures by those who must use it
c) in a desert environment (is there such a thing?)
    the continuous counter method
    tends to be simpler for agent implementation

it may not be optimal but we do want specifications
that will also be implemented, no?

kaj

>nathan kohn

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies
Email  [email-masked]
Tel    732.758.5254
Fax    732.758.2269
Postal 331 Newman Springs Rd
        Red Bank, NJ 07701
        USA

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/