Subject: RE: [Hubmib] Comments on <draft-ietf-hubmib-wis-mib-00.txt>

From: Kaj Tesink <[email-masked]>
Date: Wed, 01 Aug 2001 16:45:44 -0400

At 05:21 PM 7/31/01 -0500, Ayers, Mike wrote:

> > From: C. M. Heard [mailto:[email-masked]]
> > Sent: Monday, July 30, 2001 06:42 PM
> > To: Hubmib Working Group; AToMMIB Working Group
> > Subject: [Hubmib] Comments on <draft-ietf-hubmib-wis-mib-00.txt>

i have read mike's analysis in detail; here's what i found

a) would like to thank mike for his very thorough and extensive
    analysis; i does touch all the bases and challenges that this
    work must address and finds good answers in all cases.

b) i find myself in full agreement with both his approach and
    on the details; in particular

    - mike's approach and draft makes full use of existing mib modules
      whenever possible and appropriate; this meets the concern i raised
      a while ago on the list.
      this will benefit existing implementations both on the agent
      as well as on the NMS side.

    - his draft only adds objects for functions that have not been addressed
      elsewhere; it appears that these functions are necessary and therefore
      that new objects are merited. appropriately these objects tend to
      extend existing tables as described in the mib module.

    - the draft also addresses the issue of compliance and the relationship
      with the different mib modules. i do view the precise definition
      of that relationship as important, as to avoid guesswork and
      diverging implementations later on

    - the final I-D will have to add appropriate text in the preamble
      to explain the rationale and use of the various mib modules
      and this mib module; mike's analysis has large portions that can
      be used verbatim.

c) mike's analysis squarely addresses the subject matter of the joint
    AToMMIB/HUBMIB meeting, i.e.,
    "Discuss the potential for next revision of RFC 2558 to cover 1.
    Or alternatively a new MIB that will cover both SONET and 10 Gbps
    Ethernet interfaces using SONET."

unfortunately i will not be able to attend the london meeting but
i'd like to see the meeting to adopt mike's draft & recommendations.

kaj

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies
Email  [email-masked]
Tel    732.758.5254
Fax    732.758.2269
Postal 331 Newman Springs Rd
        Red Bank, NJ 07701
        USA

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

_______________________________________________
Hubmib mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/hubmib

---

From: Kaj Tesink <[email-masked]>
Date: Fri, 03 Aug 2001 09:39:53 -0400

following up on mike's posting earlier mike and i collaborated
to produce attached draft. realizing that the analysis has a lot
of material in it and is somewhat lengthy, the aim of this draft
is to make the recommendations from the analysis  available
in a more condensed form, i.e., in I-D format.

we provide this as input for discussion at the london meeting.
if it is acceptable as a basis for further work we will make the
source file available to the ether-wis editors.

as mentioned, unfortunately neither mike nor i can attend the
meeting but hopefully mike's analysis together with this draft
illustrate our proposed approach.
we'd be happy to provide additional on-line clarifications.

kaj

Kaj Tesink
Telcordia Technologies