Subject: [Hubmib] Wis MIB submission - draft-wis-design-team-wis-mib-00.txt

From: "K.C. Norseth" <[email-masked]>
Date: Thu, 18 Oct 2001 22:40:37 -0600

The wis mib design team has submitted the ID for the Wis mib to the IETF.
While waiting for it to come out officially by the IETF, you can review the
draft at:
http://norseth.org/ietf/hubmib/draft-wis-design-team-wis-mib-00.txt

This document was created by a design team with people by both the HUBMIB
and ATOMMIB WG's.  The problem we were tasked to do was to create a mib that
followed the 802.ae wis spec, clause 30 from the IEEE.   This mib has a mix
of both the ETHERNET and SONET worlds.  From a combined meeting in London of
the two groups, this design team was formed from both groups.  We tried to
put in the document any issues discussed in the overlap of both worlds.  We
were hoping to anticipate any problems or questions arising from both
groups.

The design team consisted of:
Mike Ayers
John Flick
C. M. Heard
Kam Lam
Kerry McDonald
K. C. Norseth
Kaj Tesink

If you have any questions or comments, post to either WG.

Good work team.

K.C.

_______________________________________________
Hubmib mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/hubmib

---

From: "C. M. Heard" <[email-masked]>
Date: Thu, 18 Oct 2001 23:27:01 -0700 (PDT)

> http://norseth.org/ietf/hubmib/draft-wis-design-team-wis-mib-00.txt
[ ... ]
> If you have any questions or comments, post to either WG.

I'd like to bring a couple of open issues to the attention of the WGs.

1.) The WIS MIB draft extensively references RFC 2558 (the SONET-MIB).
    However, it requires that the value of sonetPathCurrentWidth be
    set to sts192cSTM64(6), which is not supported by RFC 2558.  This
    will be resolved when a new version of the SONET-MIB is published
    with the changes that Kaj Tesink posted to the AToMMIB mailing list
    on 7 June 2001.

2.) The draft proposes the following ifTable layering model:

           -------------------
          | ethernetCsmacd    |
          +-------------------+
          | sonetPath         |
          +-------------------+
          | sonet             |
           -------------------

    One of the members of the design team (Mike Ayers) has
    suggested that a better model would be

           -------------------
          | ethernetCsmacd    |
          +-------------------+
          | ethernet64-66bWIS |
          +-------------------+
          | sonetPath         |
          +-------------------+
          | sonet             |
           -------------------

    on the grounds that there is more than one Ethernet-over-SONET
    payload mapping.  A conter-argument to this proposal is that
    this distinction can be represented more economically by
    having different ifMauType values for different EoS mappings.
    Comments are invited.

Regards,

Mike
--
C. M. Heard
[email-masked]

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 19 Oct 2001 21:47:26 +0200

The preferable editorial path would have been to list these in an Open
Issues session of the design team draft. In the absence of such a
section, I would suggest that the design team moderator opens a list of
such issues - which can be augmented until the Utah meeting and which we
would work to resolve by that time.

Regards,

Dan

> -----Original Message-----
> From: C. M. Heard [mailto:[email-masked]]
> Sent: Friday, October 19, 2001 8:27 AM
> To: Hubmib Mailing List; AToMMIB Mailing List
> Subject: [Hubmib] Re: Wis MIB submission - 
> draft-wis-design-team-wis-mib-00.txt
> 
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sat, 20 Oct 2001 02:21:16 +0200

Please allow me to congratulate and thank the design team for a work
well done.

I would now kindly request all the WG members to go ahead and read the
draft. We intent to collect feedback in the next two weeks, and then
issue a revised version of draft-ietf-hubmib-wis-mib-00. txt, taking
into account the results of the design team work, and the discussions on
the list.

Regards,

Dan

> From: K.C. Norseth [mailto:[email-masked]]
> Sent: Friday, October 19, 2001 6:41 AM
> To: [email-masked]; [email-masked]
> Subject: Wis MIB submission - draft-wis-design-team-wis-mib-00.txt
> 
>