Subject: [Hubmib] RE: [Bridge-mib] Support of LAN FCS in Ethernet packet over ATM AAL5.

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 27 Jun 2002 11:22:28 +0300

Nurit,

Please take this discussion off the hubmib list. I do not think this is relevant for this working group, which focuses on management of Ethernet interfaces and devices. 

Thanks,

Dan

> -----Original Message-----
> From: Nurit Sprecher [mailto:[email-masked]]
> Sent: Thursday, June 27, 2002 11:19 AM
> To: 'Manuel Stol'; PPPoE Mailing List (E-mail)
> Cc: [email-masked]'; [email-masked]'
> Subject: [Bridge-mib] Support of LAN FCS in Ethernet packet over ATM
> AAL5.
> 
> 
> In RFC 2684 on Multiprotocol Encapsulation over ATM 
> Adaptation Layer 5, the
> Payload Format for Bridged Ethernet/802.3 PDUs is defined as follows:
> 
>                 +-------------------------------+
>                 |    MAC destination address    |
>                 +-------------------------------+
>                 |                               |
>                 |   (remainder of MAC frame)    |
>                 |                               |
>                 +-------------------------------+
>                 |  LAN FCS (if PID is 0x00-01)  |
>                 +-------------------------------+
>  
> The LAN FCS option is VC dependent. 
> In case that the LAN FCS is supported, duplicate checksum 
> calculations are
> performed: one for the AAL5 frame and one for the Ethernet frame.
> 
> In what cases is it required/suggested/worth to support the 
> LAN FCS when
> transmitting a packet within an AAL5 packet over an ATM network? 
> 
> Can a bridge that resides at the end of the ATM, de-capsulate 
> the ATM packet
> and transmit the Ethernet packet over a LAN, calculate the 
> LAN FCS and set
> it in the Ethernet packet (if required)?
> 
> Thanks in advance, 
> Nurit Sprecher
> 
> 
> _______________________________________________
> Bridge-mib mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bridge-mib
> 

_______________________________________________
Hubmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hubmib

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 27 Jun 2002 11:22:28 +0300

Nurit,

Thanks,

Dan