Subject: [I2nsf] draft-zhang-gap-analysis

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 12 Feb 2015 13:15:54 -0500

Hello,

Once the list has agreed upon a scope, it will need to be clearly
documented to set the tone for the gap analysis in draft-zhang-gap-analysis.

I see additional terms are listed in this draft.  There is some overlap
between drafts.  I suggest you keep terminology in the framework draft and
reference it from one place.

In the Gap analysis, the first 2 WGs NSIS and SACM have clear overlap.  Are
there any work items that could be done in SACM since that group is still
open?  SACM is starting to do information model work, could there be a fit
for any of the endpoint policy?  Would this be in YANG or something else?

TRAM should be added to the list of WGs in the gap analysis.  PCP folks
have moved onto TRAM.  If the voice use case continues to be an example,
explaining in terms of these WGs will be necessary along with MIDCOM.

I see in ANIMA it says some aspects may be used.  Once the use cases and
scope are nailed down, I'd like to know what exactly may fit in the other
WGs in this gap analysis.

Please add SUPA to the list in the gap analysis as well.

For I2RS and Netconf, once you know the use cases and scope, please
elaborate more on what can be used and why I2NSF is still needed or if the
work can just be brought to those WGs.  In looking at the I2RS section, why
couldn't the data models be handled in SACM for instance?

My suggestion is to wait until the WG agrees upon a set of use cases and
scope of work before editing this draft further.  Once that has been agreed
upon, please look through the full list of WGs, adding in the ones
mentioned (TRAM and SUPA) and re-evaluate the gap analysis looking for
opportunities to complete work items in existing WGs.  This may have the
effect of further narrowing the scope or even getting all of the intended
work done split across several WGs.  If it's the latter, it may be possible
to finish this work sooner than would be the case with a new WG.

Thanks for your work to date on this draft!

-- 

Best regards,
Kathleen

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 18 Feb 2015 19:45:46 +0000

Kathleen,

SUPA is clearly different from I2NSF. As the SUPA charter says:

The [SUPA] will focus in the first phase on inter-datacenter traffic management in the use case of a distributed data center, including the automated provisioning of site-to-site virtual private networks of various types

SUPA is for managing traffic engineered networks, creating virtual private networks on demand, which is more common to Routing Area’s TESS.

ANIMA is for managing “network” too, meaning automatically create the links, VPN, etc.

Whereas, I2NSF focuses on the interface to “Flow Based Security Functions”. I2NSF doesn’t manage networks, links or VPNs. Instead, I2NSF manages the interface to/from the vNSFs, even though the “interface” by I2NSF won’t cover all functions of any specific security devices.

It is fair to say that I2NSF is in the similar categories as TRAM, PCP, and MIDCOM.

Key differences:

MIDCOM: its SNMP scheme doesn’t work with vNSF management
PCP: Focusing on the perform port opening and/or port forwarding on NAT
TRAM: TRAM Working Group is to consolidate the various
initiatives to update TURN and STUN to make them more suitable for
the WebRTC environment.

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Thursday, February 12, 2015 12:16 PM
To: [email-masked]
Subject: [I2nsf] draft-zhang-gap-analysis

Hello,

Once the list has agreed upon a scope, it will need to be clearly documented to set the tone for the gap analysis in draft-zhang-gap-analysis.

I see additional terms are listed in this draft.  There is some overlap between drafts.  I suggest you keep terminology in the framework draft and reference it from one place.

In the Gap analysis, the first 2 WGs NSIS and SACM have clear overlap.  Are there any work items that could be done in SACM since that group is still open?  SACM is starting to do information model work, could there be a fit for any of the endpoint policy?  Would this be in YANG or something else?

TRAM should be added to the list of WGs in the gap analysis.  PCP folks have moved onto TRAM.  If the voice use case continues to be an example, explaining in terms of these WGs will be necessary along with MIDCOM.

I see in ANIMA it says some aspects may be used.  Once the use cases and scope are nailed down, I'd like to know what exactly may fit in the other WGs in this gap analysis.

For I2RS and Netconf, once you know the use cases and scope, please elaborate more on what can be used and why I2NSF is still needed or if the work can just be brought to those WGs.  In looking at the I2RS section, why couldn't the data models be handled in SACM for instance?

My suggestion is to wait until the WG agrees upon a set of use cases and scope of work before editing this draft further.  Once that has been agreed upon, please look through the full list of WGs, adding in the ones mentioned (TRAM and SUPA) and re-evaluate the gap analysis looking for opportunities to complete work items in existing WGs.  This may have the effect of further narrowing the scope or even getting all of the intended work done split across several WGs.  If it's the latter, it may be possible to finish this work sooner than would be the case with a new WG.

--

Best regards,
Kathleen

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 18 Feb 2015 14:51:53 -0500

On Wed, Feb 18, 2015 at 2:45 PM, Linda Dunbar <[email-masked]>
wrote:

> The [SUPA] will focus in the first phase on inter-datacenter traffic
> management in the use case of a distributed data center, including the
> automated provisioning of site-to-site virtual private networks of various
> types
>
>
>
Linda,

Sure, I see that they are different, but this should be added to the gap
analysis as others were asking this very question.

Thank you,
Kathleen

>  SUPA is for managing traffic engineered networks, creating virtual
> private networks on demand, which is more common to Routing Area’s TESS.
>
>
>
> Whereas, I2NSF focuses on the interface to “Flow Based Security
> Functions”. I2NSF doesn’t manage networks, links or VPNs. Instead, I2NSF
> manages the interface to/from the vNSFs, even though the “interface” by
> I2NSF won’t cover all functions of any specific security devices.
>
>
>
>
>
> *From:* I2nsf [mailto:[email-masked]] *On Behalf Of *Kathleen
> Moriarty
> *Sent:* Thursday, February 12, 2015 12:16 PM
> *To:* [email-masked]
> *Subject:* [I2nsf] draft-zhang-gap-analysis
>
>
>
> Hello,
>
>
>
> In the Gap analysis, the first 2 WGs NSIS and SACM have clear overlap.
> Are there any work items that could be done in SACM since that group is
> still open?  SACM is starting to do information model work, could there be
> a fit for any of the endpoint policy?  Would this be in YANG or something
> else?
>
>
>

-- 

Best regards,
Kathleen