Subject: [I2nsf] what is the right definition for "flow-based security functions"?

From: Linda Dunbar <[email-masked]>
Date: Wed, 20 May 2015 22:04:00 +0000

Do people agree on this definition for "flow-based security function"?

"A security function that performs actions or invokes function calls for the communications between origination and termination entities."

Thanks, Linda

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Thu, 21 May 2015 02:33:27 +0000

Hmmm, I'd prefer a more detailed definition, in the style of:

"A function that manages network flows (sequences of packets from a source node to a destination node characterized by specific parameters) according to a policy intended for enforcing security properties"
If the definition of a network flow  is clear, we could omit what goes between parenthesis...

Be goode,

On 21 May 2015, at 06:04 , Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

Do people agree on this definition for “flow-based security function”?

“A security function that performs actions or invokes function calls for the communications between origination and termination entities.”

Thanks, Linda

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Thu, 21 May 2015 02:41:15 +0000

Be goode,

Thanks, Linda

Dr Diego R. Lopez
Telefonica I+D

---

From: Edward Lopez <[email-masked]>
Date: Thu, 21 May 2015 11:04:54 +0000

In network security, flow-based security also means that packets are inspected in the order they are received, and without modification to the packet due to the inspection process (MAC rewrites, TTL decrement action, even NAT would be outside the inspection process).

Proxy-based security functions can buffer, and defragment packets, as well as perform content rewrites.

Ed Lopez

Sent from my iPhone ... Sorry for any auto-correct errors

On May 20, 2015, at 10:33 PM, DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>> wrote:

Be goode,

Thanks, Linda

Dr Diego R. Lopez
Telefonica I+D

***  Please note that this message and any attachments may contain confidential 
and proprietary material and information and are intended only for the use of 
the intended recipient(s). If you are not the intended recipient, you are hereby 
notified that any review, use, disclosure, dissemination, distribution or copying 
of this message and any attachments is strictly prohibited. If you have received 
this email in error, please immediately notify the sender and destroy this e-mail 
and any attachments and all copies, whether electronic or printed.
Please also note that any views, opinions, conclusions or commitments expressed 
in this message are those of the individual sender and do not necessarily reflect 
the views of Fortinet, Inc., its affiliates, and emails are not binding on 
Fortinet and only a writing manually signed by Fortinet's General Counsel can be 
a binding commitment of Fortinet to Fortinet's customers or partners. Thank you. ***