Subject: [I2nsf] I2NSF BOF Session request for IETF 93

From: Linda Dunbar <[email-masked]>
Date: Mon, 18 May 2015 20:41:24 +0000

Kathleen,

We would like to request a WG forming BOF for I2NSF at IETF93. Here are the details of the request:

  *   BOF's full name and acronym in brackets:  Interface to Network Security Functions (I2NSF)
  *   AREA under which Working Group or BOF appears: Security
  *   Chair(s) Name(s) and e-mail address(es): TBD
  *   Agenda (to be adjusted)

o   Use cases & Problem space

o   Packet-Based Paradigm For Interfaces To NSFs

o   Capability interface Information model

o   Gap Analysis

o   Framework

o   Charter discussion: http://www.ietf.org/mail-archive/web/i2nsf/current/msg00391.html

  *   Full Description of BOF
In a nutshell, I2NSF wants to define interfaces to the flow based network security functions hosted by service providers at different premises.

Network security functions (NSFs) are provided and consumed in increasingly diverse environments. Users of NSFs could consume network security services hosted by one or more providers, which may be their own enterprise, service providers, or a combination of both. Likewise, service providers of NSFs may offer their customers network security services that consist of multiple security products and/or functions from different vendors. NSFs may be provided by physical and/or virtualized infrastructure. Without standard interfaces to express, monitor, and control security policies that govern the behavior of NSFs, it becomes virtually impossible for security service providers to automate their service offerings that utilize different security functions from multiple vendors.

The primary goal of I2NSF is to define an information model,  a set of software interfaces and data models for controlling and monitoring aspects of NSFs (both physical and virtual). Other aspects of NSFs such as device or network provisioning and configuration are out of scope. Controlling and monitoring of NSFs should include the use of policies to specify, query, monitor, and control the NSFs by one or more management entities. Since different security vendors support different features and functions on their devices, I2NSF will focus on flow based NSFs that provide treatment to packets/flows, such as IPS/IDS, Web filtering, flow filtering, deep packet inspection, or pattern matching and remediation.

  *   CONFLICTS you wish to avoid, please be as specific as possible:
SACM, SAAS, nfvrg, SFC, NVO3, TRILL, ...

  *   Expected Attendance (figures from the previous IETF meeting are included in the message that is sent when scheduling opens): 60
  *   Special requests:
  *   Number of sessions: 1
  *   Length of sessions:
     *   2 hours

Hope you can guide us through the process.

Thank you very much.

Linda Dunbar

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 18 May 2015 16:44:49 -0400

Linda,

Could you please add this to the wiki?  I'm about to fly to Lima, so I wouldn't be able to get to it for a bit.

Thank you,
Kathleen

Sent from my iPhone

> On May 18, 2015, at 4:41 PM, Linda Dunbar <[email-masked]> wrote:
> 
> Kathleen,
>  
> BOF's full name and acronym in brackets:  Interface to Network Security Functions (I2NSF)
> AREA under which Working Group or BOF appears: Security
> Chair(s) Name(s) and e-mail address(es): TBD
> Agenda (to be adjusted)
> Full Description of BOF
> CONFLICTS you wish to avoid, please be as specific as possible:
> SACM, SAAS, nfvrg, SFC, NVO3, TRILL, …
> Expected Attendance (figures from the previous IETF meeting are included in the message that is sent when scheduling opens): 60
> Special requests:
> Number of sessions: 1
> Length of sessions:
> 2 hours
>

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 18 May 2015 21:27:00 +0000

Kathleen,

Thanks.
I have added what we have to the IETF93 BOF wiki. Let me know if any changes are needed: http://trac.tools.ietf.org/bof/trac/wiki/WikiStart

Have a good trip to Lima. Looking forward to talking to you more on the I2NSF BOF preparation when you come back.

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Monday, May 18, 2015 3:45 PM
To: Linda Dunbar
Cc: [email-masked]; [email-masked] Agenda; Stephen Farrell
Subject: Re: [I2nsf] I2NSF BOF Session request for IETF 93

Linda,

Thank you,
Kathleen

Sent from my iPhone

On May 18, 2015, at 4:41 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
Kathleen,

o   Gap Analysis

o   Framework

     *   2 hours

Thank you very much.

Linda Dunbar