Subject: [I2nsf] draft-xia-i2nsf-capability-interface-im-03 BOF review comments

From: Linda Dunbar <[email-masked]>
Date: Fri, 10 Jul 2015 17:30:41 +0000

Frank, et al,

Thank you very much for participating in the I2NSF BOF preparation call yesterday to review the draft-xia-i2nsf-capability-interface-im-03 BOF slides with the I2NSF BOF Chairs

Since the audio quality from your side is not very good, I just want to pass you the comments, in case you didn't get them.

-           It was suggested to add some explanation on the difference between <Packet-based-match> and <context-based-match>

-          Add some explanation on the approach (or the thinking process behind) on how those information model grammar are derived.

-          Question came up during the discussion if the Data Models should be separated into a new draft. The decision is that keep the Data Models together with the information model until the I2NSF WG is charted. Once charted, a separate draft is needed for Data Model.

-          If I2NSF is charted, more work is needed to align with the data model implemented by draft-jeong-i2nsf-sdn-security-services-02

Thank you very much.

See you in Prague.

Linda

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Mon, 13 Jul 2015 02:19:50 +0000

Thanks a lot, Linda.
Please see my response inline:

BTW, all the updates will be included in the –03 draft.

发件人: Linda Dunbar
发送时间: 2015年7月11日 1:31
收件人: Xialiang (Frank); [email-masked]
主题: draft-xia-i2nsf-capability-interface-im-03 BOF review comments

Frank, et al,

Since the audio quality from your side is not very good, I just want to pass you the comments, in case you didn’t get them.

-           It was suggested to add some explanation on the difference between <Packet-based-match> and <context-based-match>
[Frank]: The updated draft will include some contents to describe it.

-          Add some explanation on the approach (or the thinking process behind) on how those information model grammar are derived.
[Frank]: Actually, we already have some explanation contents in section 3.2 about the introduction of packet-based paradigm:
“
It is clarified in [I-D.lopez-i2nsf-packet] that abstractly all NSFs are packet-processing engines that inspect packets traversing networks, either directly or in context to sessions to which the packet is associated. This draft uses this packet-based paradigm for the design of NSF capability interface IM. This packet-based design approach is very general and easily extensible, and so can avoid any potential constraints which could limit NSFs’ functional capabilities.
Considering from the perspective of packet-processing, NSFs differ in the depths of packet headers and/or payloads they can inspect, the various session/context states they can maintain, and the actions or specific profiles they can apply. Therefore, the NSF capabilities can be characterized by the level of packet-processing and context that a NSF can support, and the actions and profiles that the NSF can apply. In the other hand, NSF Vendors can register their provided NSF capabilities by using the Subject-Object-Action-Function categories described by [I-D.lopez-i2nsf-packet].
”
Any consideration?

[Frank]: agree.

-          If I2NSF is charted, more work is needed to align with the data model implemented by draft-jeong-i2nsf-sdn-security-services-02
[Frank]: yes, need to consider it all together.

Thank you very much.

See you in Prague.

Linda