Subject: [I2nsf] draft-jeong-i2nsf-sdn-security-services-02 BOF slides review comments

From: Linda Dunbar <[email-masked]>
Date: Thu, 9 Jul 2015 22:31:08 +0000

Paul, Hyoung, JingYong, and JunSoo,

Thank you very much for participating in the I2NSF BOF preparation call today to review the draft-jeong-i2nsf-sdn-security-services-02 BOF slides with the I2NSF BOF Chairs.

Your draft brought out a very interesting aspect of SDN controlled security services: taking out the "brain" of NSFs and putting them in the SDN controller, leaving only the forwarding engine on the data path.  Whereas other I2NSF  solution drafts have NSFs in the data path, as most deployment done today.

Here is the summary of the comments given at today review session:

-          Your whole architecture is SDN controlled Security Service. So please use the specific name for the Controller to the Switches: e.g. Switch Controller, or Network controller, etc.

-          To avoid people who have the view of NSFs being on the data path, can you emphasize that your solution is to take "brain" of NSFs out of data path, leaving simple forwarding on the data path?  Of course, same as other SDN controlled network, forwarding device might need to send initial packets to the SDN controller if they don't know how to forward.

-          Add a note at the last page stating that the YANG model proposed will be aligned with I2NSF Capability solution. (that is the goal this WG).

Thank you. See you in Prague.

Linda

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 10 Jul 2015 09:11:17 +0900

Linda and Chairs,
I will reflect your comments on our slides.

Thanks for your valuable and constructive comments on our work.

Best Regards,
Paul

===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software /
Department of Computer Engineering
Sungkyunkwan University
Office: +82-31-299-4957
Mobile: +82-10-4758-1765
Fax: +82-31-290-5119
Email: [email-masked], [email-masked]
CPS Lab Website: http://cpslab.skku.edu
Personal Homepage: http://cpslab.skku.edu/people-jaehoon-jeong.php

On Fri, Jul 10, 2015 at 7:31 AM, Linda Dunbar <[email-masked]>
wrote:

> Thank you very much for participating in the I2NSF BOF preparation call
> today to review the draft-jeong-i2nsf-sdn-security-services-02 BOF slides
> with the I2NSF BOF Chairs.
>
>
>
> Your draft brought out a very interesting aspect of SDN controlled
> security services: taking out the “brain” of NSFs and putting them in the
> SDN controller, leaving only the forwarding engine on the data path.
> Whereas other I2NSF  solution drafts have NSFs in the data path, as most
> deployment done today.
>
>
>
> -          Your whole architecture is SDN controlled Security Service. So
> please use the specific name for the Controller to the Switches: e.g.
> Switch Controller, or Network controller, etc.
>
> -          To avoid people who have the view of NSFs being on the data
> path, can you emphasize that your solution is to take “brain” of NSFs out
> of data path, leaving simple forwarding on the data path?  Of course, same
> as other SDN controlled network, forwarding device might need to send
> initial packets to the SDN controller if they don’t know how to forward.
>
> -          Add a note at the last page stating that the YANG model
> proposed will be aligned with I2NSF Capability solution. (that is the goal
> this WG).
>
>
>