Subject: Re: [I2nsf] Ben Campbell's No Objection on charter-ietf-i2nsf-00-02: (with COMMENT)

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 2 Sep 2015 20:01:52 -0400

Hi Ben,

Thanks for your review.

On Wed, Sep 2, 2015 at 7:53 PM, Ben Campbell <[email-masked]> wrote:
> Ben Campbell has entered the following ballot position for
> charter-ietf-i2nsf-00-02: No Objection
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/charter-ietf-i2nsf/
>
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> I concur with Barry's comments about the time limit.

This has been updated using Barry's suggested text, thanks.

>
> The following sentence sets important context, please consider moving it
> earlier in the charter:
>
> "As there are many different security vendors supporting different
> features and
> functions on their devices, I2NSF will focus on flow-based NSFs that
> provide
> treatment to packets/flows, such as Intrusion Protection/Detection
> System
> (IPS/IDS), Web filtering, flow filtering, deep packet inspection, or
> pattern
> matching and remediation."

Do you have a preference as to where it should go?  If not, we'll take
a look and figure something out that makes sense.

>
>  Is the capitalization of Simple Service Layer significant? That is, is
> it a named thing?

No, I don't think this needs to be capitalized, thanks for catching that!

>
> The deliverables seem overly prescriptive about document structure. (e.g.
> a "single document covering use cases..." instead of "Use cases...")

This is a result of much consolidation.  The consolidation has
happened, so the deliverable is likely to match this format.

>
> "The working group will communicate with external SDOs like ETSI NFV"
> sounds pretty open ended.

They will be working with open source efforts too like OpenStack.
This is a fairly new space, so I think that may be it for external
SDOs at the moment, but Linda should chime in if there are others.

Thank you,
Kathleen

-- 

Best regards,
Kathleen

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 02 Sep 2015 16:53:22 -0700

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 3 Sep 2015 02:00:58 +0000

They will be working with open source efforts too like OpenStack.
This is a fairly new space, so I think that may be it for external SDOs at the moment, but Linda should chime in if there are others.

[Linda] Thank Kathleen for the reply. There is also ONF NBI Real Time Media  NBI that gives positive session knowledge for white listing flows that are encrypted.  This means FW, IPS etc can be programmed on what is  a trusted flow via the Real Time Media NBI,  and L4-L7 Proof of Concept project. 

Linda

-----Original Message-----
From: I2nsf [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Wednesday, September 02, 2015 7:02 PM
To: Ben Campbell
Cc: [email-masked]; The IESG
Subject: Re: [I2nsf] Ben Campbell's No Objection on charter-ietf-i2nsf-00-02: (with COMMENT)

Hi Ben,

Thanks for your review.

On Wed, Sep 2, 2015 at 7:53 PM, Ben Campbell <[email-masked]> wrote:
> email addresses included in the To and CC lines. (Feel free to cut 
> this introductory paragraph, however.)
>
>
>

>
> The following sentence sets important context, please consider moving 
> it earlier in the charter:
>
> features and functions on their devices, I2NSF will focus on 
> flow-based NSFs that provide treatment to packets/flows, such as 
> Intrusion Protection/Detection System (IPS/IDS), Web filtering, flow 
> filtering, deep packet inspection, or pattern matching and 
> remediation."

Do you have a preference as to where it should go?  If not, we'll take a look and figure something out that makes sense.

>
>  Is the capitalization of Simple Service Layer significant? That is, 
> is it a named thing?

> a "single document covering use cases..." instead of "Use cases...")

This is a result of much consolidation.  The consolidation has happened, so the deliverable is likely to match this format.

They will be working with open source efforts too like OpenStack.
This is a fairly new space, so I think that may be it for external SDOs at the moment, but Linda should chime in if there are others.

Thank you,
Kathleen

-- 

Best regards,
Kathleen

_______________________________________________
I2nsf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2nsf

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 2 Sep 2015 22:12:01 -0400

Ben,

Sent from my iPhone

> On Sep 2, 2015, at 10:00 PM, Linda Dunbar <[email-masked]> wrote:
> 
> Ben and Kathleen: 
> 
>> 

Do you want to see this listed explicitly?

Thanks for responding quickly, Linda.

Thanks,
Kathleen

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 3 Sep 2015 08:45:25 -0400

Hi Ben,

In taking another look at it with caffeine...

> No, I don't think this needs to be capitalized, thanks for catching that!

The capitalization makes sense as all other instances of Capability
Layer and Service Layer are capitalized.

Thanks,
Kathleen

-- 

Best regards,
Kathleen

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 2 Sep 2015 23:37:33 -0500

Just chiming in, having co-chaired a working group with a laundry list of
expected liaison relationships ...

> SDOs at the moment, but Linda should chime in if there are others.

o I do think Kathleen's right - there's no telling what the landscape will
look like in two years, in this space.

o Having said that, I don't expect the list of expected liaison
relationships with SDOs and with Open Source projects in a charter to be
restrictive, or to compel any particular action on the working group, once
it's chartered. I do expect working groups to do the right thing on liaison
relationships, no matter what's in the charter.

So, I think open ended is OK for liaison relationships in a charter,
especially when there are SDOs that you're highly confident will be
critical for success, but I hope we can rely on working groups to do the
right thing, which does include requesting that the IAB establish a formal
liaison relationship when that's needed and we don't already have one in
place.

Does that make sense to other ADs?

Spencer

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 03 Sep 2015 08:59:30 -0500

On 2 Sep 2015, at 19:01, Kathleen Moriarty wrote:

[...]

> a look and figure something out that makes sense.

Maybe the end of the 2nd paragraph?

[...]

> happened, so the deliverable is likely to match this format.

Okay.

> SDOs at the moment, but Linda should chime in if there are others.

Based on the discussion so far, I'm okay with the existing text.

But it does bring up another question: The specific callout of ETSI NFV 
makes me think that this may be more virtualization oriented than is 
clear from the charter (which mentions virtual only in the context of 
"physical and virtual".) (This is just a thought, and it's perfectly 
fine if you think it strikes the right balance.)

---

From: "Ben Campbell" <[email-masked]>
Date: Thu, 03 Sep 2015 09:00:34 -0500

On 3 Sep 2015, at 7:45, Kathleen Moriarty wrote:

>>> is

"Service Layer" yes. But in that paragraph it's "Simple Service Layer". 
Does that mean the layer had been officially named?

Ben.

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 3 Sep 2015 10:16:11 -0400

> Maybe the end of the 2nd paragraph?

Done, thank you.

Kathleen

> makes me think that this may be more virtualization oriented than is clear
> from the charter (which mentions virtual only in the context of "physical
> and virtual".) (This is just a thought, and it's perfectly fine if you think
> it strikes the right balance.)
>
>
>>
>> Thank you,
>> Kathleen
>>>
>>>
>>>
>>
>>
>>
>> --
>>
>> Best regards,
>> Kathleen

-- 

Best regards,
Kathleen