Subject: Re: [I2nsf] Stephen Farrell's Yes on charter-ietf-i2nsf-00-02: (with COMMENT)

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 3 Sep 2015 09:08:34 -0400

Hi Stephen,

Thanks for your comments, some notes and suggestions are inline.

On Thu, Sep 3, 2015 at 8:19 AM, Stephen Farrell
<[email-masked]> wrote:
> Stephen Farrell has entered the following ballot position for
> charter-ietf-i2nsf-00-02: Yes
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/charter-ietf-i2nsf/
>
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
>
> I think this is fine to go ahead. I do have some comments,
> roughly in order of importance (but none being that
> important):
>
> - The capability vs. service "layer" thing is still not
> clear to me as written, and I suspect those may just not
> be the best terms, but I'm ok that it is considered clear
> enough to those who want to participate that it'll work or
> they'll need to fix this as they go. (I suspect the
> latter, but am often wrong:-)

Would the following text help?  I think this is already in the
charter, but maybe not said as clearly.

A client may leverage the I2NSF Service Layer interface to express
security policies to a security controller, which in turn interacts
with one or more NSFs through the I2NSF Capability Layer interface.
Alternatively, a client may interact with one or more NSFs directly
through the I2NSF Capability Layer interface.

>
> - The charter says "vendor" too often when it ought also
> include open-source technologies - not every NSF provider
> has to be for-profit.  For example in para1 maybe s/from
> different vendors/from different vendors or open-source
> technologies/ but a general pass for that would be good
> maybe trying s/vendor/NSF developer/ or something.
>

Done, good point.

> - 1st sentence: should "and to block" be "or to block"?

Fixed, thanks.

>
> - I like the last para.
>
> - (nit) 2nd sentence introduces network security services
> as being things that can be enforced by an NSF.  That's
> probably ok, but could maybe be confusing for someone not
> used to the service/mechanism distinction commonly used in
> security. (So I'm not sure if that's ok or not since it is
> clear enough for me.)

I haven't made a change yet, let's see if this matters as it didn't come up yet.

Thanks,
Kathleen

-- 

Best regards,
Kathleen

---

From: "Stephen Farrell" <[email-masked]>
Date: Thu, 03 Sep 2015 05:19:58 -0700

- I like the last para.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 3 Sep 2015 14:16:06 +0100

Hiya,

> through the I2NSF Capability Layer interface.

For me, that would help a little bit, but I'd not argue to include
it unless others like it too.

The rest below is all fine.

S..

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 3 Sep 2015 09:33:41 -0400

On Thu, Sep 3, 2015 at 9:20 AM, Spencer Dawkins at IETF
<[email-masked]> wrote:
> Hi, Kathleen,
>
> On Thu, Sep 3, 2015 at 8:16 AM, Stephen Farrell <[email-masked]>
> wrote:
>>
>>
>> Hiya,
>>
> At least one non-Stephen AD likes it ...

Thanks, I aded it in where I think it makes the most sense with the
other text on capability layer and service layer.

Kathleen

-- 

Best regards,
Kathleen

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 3 Sep 2015 08:20:51 -0500

Hi, Kathleen,