Subject: Re: [I2nsf] New Version Notification for draft-hares-i2nsf-capability-yang-00.txt

From: "Susan Hares" <[email-masked]>
Date: Fri, 1 Jul 2016 18:13:35 -0400

Bob, Frank, Aldo, and I2NSF folks: 

Initial draft of the capability yang data model.   I incorporated ideas from Aldo's paper and Frank's information model.   This data model uses draft-ietf-i2rs-pkt-eca-model-01.txt.   Data models compile under yang 1.1.   Please let me know if this data model matches what you desire for capability.  I've written it so it could be NSF device (firewall) or NSF application.    (see NSF name in data model).  I'm looking for feedback.  I hope it is close to Aldo's experimental models.   

I'll wait for feedback on Tuesday before I do any more revisions.  I will post the DDOS model that has two parts: 

DDOS Cloud 1 (agent) ---> DDOS Cloud 2(agent) 

Sue Hares

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 1, 2016 5:38 PM
To: Susan Hares; Robert Moskowitz
Subject: New Version Notification for draft-hares-i2nsf-capability-yang-00.txt

A new version of I-D, draft-hares-i2nsf-capability-yang-00.txt
has been successfully submitted by Susan Hares and posted to the IETF repository.

Name:		draft-hares-i2nsf-capability-yang
Revision:	00
Title:		I2NSF Capability Yang Model
Document date:	2016-07-01
Group:		Individual Submission
Pages:		24
URL:            https://www.ietf.org/internet-drafts/draft-hares-i2nsf-capability-yang-00.txt
Status:         https://datatracker.ietf.org/doc/draft-hares-i2nsf-capability-yang/
Htmlized:       https://tools.ietf.org/html/draft-hares-i2nsf-capability-yang-00

Abstract:
   This document defines a yang model that enables a I2NSF controller to
   control various network security functions in Network security
   devices.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Mon, 4 Jul 2016 02:24:55 +0000

Hi Sue and Bob,
I really like the content of this draft. More importantly, it's the first data model draft of I2NSF. 
Good start~~

Thanks for considering my capability interface IM draft as a reference. 
I have some comments as below:
1. Please make the draft to be consistent with I2NSF Terminology draft;
2. For Section 3, are you trying to associate I2NSF security policy rule management with device's filter-based RIB management? What's the reason?
3. In general, it's a good start and construct a solid framework for the data model. Next step, More detailed data model contents can be included by referencing to the updated I2NSF capability interface IM draft and monitoring IM draft.

B.R.
Frank

-----邮件原件-----
发件人: Susan Hares [mailto:[email-masked]] 
发送时间: 2016年7月2日 6:14
收件人: [email-masked]
抄送: 'Robert Moskowitz'; Xialiang (Frank); 'Aldo Basile'
主题: RE: New Version Notification for draft-hares-i2nsf-capability-yang-00.txt

Sue Hares

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 1, 2016 5:38 PM
To: Susan Hares; Robert Moskowitz
Subject: New Version Notification for draft-hares-i2nsf-capability-yang-00.txt

Abstract:

The IETF Secretariat