Subject: [I2nsf] Fwd: New Version Notification for draft-xia-i2nsf-capability-interface-im-06.txt

From: "Xialiang (Frank)" <[email-masked]>
Date: Fri, 1 Jul 2016 08:48:20 +0000

Hi all,
The new version of this draft is just submitted, which includes the following updates:
* Redesign the I2NSF specified ECA model:
	- Introduce the general external Info Model for ECA, Security Policy Metadata;
	- Specify the I2NSF capability Info Model by inheriting and extending the general external IM;
	- Specify the aggregation and association relation among the I2NSF sub-models. 
* Propose a more detailed design about “Event”, “Condition”, “Action” sub-classes for Network Security sub-model;  
* Make a lot of editorial text changes;
* Have More co-authors joining.

Your comments are warmly welcome!

B.R.
Frank

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2016年7月1日 16:24
收件人: [email-masked]; DaCheng Zhang; Nicolas Bouthors; Xialiang (Frank); Luyuan Fang; Nicolas BOUTHORS; Dacheng Zhang; Edward Lopez; John Strassner; Kepeng Li
主题: New Version Notification for draft-xia-i2nsf-capability-interface-im-06.txt

A new version of I-D, draft-xia-i2nsf-capability-interface-im-06.txt
has been successfully submitted by Liang Xia and posted to the IETF repository.

Name:		draft-xia-i2nsf-capability-interface-im
Revision:	06
Title:		Information Model of Interface to Network Security Functions Capability Interface
Document date:	2016-06-29
Group:		Individual Submission
Pages:		55
URL:            https://www.ietf.org/internet-drafts/draft-xia-i2nsf-capability-interface-im-06.txt
Status:         https://datatracker.ietf.org/doc/draft-xia-i2nsf-capability-interface-im/
Htmlized:       https://tools.ietf.org/html/draft-xia-i2nsf-capability-interface-im-06
Diff:           https://www.ietf.org/rfcdiff?url2=draft-xia-i2nsf-capability-interface-im-06

Abstract:
   This draft is focused on the capability interface of NSFs (Network
   Security Functions) and proposes its information model for managing
   the various network security functions.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: IMTL YunSuk Yeo <[email-masked]>
Date: Fri, 08 Jul 2016 08:31:07 +0000

Dear Xia,

I'm currently reading the new version of
draft-xia-i2nsf-capability-interface-im-06. In page 12, the figure 1 does
not match with description. I think Network Security Sub-Model and Content
Security Sub-Model have to change their position in figure 1. The problem
state is attached below.

Figure 1:

Description in document:
As illustrated in Figure 1, *the network security function* is the key. It
usually runs as the first step to handle traffic (e.g., packet/flow
detection and filtering, etc.) over the network layer.
 The framework portion of the information model ensures that each of the
three domain sub-models (content security, network security, and attack
mitigation) can function in collaboration or independently.

*The content security* and attack mitigation sub-models can be enforced on
demand (i.e., once or recursively based on the results of network security
function).

2016년 7월 1일 (금) 오후 5:48, Xialiang (Frank) <[email-masked]>님이 작성:

> * Propose a more detailed design about “Event”, “Condition”, “Action”
> sub-classes for Network Security sub-model;
> 收件人: [email-masked]; DaCheng Zhang; Nicolas Bouthors; Xialiang
> (Frank); Luyuan Fang; Nicolas BOUTHORS; Dacheng Zhang; Edward Lopez; John
> Strassner; Kepeng Li
> 主题: New Version Notification for
> draft-xia-i2nsf-capability-interface-im-06.txt
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-xia-i2nsf-capability-interface-im-06.txt
> Status:
> https://datatracker.ietf.org/doc/draft-xia-i2nsf-capability-interface-im/
> Htmlized:
> https://tools.ietf.org/html/draft-xia-i2nsf-capability-interface-im-06
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-xia-i2nsf-capability-interface-im-06
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Mon, 11 Jul 2016 02:07:57 +0000

Good catch, YunSuk. Will correct it in next version.
Thanks!

发件人: IMTL YunSuk Yeo [mailto:[email-masked]]
发送时间: 2016年7月8日 16:31
收件人: Xialiang (Frank); [email-masked]
主题: Re: [I2nsf] Fwd: New Version Notification for draft-xia-i2nsf-capability-interface-im-06.txt

Dear Xia,

I'm currently reading the new version of draft-xia-i2nsf-capability-interface-im-06. In page 12, the figure 1 does not match with description. I think Network Security Sub-Model and Content Security Sub-Model have to change their position in figure 1. The problem state is attached below.

Figure 1:

[pasted1]

Description in document:
As illustrated in Figure 1, the network security function is the key. It usually runs as the first step to handle traffic (e.g., packet/flow detection and filtering, etc.) over the network layer.
 The framework portion of the information model ensures that each of the three domain sub-models (content security, network security, and attack mitigation) can function in collaboration or independently.

The content security and attack mitigation sub-models can be enforced on demand (i.e., once or recursively based on the results of network security function).

2016년 7월 1일 (금) 오후 5:48, Xialiang (Frank) <[email-masked]<mailto:[email-masked]>>님이 작성:
Hi all,

B.R.
Frank

-----邮件原件-----
发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
发送时间: 2016年7月1日 16:24
收件人: [email-masked]<mailto:[email-masked]>; DaCheng Zhang; Nicolas Bouthors; Xialiang (Frank); Luyuan Fang; Nicolas BOUTHORS; Dacheng Zhang; Edward Lopez; John Strassner; Kepeng Li
主题: New Version Notification for draft-xia-i2nsf-capability-interface-im-06.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf