Subject: [I2nsf] draft-ietf-i2nsf-problem-and-use-cases-00.txt

From: Rakesh Kumar <[email-masked]>
Date: Thu, 7 Jul 2016 17:38:04 +0000

Dear authors,

I have read the draft "draft-ietf-i2nsf-problem-and-use-cases-00.txt”. It is very well written and identifies the most common problems due to lack of standard interfaces. It also list “Access Networks” (Residential/Cloud/Mobile) and “Cloud Data centers” as the use-cases. This is good start but I think it would be nice to list other major drivers as well since use-cases would tell us whether interfaces we develop in here are widely applicable.

Can we do something like this for use-cases (section 4)? These are just ideas to start a discussion.

  1.  Service provider use-cases
     *   Access use-cases
        *   Residential
           *   Interface for parental control
           *   Interface for threat management
        *   Mobile
           *   User experience
           *   Content and access management
           *   Threat management for infrastructure
              *   Botnet, DDoS, Malware etc.
        *   Enterprise
           *   Managed security services (Threat management)
     *   Data center (legacy/public-cloud) use-cases
        *   Managed security services
        *   GiLAN firewall
        *   Threat management for infrastructure
  2.  Enterprise use-cases
        *   Branch & Campus
           *   Threat management policies
        *   Data center (legacy/private-cloud/public-cloud) use-cases
           *   Threat management for infrastructure
           *   Regulatory and compliance policies
           *   Access policies
              *   Application, Users, Data access management
              *   Htybrid-cloud access management
           *   Application policies
              *   East-to-west policies

I can write a small paragraph for all these use-cases if we want to go deeper for the draft.

Thanks & Regards,
Rakesh

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 7 Jul 2016 18:25:17 -0400

Rakesh: 

Thank you for the comments on the draft.    I believe your comments to be technical in nature. If I am mistaken, please let me know. 

The original drafts for the use cases were: 

https://tools.ietf.org/html/draft-pastor-i2nsf-access-usecases-00

https://datatracker.ietf.org/doc/draft-zarny-i2nsf-data-center-use-cases/

https://tools.ietf.org/html/draft-qi-i2nsf-access-network-usecase-02

We compiled this to provide a summarization of these cases.    

The first thing to check is whether your ideas were in these original drafts.  If they are, and you think it should be emphasized in the summary – please indicate the text you think should be included in the summary and why.  This feedback is really useful as due to my struggles with security area reviews – this document did not enter WG LC as requested.  Here’s my understanding of your work. 

On Service provider: 

Ke Wang, Xiaojun, and Minpeng Q China Mobile)i in draft-qi-i2nsf-access-network-usecase-02 suggested the provider based:  residential  use and enterprise use.  China Mobile suggested the mobile use case in their original discussions.   Myo Zarny (Goldman Sachs), S. Magee (F5), Nicholas Leymann (DT) , and   suggested the data center use cases for data centers. 

On Enterprise, for branch and Campus we should get more detail on the threat management policies.  Please check draft-pastor-i2nsf-access-usecases-00, but I am not sure there is a match.  I think the zarny draft covered most of the issues listed, but you should look at this as well. 

If you think your text is not in these document, but you’d like to create it.  Please write-up the text and send it to list or put it in a draft.   If you just send it to the list, I’ll include your comments in my slides at IETF-95. 

Thanks for reviewing the document, 

Sue Hares

From: Rakesh Kumar [mailto:[email-masked]] 
Sent: Thursday, July 7, 2016 1:38 PM
To: Linda Dunbar; [email-masked]; [email-masked]; [email-masked]
Cc: Rakesh Kumar; [email-masked]
Subject: draft-ietf-i2nsf-problem-and-use-cases-00.txt

Dear authors,

*	Access use-cases 

*	Residential 

*	Mobile  

*	User experience

*	Enterprise  

2.	Enterprise use-cases 

*	Branch & Campus 

*	Application policies 

*	East-to-west policies

 

Thanks & Regards,

Rakesh

---

From: Rakesh Kumar <[email-masked]>
Date: Thu, 7 Jul 2016 22:45:41 +0000

Hi Sue,

I appreciate your response. Yes my comments are technical in nature.
I would definitely look at the other drafts you mentioned in this thread. I will let you know based on my finding about the missing use-cases.

IMHO, it would be great to structure section 4 (use-cases)  in this draft into some broad categories either based on end-customer (like I did) or some other way and explain the use-cases in some detail. We can talk more in Berlin to see how to do this if you are ok.

Thanks & Regards,
Rakesh

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Thursday, July 7, 2016 at 3:25 PM
To: Rakesh Kumar <[email-masked]<mailto:[email-masked]>>, 'Linda Dunbar' <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-ietf-i2nsf-problem-and-use-cases-00.txt

Rakesh:

On Service provider:

From: Rakesh Kumar [mailto:[email-masked]]
Sent: Thursday, July 7, 2016 1:38 PM
To: Linda Dunbar; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Rakesh Kumar; [email-masked]<mailto:[email-masked]>
Subject: draft-ietf-i2nsf-problem-and-use-cases-00.txt

Dear authors,

Thanks & Regards,
Rakesh

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 7 Jul 2016 18:56:10 -0400

Rakesh: 

I’d love to chat in Berlin about a way to do this.   Please let me know what times you are available M-W.  I’d like to have the discussion before the I2NSF meeting. 

Sue 

From: Rakesh Kumar [mailto:[email-masked]] 
Sent: Thursday, July 7, 2016 6:46 PM
To: Susan Hares; 'Linda Dunbar'; [email-masked]; [email-masked]
Cc: [email-masked]; Rakesh Kumar
Subject: Re: draft-ietf-i2nsf-problem-and-use-cases-00.txt

Hi Sue,

Thanks & Regards,

Rakesh

From: Susan Hares <[email-masked]>
Date: Thursday, July 7, 2016 at 3:25 PM
To: Rakesh Kumar <[email-masked]>, 'Linda Dunbar' <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: draft-ietf-i2nsf-problem-and-use-cases-00.txt

Rakesh: 

On Service provider: 

Sue Hares

Dear authors,

*	Access use-cases 

*	Residential 

*	Mobile  

*	User experience

*	Enterprise  

2.	Enterprise use-cases 

*	Branch & Campus 

*	Application policies 

*	East-to-west policies

 

Thanks & Regards,

Rakesh