Subject: [I2nsf] A New I-D on Service Function Chaining-Enabled I2NSF Architecture

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 6 Jul 2016 00:48:07 +0900

.onHi all,
I have posted a new i2nsf I-D:
- Title
   Service Function Chaining-Enabled I2NSF Architecture

- File
   https://tools.ietf.org/html/draft-hyun-i2nsf-sfc-enabled-i2nsf-00

- Abstract
   This document describes an architecture of the I2NSF framework using
   security function chaining for securiy policy enforcement.  Security
   function chaining enables composite inspection of network traffic by
   steering the traffic through multiple types of security functions
   according to the information model for the capability layer interface
   in the I2NSF framework.  This document explains the additional
   components integrated into the I2NSF framework and their
   functionalities to achieve security function chaining.  It also
   describes representative use cases to address major benefits from the
   proposed architecture.

In this draft, we propose an architecture for I2NSF to provision
network security functions by using Service Function Chaining (SFC)
of network security services.

This draft will be used for i2nsf wg to discuss how the I2NSF framework can
perform security services in NFV environments.

It will be great for you to take a look at this I-D and give us comments or
suggestions.

Thanks.

Best Regards,
Paul
-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 12 Jul 2016 20:30:13 +0000

Sangwon, SangUk, YunSuk, Paul, and Jung-Soo:

Is your draft more about "NSF dictated SF paths" (instead of SFC enabled I2NSF)?
i.e. allowing running NSFs to exchange information with "controller", which in turn changes the policies to other Network Functions (which effectively change the flow path traversed through the network)?

The Section 5.1 Use Case is about NSFs sending its flow analysis information to Controller? Is it correct?

Are you going to follow up with the information exchanged from NSF? and the follow-up policies from the Controller, as I2NSF’s scope is to specify the data models over each interface.

To avoid potential conflict with the SFC WG scope, I suggest tilting your presentation at Berlin I2NSF session more towards the concrete information exchanged between NSFs and Controllers.
Maybe using a different draft title to avoid confusion with SFC WG, such as “NSF Controlled Flow Path”, or other more accurate names you can come up with.

Thank you,

Linda

From: I2nsf [mailto:[email-masked]] On Behalf Of Mr. Jaehoon Paul Jeong
Sent: Tuesday, July 05, 2016 5:48 PM
To: [email-masked]
Cc: [email-masked]
Subject: [I2nsf] A New I-D on Service Function Chaining-Enabled I2NSF Architecture

.onHi all,

- File

- Abstract

It will be great for you to take a look at this I-D and give us comments or suggestions.

Thanks.

Best Regards,
Paul
--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>