Subject: [I2nsf] Is there any objection of merging the content from draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft?

From: Linda Dunbar <[email-masked]>
Date: Wed, 2 Aug 2017 17:31:11 +0000

I2NSF participants:

During the IETF99 I2NSF Session, our AD Kathleen said that the current IESG doesn't like to have RFC for Terminology only drafts. So we should consider merging the content of Terminology with other drafts. I2NSF framework draft would be a nature place to have the terminologies.

If you have any objections or concerns of merging the content from draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft, please express them to the I2NSF mailing list.

Thanks, Linda & Yoav.

---

From: John Strassner <[email-masked]>
Date: Wed, 2 Aug 2017 17:51:53 +0000

I expressed some minor concerns before, and will do so again.

*         What is the reasoning against publishing an INFORMATIONAL RFC for terminology?

*         Many of the terms in the current terminology draft are not used in the framework draft

o   This is because the terminology draft was originally conceived to work for many diverse subject areas

o   The framework draft will not cover some of these diverse subjects in detail, and hence, does not need those terms; including them will make the reading awkward at best

*         Thus, I would recommend

o   We keep the current terminology draft until these other subject areas mature and have WG-adopted drafts (a possible alternative is putting them on the wiki; I am not a big fan of wikis)

o   We move the appropriate terms into appropriate drafts

?  Note: this will cause duplication of terms - yet another reason to keep the terminology draft

Regards,
John

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Wednesday, August 02, 2017 10:31 AM
To: [email-masked]' <[email-masked]>; [email-masked]; [email-masked]
Cc: 'Kathleen Moriarty' <[email-masked]>; Yoav Nir <[email-masked]>
Subject: [I2nsf] Is there any objection of merging the content from draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft?

I2NSF participants:

Thanks, Linda & Yoav.

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 2 Aug 2017 15:16:38 -0400

Hi John,

As a standalone document, the terminology draft is a support document.
The IESG issued the following statement on support documents:
https://www.ietf.org/iesg/statement/support-documents-in-ietf-wgs.html

I have no problem helping a WG to publish support documents, but would
like them to think through what they are doing. We typically see
terminology as part of a main document for a WG and not a draft by
itself.  If it's part of a standards track document (appendix or
terminology section), then there is no question on it's value.

You may want to take a look at the ballots for the WG documents that
have gone through the IESG to date and you'll see the types of issues.
Mainly it is the time/resources spent publishing such documents.  I'd
like to see the terminology published in some document, but not
necessarily as a stand alone document.

Best regards,
Kathleen

On Wed, Aug 2, 2017 at 1:51 PM, John Strassner
<[email-masked]> wrote:
> ·         What is the reasoning against publishing an INFORMATIONAL RFC for
> terminology?
>
> ·         Many of the terms in the current terminology draft are not used in
> the framework draft
>
> o   The framework draft will not cover some of these diverse subjects in
> detail, and hence, does not need those terms; including them will make the
> reading awkward at best
>
> ·         Thus, I would recommend
>
> o   We keep the current terminology draft until these other subject areas
> mature and have WG-adopted drafts (a possible alternative is putting them on
> the wiki; I am not a big fan of wikis)
>
> §  Note: this will cause duplication of terms – yet another reason to keep
> the terminology draft
>
>
>
> Regards,
>
> John
>
>
>
> Subject: [I2nsf] Is there any objection of merging the content from
> draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft?
>
>
>
> I2NSF participants:
>
>
>
> During the IETF99 I2NSF Session, our AD Kathleen said that the current IESG
> doesn’t like to have RFC for Terminology only drafts. So we should consider
> merging the content of Terminology with other drafts. I2NSF framework draft
> would be a nature place to have the terminologies.
>
>
>
> If you have any objections or concerns of merging the content from
> draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft, please
> express them to the I2NSF mailing list.
>
>
>
> Thanks, Linda & Yoav.
>
>

-- 

Best regards,
Kathleen

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 2 Aug 2017 19:27:42 +0000

John,

Thank you very much for the suggestion of only porting the terminologies that are used by Framework into the draft-ietf-i2nsf-framework draft. That is really good suggestion.

We can still keep the Terminology draft as WG draft.

Linda

From: John Strassner
Sent: Wednesday, August 02, 2017 12:52 PM
To: Linda Dunbar <[email-masked]>; [email-masked]' <[email-masked]>; [email-masked]; [email-masked]
Cc: 'Kathleen Moriarty' <[email-masked]>; Yoav Nir <[email-masked]>
Subject: RE: [I2nsf] Is there any objection of merging the content from draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft?

Regards,
John

From: I2nsf [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Wednesday, August 02, 2017 10:31 AM
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: 'Kathleen Moriarty' <[email-masked]<mailto:[email-masked]>>; Yoav Nir <[email-masked]<mailto:[email-masked]>>
Subject: [I2nsf] Is there any objection of merging the content from draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft?

I2NSF participants:

Thanks, Linda & Yoav.

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 3 Aug 2017 11:18:48 +0100

FWIW, some context.

As we started to advance a number of I2NSF document we ran into a few problems:
- Different documents used different terms for similar or identical concepts
- Different documents used the same terms to mean different things
- Different documents attempted to define the same terms, but actually introduced
   discrepancies in the definitions
- Documents started to acquire circular normative dependencies on each other
- Documents made best efforts to duplicate definition text but were not kept
   up-to-date and in synch

The terminology document was introduced as a way to provide one single point of reference for all terms and to ensure consistency.

Of course, I don't mind what solution to this purely non-technical issue is used so long as it adequately addresses all of the needs. And if the IESG has cycles to burn to work out how to publish terminology definitions without causing ambiguity or confusion, then it is fine with me that they do that (it will keep them from doing harm in the technical areas where they might not have the expertise to do the right thing :-)

But there are three concerns that I have:

1. Moving *some* of the definitions from the terminology draft to another draft will leave behind other terms. That is to say, not all the terms currently in the terminology draft are currently used in just one other draft. So there will be an annoying and messy period of working out where the terms need to be moved to. Alternatively, the whole of the terminology draft should be subsumed into some other foundational document notwithstanding that that other document does not use those terms - that sounds easy, but I bet there will be review comments that say "delete this term because it is not used in this document."

2. When new drafts are written there needs to be a central place to go to find the right term to use to prevent invention of new terms or re-invention of existing terms. 

3. When a WG or document authors find themselves doing "whatever is necessary to get a document published" they are making pointless concessions to the arbitrary rules of Discusses placed on them by the IESG which risks over-running community consensus. That is, of course, a socio-political matter, and I don't expect the WG to engage on it, but individuals who care about the IETF might want to think it through.

I'm not really working on this stuff anymore, so this email really is only for context and to help you understand how we got to where we are.

Cheers,
Adrian

> -----Original Message-----
> From: I2nsf [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
> Sent: 02 August 2017 20:17
> To: John Strassner
> Cc: [email-masked]; [email-masked]; draft-ietf-i2nsf-
> [email-masked]; Yoav Nir; Linda Dunbar
> Subject: Re: [I2nsf] Is there any objection of merging the content from draft-ietf-
> i2nsf-terminology to draft-ietf-i2nsf-framework draft?
> 
> Hi John,
> 
> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 3 Aug 2017 12:47:31 +0200

Hello Adrian,

some comments inline.

> The terminology document was introduced as a way to provide one single point of reference for all terms and to ensure consistency.

Personally I think, that is a very elegant way to move forward. Alas, 
authors of other documents have to start to use the agreed upon terms 
and by using them also use them in respect to their current definition.

Definition of terms MUST NOT be a blocker. If there are terms used in 
multiple documents and are providing a vital foundation - you cannot 
change them all the time, over and over again.

This also means that authors that need stable terms and want to move on 
to the really interesting things SHOULD provide input to terminology 
issues as early as possible, chime in, and also keep in the loop. 
Otherwise they MUST deal with the definitions as they evolve and are 
eventually defined, I guess?

> Of course, I don't mind what solution to this purely non-technical issue is used so long as it adequately addresses all of the needs. And if the IESG has cycles to burn to work out how to publish t…

This is an interesting point. What do you think would be the way to move 
forward that would use the minimal amount of IESG cycles?

> 1. Moving *some* of the definitions from the terminology draft to another draft will leave behind other terms. That is to say, not all the terms currently in the terminology draft are currently use…

Splintering the definitions into multiple documents on one hand "solves" 
a portion of the "overhead problem" of "yet another document", but on 
the other hand will result in more thresholds for implementors. If one 
is trying to look up definitions, especially in the initial phase of 
implementation, this is a frustrating blocker for adopters that I've 
observed quite often.

Merging the definition into a "root" document requires.... a adequate 
"root" document that ideally uses and introduces all the terms in 
normative text, I think.

> I'm not really working on this stuff anymore, so this email really is only for context and to help you understand how we got to where we are.

Thank you for your input even more so! I try to be not a blocker. If an 
adequate document that could subsume the terminology can be identified, 
we should explore the direction. Please note that - in general:

- I agree with John's point of view, as stated by him previously.
- after certain protocol actions, you are stuck with the definitions in 
your "root" document -if- you place them there. That can become a real 
problem (blocker) by itself.

> Adrian

Viele Grüße,

Henk

---

From: Yoav Nir <[email-masked]>
Date: Thu, 03 Aug 2017 14:27:28 +0300

Hi, Adrian.

I tend to agree that splitting the terminology around to several small
documents is not a good way to go.  

I think it should be OK to move the contents into the framework draft,
perhaps as an appendix, with an appropriate paragraph saying that the
terminology in this section is meant for the entire document set of
I2NSF and some of the terms are not used in this (the framework)
document.

There is one potential issue with doing it this way. We intend to get
the framework document published soonish. So if we add the terminology
there, it gets published in an RFC and gets "set in stone". While it's
always possible to add new terms afterwards, it gets messy to change the
meaning of existing terms already defined in the RFC.

Are we willing to accept this risk/constraint of future work?

Yoav

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 3 Aug 2017 08:24:02 -0400

Yoav and Adrian: 

I agree with you that split the terminology is not a good way to go.  As a solution to Yoav's problem, may I suggest the following: 

1) publish the terminology information in the framework document, 
2) Keep a WG draft for terms that change - this can create a bis document for the framework document when we have completed all the rest of the work, 

Cheerily,  
Sue hares 

-----Original Message-----
From: Yoav Nir [mailto:[email-masked]] 
Sent: Thursday, August 3, 2017 7:27 AM
To: [email-masked]
Cc: [email-masked]'; [email-masked]; 'Kathleen Moriarty'
Subject: Re: [I2nsf] Is there any objection of merging the content from draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft?

Hi, Adrian.

I tend to agree that splitting the terminology around to several small documents is not a good way to go.  

I think it should be OK to move the contents into the framework draft, perhaps as an appendix, with an appropriate paragraph saying that the terminology in this section is meant for the entire document set of I2NSF and some of the terms are not used in this (the framework) document.

There is one potential issue with doing it this way. We intend to get the framework document published soonish. So if we add the terminology there, it gets published in an RFC and gets "set in stone". While it's always possible to add new terms afterwards, it gets messy to change the meaning of existing terms already defined in the RFC.

Yoav

On Thu, 2017-08-03 at 11:18 +0100, Adrian Farrel wrote:
> Of course, I don't mind what solution to this purely non-technical 
> issue is used so long as it adequately addresses all of the needs. And 
> if the IESG has cycles to burn to work out how to publish terminology 
> definitions without causing ambiguity or confusion, then it is fine 
> with me that they do that (it will keep them from doing harm in the 
> technical areas where they might not have the expertise to do the 
> right thing :-)
> 
> > Cc: [email-masked]; [email-masked]; 
> > draft-ietf-i2nsf- [email-masked]; Yoav Nir; Linda Dunbar
> > Subject: Re: [I2nsf] Is there any objection of merging the content 
> > from draft-ietf- i2nsf-terminology to draft-ietf-i2nsf-framework draft?
> > 
> > Hi John,
> > 
> > I have no problem helping a WG to publish support documents, but 
> > would like them to think through what they are doing. We typically 
> > see terminology as part of a main document for a WG and not a draft 
> > by itself.  If it's part of a standards track document (appendix or 
> > Mainly it is the time/resources spent publishing such documents.  
> > I'd like to see the terminology published in some document, but not 
> > > detail, and hence, does not need those terms; including them will 
> > > make the reading awkward at best
> > >
> > > mature and have WG-adopted drafts (a possible alternative is 
> > > putting them on the wiki; I am not a big fan of wikis)
> > >
> > > §  Note: this will cause duplication of terms – yet another reason 
> > > to keep the terminology draft
> > >
> > >
> > >
> > > Regards,
> > >
> > > John
> > >
> > >
> > >
> > > To: [email-masked]' <[email-masked]>; 
> > > [email-masked];
> > > [email-masked]
> > > Subject: [I2nsf] Is there any objection of merging the content 
> > > from draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft?
> > >
> > >
> > >
> > > I2NSF participants:
> > >
> > >
> > >
> > > During the IETF99 I2NSF Session, our AD Kathleen said that the 
> > > current IESG doesn’t like to have RFC for Terminology only drafts. 
> > > So we should consider merging the content of Terminology with 
> > > other drafts. I2NSF framework draft would be a nature place to have the terminologies.
> > >
> > >
> > >
> > > draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft, 
> > > please express them to the I2NSF mailing list.
> > >
> > >
> > >
> > > Thanks, Linda & Yoav.
> > >
> > >
> > 
> > 
> > 
> > --
> > 
> > Best regards,
> > Kathleen
> >

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 3 Aug 2017 14:42:38 +0200

Hello Sue :)

I hope you are well!

> 2) Keep a WG draft for terms that change - this can create a bis document for the framework document when we have completed all the rest of the work,

The meta-goal here is to safe "IESG cycles", if I understand it 
correctly? Is the - eventually inevitable - creation of a bis document 
less effort than maintaining a separate terminology document?

Viele Grüße,

Henk

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 3 Aug 2017 09:56:32 -0400

Thank you, all for the useful discussion.  If the WG (and it seems to)
feels strongly about a separate document, we can certainly publish
this as a separate document.  This discussion was helpful and will be
if there is any pushback.  Thanks for taking the time to share your
thoughts on list.

Best regards,
Kathleen

On Thu, Aug 3, 2017 at 8:43 AM, NetNull <[email-masked]> wrote:
> I wouldn't want a terminology document that is set in stone, by merging it
> into the framework document.  I don't think the role of the framework
> document is to be the terminology standard for other documents.  The last
> thing I would want is an argument in that a given effort is out of bounds
> because the terminology is not in the framework, or the framework
> terminology is somehow obsolete.
>
> I do agree that as the framework document effort preceded the terminology
> document, we should reconcile the two.
>
>
> On August 3, 2017 at 6:18 AM, Adrian Farrel <[email-masked]> wrote:
>
> FWIW, some context.
>
> The terminology document was introduced as a way to provide one single point
> of reference for all terms and to ensure consistency.
>
> Of course, I don't mind what solution to this purely non-technical issue is
> used so long as it adequately addresses all of the needs. And if the IESG
> has cycles to burn to work out how to publish terminology definitions
> without causing ambiguity or confusion, then it is fine with me that they do
> that (it will keep them from doing harm in the technical areas where they
> might not have the expertise to do the right thing :-)
>
> 1. Moving *some* of the definitions from the terminology draft to another
> draft will leave behind other terms. That is to say, not all the terms
> currently in the terminology draft are currently used in just one other
> draft. So there will be an annoying and messy period of working out where
> the terms need to be moved to. Alternatively, the whole of the terminology
> draft should be subsumed into some other foundational document
> notwithstanding that that other document does not use those terms - that
> sounds easy, but I bet there will be review comments that say "delete this
> term because it is not used in this document."
>
> 2. When new drafts are written there needs to be a central place to go to
> find the right term to use to prevent invention of new terms or re-invention
> of existing terms.
>
> 3. When a WG or document authors find themselves doing "whatever is
> necessary to get a document published" they are making pointless concessions
> to the arbitrary rules of Discusses placed on them by the IESG which risks
> over-running community consensus. That is, of course, a socio-political
> matter, and I don't expect the WG to engage on it, but individuals who care
> about the IETF might want to think it through.
>
> I'm not really working on this stuff anymore, so this email really is only
> for context and to help you understand how we got to where we are.
>
> Cheers,
> Adrian
>

-- 

Best regards,
Kathleen

---

From: NetNull <[email-masked]>
Date: Thu, 3 Aug 2017 08:43:01 -0400

I wouldn't want a terminology document that is set in stone, by merging it into the framework document.I don't think the role of the framework document is to be the terminology standard for other documents.The last thing I would want is an argument in that a given effort is out of bounds because the terminology is not in the framework, or the framework terminology is somehow obsolete.

I do agree that as the framework document effort preceded the terminology document, we should reconcile the two.

On August 3, 2017 at 6:18 AM, Adrian Farrel<[email-masked]>wrote:
> > <[email-masked]>wrote:
> > > To: [email-masked]'<[email-masked]>; [email-masked];
> > > Cc: 'Kathleen Moriarty'<[email-masked]>; Yoav Nir
> > > <[email-masked]>
> > > Thanks, Linda&Yoav.

---

From: John Strassner <[email-masked]>
Date: Thu, 3 Aug 2017 09:29:06 -0700

I disagree that creating a bis document for terminology changes is a good
approach. This means that we are creating a bis document for content that
is not inherently part of the framework document!

John

On Thu, Aug 3, 2017 at 5:24 AM, Susan Hares <[email-masked]> wrote:

> Yoav and Adrian:
>
> I agree with you that split the terminology is not a good way to go.  As a
> solution to Yoav's problem, may I suggest the following:
>
> 2) Keep a WG draft for terms that change - this can create a bis document
> for the framework document when we have completed all the rest of the work,
>
> Cheerily,
> Sue hares
>
> Subject: Re: [I2nsf] Is there any objection of merging the content from
> terminology in this section is meant for the entire document set of I2NSF
> and some of the terms are not used in this (the framework) document.
>
> There is one potential issue with doing it this way. We intend to get the
> framework document published soonish. So if we add the terminology there,
> it gets published in an RFC and gets "set in stone". While it's always
> possible to add new terms afterwards, it gets messy to change the meaning
> of existing terms already defined in the RFC.
>
> > The terminology document was introduced as a way to provide one single
> point of reference for all terms and to ensure consistency.
> >
> > 1. Moving *some* of the definitions from the terminology draft to
> another draft will leave behind other terms. That is to say, not all the
> terms currently in the terminology draft are currently used in just one
> other draft. So there will be an annoying and messy period of working out
> where the terms need to be moved to. Alternatively, the whole of the
> terminology draft should be subsumed into some other foundational document
> > 2. When new drafts are written there needs to be a central place to go
> to find the right term to use to prevent invention of new terms or
> re-invention of existing terms.
> >
> necessary to get a document published" they are making pointless
> concessions to the arbitrary rules of Discusses placed on them by the IESG
> which risks over-running community consensus. That is, of course, a
> socio-political matter, and I don't expect the WG to engage on it, but
> individuals who care about the IETF might want to think it through.
> >
> > I'm not really working on this stuff anymore, so this email really is
> only for context and to help you understand how we got to where we are.
> >
> > Cheers,
> > Adrian
> >
> > > > o   This is because the terminology draft was originally conceived
> to work
> > > > for many diverse subject areas
> > > >

-- 
regards,
John

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Fri, 4 Aug 2017 03:39:39 +0000

+1

-----邮件原件-----
发件人: John Strassner [mailto:[email-masked]] 
发送时间: 2017年8月4日 0:29
收件人: Susan Hares
抄送: Yoav Nir; Adrian Farrel; [email-masked]; [email-masked]; Kathleen Moriarty
主题: Re: [I2nsf] Is there any objection of merging the content from draft-ietf-i2nsf-terminology to draft-ietf-i2nsf-framework draft?

I disagree that creating a bis document for terminology changes is a good approach. This means that we are creating a bis document for content that is not inherently part of the framework document!

John

On Thu, Aug 3, 2017 at 5:24 AM, Susan Hares <[email-masked]> wrote:

> Yoav and Adrian:
>
> I agree with you that split the terminology is not a good way to go.  
> As a solution to Yoav's problem, may I suggest the following:
>
> 2) Keep a WG draft for terms that change - this can create a bis 
> document for the framework document when we have completed all the 
> rest of the work,
>
> Cheerily,
> Sue hares
>
> I2NSF and some of the terms are not used in this (the framework) document.
>
> always possible to add new terms afterwards, it gets messy to change 
> the meaning of existing terms already defined in the RFC.
>
> > As we started to advance a number of I2NSF document we ran into a 
> > few
> problems:
> > - Different documents attempted to define the same terms, but 
> > actually
> introduced
> > - Documents made best efforts to duplicate definition text but were 
> > not
> kept
> >    up-to-date and in synch
> >
> > issue is used so long as it adequately addresses all of the needs. 
> > And if the IESG has cycles to burn to work out how to publish 
> > terminology definitions without causing ambiguity or confusion, then 
> > it is fine with me that they do that (it will keep them from doing 
> > harm in the technical areas where they might not have the expertise 
> > to do the right thing :-)
> >
> another draft will leave behind other terms. That is to say, not all 
> the terms currently in the terminology draft are currently used in 
> just one other draft. So there will be an annoying and messy period of 
> working out where the terms need to be moved to. Alternatively, the 
> whole of the terminology draft should be subsumed into some other 
> foundational document notwithstanding that that other document does 
> not use those terms - that sounds easy, but I bet there will be review 
> comments that say "delete this term because it is not used in this document."
> >
> concessions to the arbitrary rules of Discusses placed on them by the 
> IESG which risks over-running community consensus. That is, of course, 
> a socio-political matter, and I don't expect the WG to engage on it, 
> but individuals who care about the IETF might want to think it through.
> >
> > > As a standalone document, the terminology draft is a support 
> > > document