Subject: Re: [I2nsf] I2NSF WG milestone & deliverable check

From: Linda Dunbar <[email-masked]>
Date: Thu, 21 Jun 2018 17:03:03 +0000

Paul,

Are those tasks still on track?
We need to re-adjust our milestone.

Linda

From: Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
Sent: Wednesday, April 11, 2018 10:55 AM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]; SecCurator_Team <[email-masked]>; Mr. Jaehoon Paul Jeong <[email-masked]>
Subject: Re: [I2nsf] I2NSF WG milestone & deliverable check

Hi Linda,
Here is the estimated time for our three WG documents, assuming that
the NSFs Capabilities Information Model Document (draft-ietf-i2nsf-capability-01)
will be sent to IESG for RFC publication before September 2018:

draft-ietf-i2nsf-applicability-02
Applicability of Interfaces to Network Security Functions to Network-Based Security Services
=> Submission to IESG for publication: June 2018

draft-ietf-i2nsf-consumer-facing-interface-dm-00
I2NSF Consumer-Facing Interface YANG Data Model
=> Submission to IESG for publication: October 2018

draft-ietf-i2nsf-nsf-facing-interface-dm-00
I2NSF Network Security Function-Facing Interface YANG Data Model
=> Submission to IESG for publication: October 2018

Thanks.

Best Regards,
Paul

On Sat, Apr 7, 2018 at 7:28 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
I2NSF WG,

Obviously we need to re-adjust our milestone established when the WG was created 2 years ago. We actually are pretty much on track, except the IESG publication dates are off.

Among the following WG documents, can authors give an estimate when you think the document can be completed? So we can adjust the milestone accordingly.

Document

Date

Status

IPR

AD / Shepherd

Active Internet-Drafts (7 hits)

draft-ietf-i2nsf-applicability-02<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-applicability/>
Applicability of Interfaces to Network Security Functions to Network-Based Security Services

2018-03-05
20 pages

I-D Exists
WG Document
Apr 2017

draft-ietf-i2nsf-capability-01<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability/>
Information Model of NSFs Capabilities

2018-04-03 <https://www.ietf.org/rfcdiff?url2=draft-ietf-i2nsf-capability-01>
57 pages New

I-D Exists
WG Document

draft-ietf-i2nsf-client-facing-interface-req-04<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-client-facing-interface-req/>
Requirements for Client-Facing Interface to Security Controller

2018-01-16
24 pages

I-D Exists
WG Document
Jun 2016

draft-ietf-i2nsf-consumer-facing-interface-dm-00<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-consumer-facing-interface-dm/>
I2NSF Consumer-Facing Interface YANG Data Model

2018-03-05 ☯
53 pages

I-D Exists
WG Document

draft-ietf-i2nsf-nsf-facing-interface-dm-00<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-facing-interface-dm/>
I2NSF Network Security Function-Facing Interface YANG Data Model

2018-03-05 ☯
46 pages

I-D Exists
WG Document

draft-ietf-i2nsf-sdn-ipsec-flow-protection-01<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-sdn-ipsec-flow-protection/>
Software-Defined Networking (SDN)-based IPsec Flow Protection

Oct 2017

Data Models and Applicability Statements to IESG for publication

Apr 2017

All early drafts to IESG for publication (if WG decided to proceed): use cases, problem statement, and gap analysis document; framework document; information model requirements for extensions to protocols document; examination of existing secure communication mechanisms document

Apr 2017

Adopt IANA registry consideration as WG document

Done

Adopt applicability statements as WG Document
draft-ietf-i2nsf-applicability<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-applicability/>

Done

Adopt data models as WG document
draft-jeong-i2nsf-consumer-facing-interface-dm<https://datatracker.ietf.org/doc/draft-jeong-i2nsf-consumer-facing-interface-dm/>
draft-kim-i2nsf-nsf-facing-interface-data-model<https://datatracker.ietf.org/doc/draft-kim-i2nsf-nsf-facing-interface-data-model/>

Dec 2016

Adopt examination of existing secure communication mechanisms as WG document

Done

Adopt info model as WG document (if desired)
draft-baspez-i2nsf-capabilities<https://datatracker.ietf.org/doc/draft-baspez-i2nsf-capabilities/>

Done

WG decides whether to progress adopted drafts for publication as RFCs (use cases, framework, information model, and examination of existing secure communication mechanisms)

Done

Adopt requirements for extensions to protocols as WG document
draft-ietf-i2nsf-client-facing-interface-req<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-client-facing-interface-req/>

Done

Adopt framework as WG document
draft-ietf-i2nsf-framework<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-framework/>
draft-ietf-i2nsf-terminology<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-terminology/>

Done

Adopt use Cases, problem statement, and gap analysis as WG document
draft-ietf-i2nsf-gap-analysis<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-gap-analysis/>
draft-ietf-i2nsf-problem-and-use-cases<https://datatracker.ietf.org/doc/draft-ietf-i2nsf-problem-and-use-cases/>

Thanks, Linda & Yoav

_______________________________________________
I2nsf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2nsf

--
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php<http://cpslab.skku.edu/people-jaehoon-jeong.php>

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Fri, 22 Jun 2018 23:13:39 +0900

Hi Linda,
I think they are on the right track.
However, I2NSF Applicability document is under revision, so
it needs some adjustment, such as the submission to the IESG on August 2018
through the feedback in this IETF-102 Montreal meeting.

Also, I2NSF Capability Data Model document will be able to be submitted
along with other data model documents as below.

-----------------------------------------------------------------------------------------------------------------------
draft-ietf-i2nsf-applicability-02
Applicability of Interfaces to Network Security Functions to Network-Based
Security Services
=> Submission to IESG for publication: August 2018

draft-ietf-i2nsf-capability-data-model-00
I2NSF Capability YANG Data Model
=> Submission to IESG for publication: October 2018
-----------------------------------------------------------------------------------------------------------------------

My SKKU team is also working for the registration interface information and
data models
for the Hackathon project in this IETF-102 Montreal meeting.

Thanks.

Best Regards,
Paul

On Fri, Jun 22, 2018 at 2:03 AM, Linda Dunbar <[email-masked]>
wrote:

> *From:* Mr. Jaehoon Paul Jeong [mailto:[email-masked]]
> *Sent:* Wednesday, April 11, 2018 10:55 AM
> *To:* Linda Dunbar <[email-masked]>
> *Cc:* [email-masked]; SecCurator_Team <skku_secu-brain_all@
> googlegroups.com>; Mr. Jaehoon Paul Jeong <[email-masked]>
> *Subject:* Re: [I2nsf] I2NSF WG milestone & deliverable check
>
>
>
> Hi Linda,
>
> On Sat, Apr 7, 2018 at 7:28 AM, Linda Dunbar <[email-masked]>
> wrote:
>
> I2NSF WG,
>
>
>
> Obviously we need to re-adjust our milestone established when the WG was
> created 2 years ago. We actually are pretty much on track, except the IESG
> publication dates are off.
>
>
>
> Among the following WG documents, can authors give an estimate when you
> think the document can be completed? So we can adjust the milestone
> accordingly.
>
>
>
>
>
>
>
> *Document*
>
> *Date*
>
> *Status*
>
> *IPR*
>
> *AD / Shepherd*
>
> *Active Internet-Drafts (7 hits)*
>
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-applicability/>
> *Applicability of Interfaces to Network Security Functions to
> Network-Based Security Services*
>
> 2018-03-05
> 20 pages
>
> I-D Exists
> WG Document
> *Apr 2017*
>
> draft-ietf-i2nsf-capability-01
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-capability/>
> *Information Model of NSFs Capabilities*
>
> 2018-04-03
> <https://www.ietf.org/rfcdiff?url2=draft-ietf-i2nsf-capability-01>
> 57 pages *New*
>
> I-D Exists
> WG Document
>
> draft-ietf-i2nsf-client-facing-interface-req-04
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-client-facing-interface-req/>
>
> *Requirements for Client-Facing Interface to Security Controller*
>
> 2018-01-16
> 24 pages
>
> I-D Exists
> WG Document
> *Jun 2016*
>
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-consumer-facing-interface-dm/>
>
> *I2NSF Consumer-Facing Interface YANG Data Model*
>
> 2018-03-05 ☯
> 53 pages
>
> I-D Exists
> WG Document
>
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-facing-interface-dm/>
>
> *I2NSF Network Security Function-Facing Interface YANG Data Model*
>
> 2018-03-05 ☯
> 46 pages
>
> I-D Exists
> WG Document
>
> draft-ietf-i2nsf-sdn-ipsec-flow-protection-01
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-sdn-ipsec-flow-protection/>
>
> *Software-Defined Networking (SDN)-based IPsec Flow Protection*
>
>
>
>
>
>
>
> Oct 2017
>
> All early drafts to IESG for publication (if WG decided to proceed): use
> cases, problem statement, and gap analysis document; framework document;
> information model requirements for extensions to protocols document;
> examination of existing secure communication mechanisms document
>
> Apr 2017
>
> *Done*
> draft-ietf-i2nsf-applicability
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-applicability/>
>
> *Done*
>
> draft-jeong-i2nsf-consumer-facing-interface-dm
> <https://datatracker.ietf.org/doc/draft-jeong-i2nsf-consumer-facing-interface-dm/>
>
> draft-kim-i2nsf-nsf-facing-interface-data-model
> <https://datatracker.ietf.org/doc/draft-kim-i2nsf-nsf-facing-interface-data-model/>
>
> Dec 2016
>
> *Done*
> draft-baspez-i2nsf-capabilities
> <https://datatracker.ietf.org/doc/draft-baspez-i2nsf-capabilities/>
>
> *Done*
>
> WG decides whether to progress adopted drafts for publication as RFCs (use
> cases, framework, information model, and examination of existing secure
> communication mechanisms)
>
> *Done*
>
> draft-ietf-i2nsf-client-facing-interface-req
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-client-facing-interface-req/>
>
> *Done*
>
> draft-ietf-i2nsf-framework
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-framework/>
> draft-ietf-i2nsf-terminology
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-terminology/>
>
> *Done*
>
> draft-ietf-i2nsf-gap-analysis
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-gap-analysis/>
> draft-ietf-i2nsf-problem-and-use-cases
> <https://datatracker.ietf.org/doc/draft-ietf-i2nsf-problem-and-use-cases/>
>
>
>
> Thanks, Linda & Yoav
>
>
> [email-masked]
> Email: [email-masked], [email-masked]
> Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
> <http://cpslab.skku.edu/people-jaehoon-jeong.php>
>
> [email-masked]

-- 
===========================
Mr. Jaehoon (Paul) Jeong, Ph.D.
Assistant Professor
Department of Software
Sungkyunkwan University
Office: +82-31-299-4957
Email: [email-masked], [email-masked]
Personal Homepage: http://iotlab.skku.edu/people-jaehoon-jeong.php
<http://cpslab.skku.edu/people-jaehoon-jeong.php>