Subject: Re: [I2nsf] [IANA #1217705] Expert Review for draft-ietf-i2nsf-nsf-monitoring-data-model-12 (xml-registry)

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Thu, 13 Jan 2022 03:06:31 +0900

Hi Tim,
We authors have addressed your comments in the beginning of Section 11.
The update is as follows:
------------------
- OLD:

11.  XML Examples for I2NSF NSF Monitoring

   This section shows the XML examples of I2NSF NSF Monitoring data
   delivered via Monitoring Interface from an NSF.

- NEW:

11.  XML Examples for I2NSF NSF Monitoring

   This section shows the XML examples of I2NSF NSF Monitoring data
   delivered via Monitoring Interface from an NSF.  In order for the XML
   to work, the prefix in the element that uses "identityref" type
   (e.g., /i2nsf-event/i2nsf-system-detection-alarm/alarm-category/) in
   the YANG module described in this document MUST be the same as the
   namespace prefix for urn:ietf:params:xml:ns:yang:ietf-i2nsf-nsf-
   monitoring.  The XML software MUST be chosen that makes the namespace
   prefix information available.
------------------

Is this update fine to you?

Thanks.

Best Regards,
Paul

On Fri, Dec 17, 2021 at 12:03 PM Tim Bray <[email-masked]> wrote:

> Sorry, but this has the same problem in figure 11.1 that we've just been
> discussing with Ian.
>
> For it to work, (a) the prefix in the alarm-category element MUST be the
> same as the namespace prefix for
> urn:ietf:params:xml:ns:yang:ietf-i2nsf-nsf-monitoring, which means that XML
> software MUST be chosen that makes the namespace prefix information
> available.  I don't think it's OK for the draft not to say those thigns.
>
> <alarm-category
>            xmlns:nsfmi="urn:ietf:params:xml:ns:yang:\
>                       ietf-i2nsf-nsf-monitoring">
>            nsfmi:memory-alarm
>          </alarm-category>
>
>
> On Thu, Dec 16, 2021 at 4:25 PM Amanda Baber via RT <
> [email-masked]> wrote:
>
>> Hi Tim and Martin (cc: i2nsf WG),
>>
>> Have you had a chance to review the XML registration in this document?
>>
>>
>> https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-model/
>>
>> thanks,
>> Amanda
>>
>> On Tue Nov 30 21:38:22 2021, michelle.cotton wrote:
>> > Dear Tim and Martin,
>> > (cc to i2nsf WG)
>> >
>> > As the designated experts for the ns IETF xml registry, can you review
>> > the proposed registration in draft-ietf-i2nsf-nsf-monitoring-data-
>> > model-12 for us? Please see
>> >
>> > https://datatracker.ietf.org/doc/draft-ietf-i2nsf-nsf-monitoring-data-
>> > model/
>> >
>> > If this is OK, when the IESG approves the document for publication,
>> > we'll make the registration at
>> >
>> > https://www.iana.org/assignments/xml-registry
>> >
>> > The IESG has asked us to set a two-week deadline for registration
>> > reviews. The due date for this request is 14 December 2021.
>> >
>> > Thank you,
>> >
>> > Michelle Cotton
>> > IANA Services
>>
>> _______________________________________________
> I2nsf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i2nsf
>

---

From: Tim Bray <[email-masked]>
Date: Wed, 12 Jan 2022 10:17:11 -0800

Thank you so much for addressing this!  May I suggest a couple of slight
edits to the proposed text, just for clarity and slightly more idiomatic
English?

<<<<<<<<<<<<
This section shows XML examples of I2NSF NSF Monitoring data
delivered via Monitoring Interface from an NSF.  In order for the XML data
to be used correctly, the prefix (i.e., the characters before the colon) in
the
content of the element that uses the "identityref" type
(e.g., /i2nsf-event/i2nsf-system-detection-alarm/alarm-category/) in
the YANG module described in this document MUST be the same as the
namespace prefix for urn:ietf:params:xml:ns:yang:ietf-i2nsf-nsf-
monitoring.  Therefore, XML software MUST be chosen that makes the
namespace prefix information available.
<<<<<<<<<<<<<<

I hope that in future we can arrange for YANG namespace registrations to
include this note?

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Tue, 18 Jan 2022 20:50:31 +0900

Hi Tim,
I have reflected your suggested text below on the revised draft.

Thanks for your help.

Best Regards,
Paul

On Thu, Jan 13, 2022 at 3:17 AM Tim Bray <[email-masked]> wrote:

> to be used correctly, the prefix (i.e., the characters before the colon)
> in the

---

From: Tim Bray <[email-masked]>
Date: Tue, 18 Jan 2022 03:59:49 -0800

Excellent, thank you. You can put me down as withdrawing any objections to
this draft.

I would hope that in future YANG registrations we would see similar text?

On Tue, Jan 18, 2022 at 3:51 AM Mr. Jaehoon Paul Jeong <
[email-masked]> wrote:

>> data
>>>> Sorry, but this has the same problem in figure 11.1 that we've just
>>>> been discussing with Ian.
>>>>
>>>> For it to work, (a) the prefix in the alarm-category element MUST be
>>>> the same as the namespace prefix for

---

From: "Mr. Jaehoon Paul Jeong" <[email-masked]>
Date: Wed, 26 Jan 2022 19:56:29 +0900

Hi Tim,
Here is the revised draft of I2NSF Monitoring Interface:
https://datatracker.ietf.org/doc/html/draft-ietf-i2nsf-nsf-monitoring-data-model-13

Parick and I have addressed your comments from page 1 in the attached
revision letter.

Thanks for your help to improve our draft.

Best Regards,
Paul

---

From: Tim Bray <[email-masked]>
Date: Wed, 26 Jan 2022 08:25:14 -0800

And in return, thank you for being open to addressing this issue.