Subject: [i2rs] WG LC for requirement documents (10/6 to 10/20/2015) -

From: "Susan Hares" <[email-masked]>
Date: Tue, 6 Oct 2015 20:16:21 -0400

This begins a 2 week WG LC on the following requirement documents for I2RS: 

draft-ietf-i2rs-ephemeral-state-02.txt  

http://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/

Note: I2RS ephemeral state has a section on minimal NETCONF Changes.  

This section is blank and this will be discussed at the 10/17/2015 interim.

We will discuss whether this section should be kept or removed.   

draft-ietf-i2rs-protocol-security-requirements-01.txt 

http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-requiremen
ts/

draft-ietf-i2rs-pub-sub-requirements-03.txt 

http://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/

draft-ietf-i2rs-traceability-03.txt 

http://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/

Sue Hares

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 7 Oct 2015 08:44:28 +0200

> We will discuss whether this section should be kept or removed.   

   Note: I2RS protocol design team is working to complete this set of
   minimal changes.

Has the design team produced any output that I can read to understand
how the changes to NETCONF and YANG are supposed to work?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 7 Oct 2015 04:03:46 -0400

Juergen: 

Not the official design team from NETCONF/I2RS.  An initial strawman ideas
from Andy and Kent will be presented today at I2RS Interim. 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Wednesday, October 07, 2015 2:44 AM
To: Susan Hares
Cc: 'Jeffrey Haas'; [email-masked]; 'Alia Atlas'
Subject: Re: [i2rs] WG LC for requirement documents (10/6 to 10/20/2015) -

Has the design team produced any output that I can read to understand how
the changes to NETCONF and YANG are supposed to work?

/js

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 7 Oct 2015 15:42:45 +0000

Support.

Linda

From: i2rs [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, October 06, 2015 7:16 PM
To: [email-masked]
Cc: 'Jeffrey Haas'; 'Alia Atlas'
Subject: [i2rs] WG LC for requirement documents (10/6 to 10/20/2015) -

draft-ietf-i2rs-protocol-security-requirements-01.txt
http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-requirements/

Sue Hares

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 15 Oct 2015 01:24:41 +0000

Hi, Sue,

Sorry, I am a bit confused — draft-ietf-i2rs-traceability finished WG LC over 4 months ago.

Looking at https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/history/ <https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/history/> you might recall:

2015-06-12	03	Susan Hares	IETF WG state changed to WG Consensus: Waiting for Write-Up from In WG Last Call
2015-05-26	02	Susan Hares	WG LC (5/26 to 6/9) for inclusion in requirements
2015-05-26	02	Susan Hares	IETF WG state changed to In WG Last Call from WG Document

And so did draft-ietf-i2rs-pub-sub-requirements BTW.

What is the goal of this new WG LC?

Thanks,

— Carlos.

> On Oct 6, 2015, at 8:16 PM, Susan Hares <[email-masked]> wrote:
> 
> http://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/ <http://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/>
> 
> http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-requirements/ <http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-requirements/>
> 
> http://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/ <http://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/>
> 
> http://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/ <http://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/>
> 
> Sue Hares
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i2rs <https://www.ietf.org/mailman/listinfo/i2rs>

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 14 Oct 2015 22:36:30 -0400

Carlos: 

Very good question.  You are correct traceability was WG LC 4 months ago (6/12/2015) and pub/sub (10/2/2015).  This fine work paved the way for the rest of the I2RS requirements to be completed. The NETMOD/NETCONF chairs know these drafts have reached WG consensus. 

However, the other components of the I2RS requirements for the I2RS protocol were not complete (I2rs security, I2rs ephemeral state).  This WG LC asks the WG to review all the I2RS requirements as a whole group to see that the whole package of requirements are consistent. This WG LC will not change the results of the pub/sub WG LCs, but other eyes may review and provide you with additional review comments (always good).  

The I2RS WG, NETCONF/NETMOD WG, and the early I2RS protocol design team have spent a great deal of time in July – September working through the other requirements for the I2RS protocol so this WG LC (10/6 to 10/20)  is for the WG to consider all the WG requirements at one time.  

The 10/7/2015 I2RS interim provided some initial work on an I2RS strawman for the I2RS protocol.  The 10/21/2015 I2RS interim will provide addition details on the strawman based on all of these requirements. 

Thank you for asking this question,

Sue Hares 

From: i2rs [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Wednesday, October 14, 2015 9:25 PM
To: Susan Hares
Cc: Jeffrey Haas; [email-masked]; Alia Atlas
Subject: Re: [i2rs] WG LC for requirement documents (10/6 to 10/20/2015) -

Hi, Sue,

Looking at https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/history/ you might recall:

Thanks,

— Carlos.

 <http://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/> http://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/

 <http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-requirements/> http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-requirements/

 <http://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/> http://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/

 <http://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/> http://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/

Sue Hares 

_______________________________________________
i2rs mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/i2rs> https://www.ietf.org/mailman/listinfo/i2rs

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 15 Oct 2015 08:24:05 +0200

Susan,

so let me state clearly once more that the ephemeral requirements
document seems to be incomplete:

  3.5.  Minimal sub-set of Changes to NETCONF

     Ephemeral-REQ-07: The minimal set of changes are: (TBD).

     Potential set: TBD

I assume you will need another WG last call once the missing pieces
have been filled in.

I am also not sure 'the NETMOD/NETCONF WGs have spent a great deal of
time' - I think it was more a design team that involves people active
in NETMOD and NETCONF.

/js

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 15 Oct 2015 11:39:54 -0400

Juergen:

Short answers:  

·         Yes, Ephemeral state will have to go through another WG LC after we complete section 3.5: Minimal components of the I2RS protocol. 

·         Yes, you are correct that it was interested parties in the NETCONF/NETMOD groups. 

Long-answer:  

The full scope of ephemeral state requirements seems to be coalescing, but it then important to reduce this long laundry list to a reasonable first cut.  This is what section 3.5 is supposed to provide. 

Can you provide any review the other components of Ephemeral state without the minimal requirements for NETCONF?  

I also would like aid in refining the minimal set of requirements for RESTCONF:

·         I have posted the question of whether "all-or-nothing" works for the I2RS agent which is the normal methodology for a NETCONF server. 

·         Where should we allow the ephemeral key word?  - at the Node level, module level 

·         Other questions have been raised on the tradeoffs between speed versus risk on “limited validation”?  Can we eliminate things for modules which most go fast?  Should we remove MUST statements or instance identifiers?  

All these things are part of reducing the total requirements to the minimal subset for NETCONF.  

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Thursday, October 15, 2015 2:24 AM
To: Susan Hares
Cc: 'Jeffrey Haas'; 'Carlos Pignataro (cpignata)'; 'Alia Atlas'; [email-masked]
Subject: Re: [i2rs] WG LC for requirement documents (10/6 to 10/20/2015) -

Susan,

so let me state clearly once more that the ephemeral requirements document seems to be incomplete:

     Potential set: TBD

     minimal changes.

I assume you will need another WG last call once the missing pieces have been filled in.

I am also not sure 'the NETMOD/NETCONF WGs have spent a great deal of time' - I think it was more a design team that involves people active in NETMOD and NETCONF.

/js

> From: i2rs [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Carlos 

> Pignataro (cpignata)

> Cc: Jeffrey Haas;  <mailto:[email-masked]> [email-masked]; Alia Atlas

> Subject: Re: [i2rs] WG LC for requirement documents (10/6 to 

> 10/20/2015) -

> Looking at  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/history/> https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/history/ you might recall:

> On Oct 6, 2015, at 8:16 PM, Susan Hares < <mailto:[email-masked]> [email-masked]> wrote:

>  < <http://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/> http://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/> 

> <http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-req

> uirements/> 

>  <http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-requ> http://datatracker.ietf.org/doc/draft-ietf-i2rs-protocol-security-requ

> irements/

> <http://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/

>  < <http://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/> http://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/> 

>  < <mailto:[email-masked]> mailto:[email-masked]>  <mailto:[email-masked]> [email-masked]

>  < <https://www.ietf.org/mailman/listinfo/i2rs> https://www.ietf.org/mailman/listinfo/i2rs> 

 

-- 

Fax:   +49 421 200 3103         < <http://www.jacobs-university.de/> http://www.jacobs-university.de/>

i2rs mailing list