Subject: [i2rs] I2RS requirements in YANG PubSub drafts for NETCONF, RESTCONF, HTTP/2

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 14 Oct 2015 03:48:13 +0000

We just posted two drafts in NETCONF.  These drafts technology specifications aiming to cover the requirements from I2RS as per:
https://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/
These drafts are:

(1)  Subscribing to YANG datastore push updates (updated)
http://www.ietf.org/id/draft-clemm-netconf-yang-push-02.txt

(2) Restconf subscription and HTTP push for YANG datastores (new)
http://www.ietf.org/id/draft-voit-restconf-yang-push-00.txt
   Draft (2) is new in that it:

*     proposes Restconf subscription and push mechanisms to continuously stream information from YANG datastores over HTTP

*     provides a mechanism to support static subscriptions so that an operator can stream updates over HTTP without Restconf

*     provides YANG model extensions to leverage HTTP/2 so that individual subscriptions can get custom treatment via their own HTTP streams.

If you are interested, please come over and follow the discussions in NETCONF.  Thanks!

- Alexander Clemm, Eric Voit, Alberto Gonzalez Prieto, Ambika Prasad Tripathy, & Einar Nilsen-Nygaard

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Thu, 15 Oct 2015 20:59:57 +0000

Hello all,

just as an FYI, "draft-clemm-netconf-yang-push" that we had posted in Netconf earlier this week (to cover I2RS requirements, as noted by Eric earlier) has now become "draft-ietf-netconf-yang-push-00".  The WG draft is now posted here:
https://datatracker.ietf.org/doc/draft-ietf-netconf-yang-push/

Kind regards
--- Alex

From: Eric Voit (evoit)
Sent: Tuesday, October 13, 2015 8:48 PM
To: [email-masked]
Cc: Alexander Clemm (alex) <[email-masked]>; Alberto Gonzalez Prieto (albertgo) <[email-masked]>; Ambika Prasad Tripathy (ambtripa) <[email-masked]>; Einar Nilsen-Nygaard (einarnn) <[email-masked]>
Subject: I2RS requirements in YANG PubSub drafts for NETCONF, RESTCONF, HTTP/2