Subject: Re: [Ibnemo] 答复: 答复: Defining a Common Model for intent

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Tue, 2 Jun 2015 13:17:37 +0000

Hi Yali,

Your understanding is correct. However, my main point is not whether one is better or worse, my point is that both views are complementary and necessary

Best, /PA

De: "zhangyali (D)" <[email-masked]<mailto:[email-masked]>>
Fecha: martes, 2 de junio de 2015 14:28
Para: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, Sue Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: 答复: 答复: [Ibnemo] Defining a Common Model for intent

Hi Pedro,

That’s very good for enumerating these two different viewpoints when discuss the layer of intent. Definitely, these two viewpoints are two important perspectives for intent representation.

I am not sure if my understanding is consistent with you, and I assume I have gotten what you said. So if my understanding is wrong, please point it out without any hesitation.

For viewpoint 1, intent is divided into hierarchical relationship according a specific implementation procedure which lower layers are completely used to fulfill the requirements of upper layers. At this point, the intent of lower layer serve as the implementation and the rendering layer by layer lead to the realization of highest layer’ intent. This confirms to implementation procedure of a specific affair, however, if we consider the responsibility of the whole layer, there are some intent just serve itself, i.e. A administrator want to do a backup line to ensure the stabilization. Another problem is that there may be some extra intent independent of present upper layer intent.
For viewpoint 2, intent is divided according to roles differentiation which have different knowledge, responsibility, etc. Users with different roles can express their intent separately, and different roles do not have the relationship of serve-client. All users with different roles have the liberty to express their own intent without worrying about what is the other users’ intent, even though the function is used by them in some specific affair. This classification give users with different roles liberty to express their intent which may involve brief vision or detailed function.

By comparing these two viewpoints, I think the classification of intent according to the difference of roles is a better way. Do you have same opinion or any comments?

Best Regards,
Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年6月2日 14:38
收件人: zhangyali (D); Susan Hares; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: 答复: [Ibnemo] Defining a Common Model for intent

Hi Yali,

let’s keep in the networking domain :-) I strongly believe that we need different levels or layers of intent. However, there are (at least) two different viewpoints:

If you follow the infrastructure view(which is where I feel more comfortable), I hope we agree that it is a completely different situation when you are designing a network element-by-element than when you are designing the network at a sub-domain level (for example levels in an IS-IS based network or areas if you use OSPF) or if you are defining the interconnections of a service provider’s AS (and dealing with BGP-4 policies) or if you are defining an end-to-end service. Although at the end, the upper layers will use all the features provided by the lower layers.

Now, I’m sure we can find the equivalent layering from a role point of view:

The user wants to access a service (for example a Web page), the provider of that Web page wants it to be served with the best quality of experience and so he chooses a specific provider – normally a CDN). The CDN provider will choose a given carrier to get access to the user’s service provider. The user’s service provider will dimension his network to fulfill a series of criteria. Within the service provider, the operators sitting at the Network Operations Centre will have to fulfill a series of KPIs, etc.

As you see, I’m more a ‘box’ thinker. However, if someone can complete the ‘role’ example we can compare both approaches and try to identify if we can do any mapping between the two views. Maybe we could come up at end with a set of common denominators we can use to continue this discussion.

Best,
/PA

De: "zhangyali (D)" <[email-masked]<mailto:[email-masked]>>
Fecha: martes, 2 de junio de 2015 05:52
Para: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]<mailto:[email-masked]>>, Sue Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: 答复: [Ibnemo] Defining a Common Model for intent
Nuevo envío de: <[email-masked]<mailto:[email-masked]>>
Nuevo envío para: <[email-masked]<mailto:[email-masked]>>
Fecha de nuevo envío: martes, 2 de junio de 2015 05:52

Hi Pedro,

Thanks for reviewing the draft and giving modification.

The question you have mentioned is a very important point for the abstraction of intent model. Maybe we can propose the transport market as a analogy.

1.       A customer wants to transport his goods from A to B. So his intent is getting his goods from A to B without carrying about how to do it. Then his intent is transferred to the transportation system.

2.       This system analyzes customer’s requirement, and choose a suitable way to complete the requirement. For example, the system choose truck as the means. So the intent of transportation system is transferring the goods with truck.

3.       The driver of this truck analyze the path from A to B, and choose a most appropriate path to complete this order which will save more time. So  the intent of driver may be transferring the goods with the least time. Then the driver will start the engine, step on the gas, etc.

From this analogy, the ultimate effect is the same, namely, transfer the goods from A to B. But the specific intent of different roles has some differences which depends on user’ role, knowledge, responsibility, etc. For example, transportation system is responsible for transporting goods, and he know the various ways. So he can form his intent by rendering the upper customer’s intent.

Supposing we divide users into different layers according to the implementation series, users in upper layer expresses his intent as what he want without having the knowledge about how to do it. Then the how procedure will be transferred to what in the lower layer according to knowledge and context. These transfer procedure lead to the completion of requirement. Same with the example in draft. Although the ultimate effect is same, the focus is different which will bring out the differentiation of intent.

This is just my immature opinion about intent. Do you think the differentiation of intent to complete the same thing is important and reasonable?

Best Regards,

Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年6月1日 17:15
收件人: Susan Hares; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Ibnemo] Defining a Common Model for intent

Hi,

A small clarification proposal for draft https://datatracker.ietf.org/doc/draft-xia-ibnemo-icim/ .

In section 2.4, I would leave the following as a paragraph

For example, in the network area the intent of end-users could be

safe connectivity between two sites which a technology independent

and device independent requirement. For business-based network

designers, the network connectivity can be selected which is device-

independent but technology specific. An example of the business-based

technology is the L3VPN.

And change:

For network administrators, intent can be

specific operations on a set of devices such as configuring IP

addresses on network servers in a data center.
To

For network administrators, intent can be <new>defining a network topology like a router connected to a firewall, connected to a load balancer and this to two L2 networks where WWW servers sit or specifying the</new> operations on a set of devices such as configuring IP addresses on network servers in a data center.

Rationale behind this is again, that intent should be anything that is invariant and that expresses what a network operator/administrator may need to do, as opposed to how he would do that, i.e. The router is a HW device from vendor X or a virtual machine running a specific routing daemon over a given data-path implementation.

Best, /PA
---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ D. Ramón de la Cruz,84
28006 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ D. Ramón de la Cruz,84
28006 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ D. Ramón de la Cruz,84
28006 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "zhangyali (D)" <[email-masked]>
Date: Wed, 3 Jun 2015 02:01:05 +0000

Hi Pedro,

I’m agree with you that the existence of both viewpoints is important, and they are reasonable under some circumstance. But could you add some statement  for why they are complementary?

Best,
Yali

发件人: PEDRO ANDRES ARANDA GUTIERREZ [mailto:[email-masked]]
发送时间: 2015年6月2日 21:18
收件人: zhangyali (D); Susan Hares; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: 答复: 答复: [Ibnemo] Defining a Common Model for intent

Hi Yali,

Best, /PA

Hi Pedro,

Best Regards,
Yali

Hi Yali,

Best,
/PA

Hi Pedro,

Best Regards,

Yali

Hi,

technology is the L3VPN.

And change:

Best, /PA
---

Technology Exploration -

---

Technology Exploration -

---

Technology Exploration -