Subject: [Ibnemo] Network user role definition and classification.

From: "Lifengkai (Fengkai)" <[email-masked]>
Date: Tue, 14 Jul 2015 02:36:28 +0000

Hi all,

>From the discussion in the mail list, I tend to draw the conclusion that people agreed on the concept for role-based intent.
Considering the further progressing of this technical field, I would like to start this thread for the network user role definition and classification.

For the work in the role classification related field, I think the followings sequenced steps are needed:

1.     Clear specifications of "role", which includes the definitions, attributes, features etc.

2.     Types of roles for classification, based on the definitions, example of roles provided by Bert and Sue from previous emails, working out the preliminary role type list.

3.     Detailed illustrations of one role type's intent as a starting point, from the role type list, choose one typical role type, and give the illustrations.

Any comments about the above proposed steps?

And the following is the text proposed, and welcome comments again.

Step 1: Role definition:

Role is a set of network user's responsibilities for specifying the scope of their intents. A network user's intent scope is for restricting the network user's corresponding desires and requirements. Network user's intent scope is unique and specific to the network users with a particular role.

The role specifies the network user's intent by taking two dimensions into account for role attributes. The first dimension is for functional abstraction and expressions. With this dimension, the network objects with which the network users want to interact and the intent expression would be defined or restricted. The second dimension is for the authorization and accessing control. With this dimension, the network users' authority or permissions for accessing to the network objects would be defined or restricted. The second dimension is controlled via an RBAC system which takes this role dimension into account.

The network user's role is constituted of object-attribute concept. With the two pattern concept, a network user can have access or no-access to specific attributes of specific object via intended abstractions and expressions

Through the role compositional semantics, one network user can be assigned with more than one roles to enjoy a broader scope for intent expression. Network user's role may not be explicit mutually exclusive, and the role overlapping part for different network users indicates that the network users share some same desires and requirements.

Step 2: Type list of roles:
Method: I want to categorize the network user role types by analyzing one typical organization's department organizational structure. Departments are grouped with the network users' same responsibilities and requirements.
         I have talked with people from China Unicom, which I chose as the concrete organization to analyze, and I will send out our initial output later.

Step 3: Concrete intent requirements:
      Method: I want to finalize a enterprise's Virtual Wide-Area Network intent requirements as an output, which falls into the use case section in https://datatracker.ietf.org/doc/draft-hares-ibnemo-overview/.

Thanks.

Best Regards,
Fengkai

---

From: "Lifengkai (Fengkai)" <[email-masked]>
Date: Fri, 17 Jul 2015 09:00:22 +0000

Hi all,

I would continue my steps for the role type list proposal. I think people are busy preparing the coming IETF conference, then welcome comments and thanks for sparing your time.

I had a discussion with people from China Unicom about China Unicom's organization structure, which is based on the division of functional units. From the discussion, we concluded the following six types of roles. I worked out the detailed descriptions of the specific roles and their responsibilities and requirements of the network according. Please give your comments and thanks again.

1.     Network infrastructure planer/constructer
Network infrastructure includes the physical hardware as well as inner running software used to transmit data, such as routers, switches, gateways, bridges, hubs, etc. People with this role type focus on the construction of network infrastructure to enable the network connectivity, communications, and service deployments. They build the network up from scratch or incrementally. They mainly following the three steps, 1) geographical design, determining the place for putting the network devices and interconnection between the network devices; 2) topological design, determining the size, topology of the network based on the capacity requirements and cost considerations; 3) network realization, interconnecting of the network devices. They cares about many parameters of the network devices, such as the capacity, performance, power consumption, price, volume/size, and so on. Based on the requirements and the network device parameters, the network infrastructure planer/constructer can work out the network deployments to satisfy the communication requirements.

2.     Network configurator
People with the network configurator role focus on the managements and configurations of the networks, which may come from 1) the basic network service requirements; or 2) the network solution requirements for customers (i.e. end-user, home user, group users etc.). They have access to the hardware and software of network devices (i.e. routers, switches, firewalls, DPI devices, DNS, etc.) that constitutes the networking infrastructure. The network devices may be from different vendors and the configurations vary from one to each other. Network configurator would want a vendor-neutral way or method to boot up or upgrade network devices, set up the AS/area/zone, basic routing protocols (i.e. RIP, OSPF, IS-IS, BGP, MPLS, etc.), basic connectivity service (i.e. L2VPN, L3VPN, TE, etc.), accessing control functions, traffic management, and so on.

3.     Network monitor
People with network monitor role focus on the status, exceptions, failure, performance, SLA monitoring of the network. The network monitoring may be for 1) the malfunction of the network devices, such as unreachability, physical device exceptions, routing exceptions, etc.; or 2) customers (i.e. end-user, home user, group users, etc.) requirements are not satisfied, such as unqualified performance, SLA violation, etc. The network monitor should be able to acquire related information from the networks. Network monitor would be able to trigger the connectivity testing, SLA parameters monitoring, collection of running time status, and so on. The network devices may be from different vendors, and the network monitor also needs a vendor-neutral way or method for the testing and information gathering.

4.     Network trouble fixer
People with the network trouble fixer role focus on the solution for network troubles encountered. Network trouble comes mainly in to categories, 1) malfunction of network devices; 2) unguaranteed of committed customers' requirements. For working out the solutions, the network trouble fixer need the ability to extract the debugging information, running time status, forwarding rules, system logs, statistics, configurations, etc. They also need the ability to install the configurations for fixing the trouble. The network devices may be from different vendors, and the network trouble fixer also needs a vendor-neutral way or method for the testing and information gathering.

5.     Network performance optimizer
People with the network performance optimizer role focus on the run time network performance optimization. Network performance optimizer works out the optimized solution for the traffic/flow forwarding path, bandwidth utilization, congestion avoiding, hot spot protecting, and so on. They mainly needs the running status, especially the performance parameters, such as delay, jitter, available/used/committed bandwidth, network element CPU usage and so on. They also need the ability to install the configurations for optimizing the network, such as traffic redirecting, content caching, data migrating, etc. The network devices may be from different vendors, and the network performance optimizer also needs a vendor-neutral way or method for the testing and information gathering.

6.     Network business designer
People with the network business designer role focus on the wrapping up the basic network functions to better support the network requirements of the customers (i.e. end-user, home user, group users, etc.). The network business designer would provide the case-by-case network service by putting or organizing a series of standard network functional building blocks together via network programming. The programmability of networks may include the control of individual network devices as well as whole network deployment consideration. Network business designer may care about the generation of forwarding rules, handling actions and SLA parameter for specific flows. These may be used for the virtual network isolation for different tenants, packet forwarding/dropping, traffic steering, bandwidth guaranteeing, metering, and operations for specific value added service handlings.

Best Regards,
Fengkai

From: Ibnemo [mailto:[email-masked]] On Behalf Of Lifengkai (Fengkai)
Sent: Tuesday, July 14, 2015 10:36 AM
To: [email-masked]
Subject: [Ibnemo] Network user role definition and classification.

Hi all,

Step 1: Role definition:

Thanks.

Best Regards,
Fengkai