Subject: [iccrg] ICCRG meeting minutes

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Apr 2016 17:14:03 -0400

Hi all,

The minutes of the ICCRG meeting at IETF95 are now posted
<https://www.ietf.org/proceedings/95/minutes/minutes-95-iccrg>. Please send
corrections to the list or to the chairs.

Thanks much, Gorry, for taking these down!

- jana

---

From: hiren panchasara <[email-masked]>
Date: Tue, 12 Apr 2016 15:15:30 -0700

> Thanks much, Gorry, for taking these down!

Thanks for the notes. 

It'd be awesome if I can get a clarification in following though:

From - Michael Welzl: TCP in UDP (draft-welzl-irtf-iccrg-tcp-in-udp-00)
Michael Tuexen: How do you ensure the right sequence of UDP packets and
TCP-in-UDP packets on the server side, when using multicore systems?
Michael: In our cases this worked.

Was there more discussed and is missed in the notes? Can Michael Welzl or
someone else elaborate?

Thanks in advance.

Cheers,
Hiren

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 13 Apr 2016 06:59:10 +0200

> On 13 Apr 2016, at 00:15, hiren panchasara <[email-masked]> wrote:
> 
My point was that some NICs distribute incoming packets to multiple
threads and that the TCP/IP and TCP/UDP/IP might end up in different
threads. So it is hard to ensure sequence preservation in that case.
If you only use a single thread, there might be no issue.

I think a couple of other agreed that this is an issue and we stopped
discussing it.

Best regards
Michael
> 
> Thanks in advance.
> 
> Cheers,
> Hiren
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg

---

From: hiren panchasara <[email-masked]>
Date: Tue, 12 Apr 2016 23:43:35 -0700

> I think a couple of other agreed that this is an issue and we stopped

I do understand the problem. I was wondering if there was any discussion
towards possible solutions specific to this draft/work.

Thanks for clarifying.

Cheers,
Hiren

---

From: Michael Welzl <[email-masked]>
Date: Wed, 13 Apr 2016 09:53:48 +0200

> On 13 Apr 2016, at 08:43, hiren panchasara <[email-masked]> wrote:
> 

Maybe my answer was written down too briefly, or the problem is that it didn't reflect my facial expression and overall reaction: in our case this worked because we didn't have a multicore system.
I'll fix the minutes to say: "in our case this worked, but we didn't have a multicore system".

I don't get the problem but I'm sure this only means that I don't understand enough about packet processing in multicore systems.

Cheers,
Michael