Subject: [iccrg] Clarification question on pantheon of Congestion Control

From: Gaetano Carlucci <[email-masked]>
Date: Sat, 23 Jul 2016 23:38:11 +0200

Hi Keith,

I wrote this email to the group already but I forgot to include you, so I
am sorry for the repetition.

I was following your interesting presentation last Thursday.

I think that Pantheon of Congestion Control is a great initiative towards
the definition of a common framework for the evaluation of different
congestion control algorithms.

I have a clarification question on the results. Is WebRTC media congestion
control the only one that, at the moment, is sending real video?

Thanks,

Gaetano Carlucci, PhD.
Politecnico di Bari.

---

From: Keith Winstein <[email-masked]>
Date: Sat, 23 Jul 2016 23:16:01 -0700

Hello Gaetano,

Yes, that is correct. You can see how we run it here:
https://github.com/StanfordLPNG/pantheon/blob/master/src/webrtc.py

We use the '--use-file-for-fake-video-capture' option to Chromium to run
the WebRTC sender in a virtual machine.

Best regards,
Keith

---

From: Gaetano Carlucci <[email-masked]>
Date: Sun, 24 Jul 2016 22:05:37 +0200

Hi Keith,

in this case we should consider that the video encoder dynamics might
influence the results.

For example the default video encoder in the last version of chromium (VP8)
does not send more than 2.5Mbps and less than 50kbps.

I think your framework might be also interesting for the rmcat working
group.

Best regards,

Gaetano Carlucci
Politecnico di Bari.

Il 24/Lug/2016 08:16, "Keith Winstein" <[email-masked]> ha scritto:

>> I have a clarification question on the results. Is WebRTC media
>> congestion control the only one that, at the moment, is sending real video?
>>
>> Thanks,
>>
>> Gaetano Carlucci, PhD.
>> Politecnico di Bari.
>>
>
>
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg
>
>