Subject: [iccrg] Proportion of the different TCP flavors

From: Kuhn Nicolas <[email-masked]>
Date: Thu, 7 Jun 2018 09:40:40 +0000

Dear all,

I am looking for pointers that assess the proportion of the different TCP flavors in deployed networks.
Do you have any ideas on how I could get that ?

Thanks for your help,
Kind regards,

Nico

---

From: Lisong Xu <[email-masked]>
Date: Sun, 10 Jun 2018 22:40:21 -0500

Dear Nico,

We did some measurement study on the deployment of different TCP 
congestion control algorithms a few years ago.  You can find our method 
and the measurement result in the following paper

"TCP Congestion Avoidance Algorithm Identification" on IEEE/ACM 
Transactions on Networking
https://ieeexplore.ieee.org/abstract/document/6594906/

Hope it helps.

Lisong

Associate Professor
Department of Computer Science and Engineering
University of Nebraska-Lincoln
http://cse.unl.edu/~xu

On 6/7/2018 4:40 AM, Kuhn Nicolas wrote:
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.irtf.org_mailman_listinfo_iccrg&d=DwICAg&c=Cu5g146wZdoqVuKpTNsYHeFX_rg6kWhlkLF8Eft-wwo&r=joaETqzHKAfUPgnpyOvXPA&m=fu34YVnl_zG6zC89zWIGs8o77sOQE2nPADiuWrgWtFo&s=XhsCwsewaFo0X_zYpn8ebUjijqsxH1VVZA0hqCHN-Fs&e=

---

From: Kuhn Nicolas <[email-masked]>
Date: Tue, 12 Jun 2018 13:26:57 +0000

Dear Lisong,

Thanks for the pointer that surely helps in my investigations.
That is the kind of information that I was looking for.

Did you recently re-run the tests to see if there are any changes?
Is your code available by any chance?

Thanks,

Nico

De : Lisong Xu [mailto:[email-masked]]
Envoyé : lundi 11 juin 2018 05:40
À : Kuhn Nicolas <[email-masked]>
Cc : [email-masked]
Objet : Re: [iccrg] Proportion of the different TCP flavors

Dear Nico,

We did some measurement study on the deployment of different TCP congestion control algorithms a few years ago.  You can find our method and the measurement result in the following paper
"TCP Congestion Avoidance Algorithm Identification" on IEEE/ACM Transactions on Networking
https://ieeexplore.ieee.org/abstract/document/6594906/

Hope it helps.

Lisong

Associate Professor

Thanks for your help,
Kind regards,

Nico

iccrg mailing list

[email-masked]<mailto:[email-masked]>

---

From: Lisong Xu <[email-masked]>
Date: Wed, 13 Jun 2018 23:09:04 -0500

Dear Nico,

No, we did not re-run it recently. You can find the source code of our 
tool at the following link.

http://digitalcommons.unl.edu/cgi/viewcontent.cgi?filename=0&article=1159&context=cseconfwork&type=additional

Feel free to contact me, if you have any questions about the code.

Lisong

On 6/12/2018 8:26 AM, Kuhn Nicolas wrote:
> *De :*Lisong Xu [mailto:[email-masked]]
> *Envoyé :* lundi 11 juin 2018 05:40
> *À :* Kuhn Nicolas <[email-masked]>
> *Cc :* [email-masked]
> *Objet :* Re: [iccrg] Proportion of the different TCP flavors
>
> Dear Nico,
>
> congestion control algorithms a few years ago.  You can find our 
> method and the measurement result in the following paper
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__ieeexplore.ieee.org_abstract_document_6594906_&d=DwMFAw&c=Cu5g146wZdoqVuKpTNsYHeFX_rg6kWhlkLF8Eft-wwo&r=8GgbmpxpPRnPS9z8_jUQhw&m=C5Jd9J7189wlQ5mw9gBfkhdfC_OYWkNf18lYKCX37X4&s=G2jcXXLdKFl2qkYPKVD3BdO0wdmWoQvj55578hu3pwo&e=>
> Hope it helps.
>
> Lisong
>
> Associate Professor
> http://cse.unl.edu/~xu <http://cse.unl.edu/%7Exu>
>
>     I am looking for pointers that assess the proportion of the
>     different TCP flavors in deployed networks.
>
>     [email-masked] <mailto:[email-masked]>
>